Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Can't get server list with new router


I just installed Xonotic. My router reboot every time xonotic search for servers list. I have a dir-601 n-150 dlink router. I have successfully played online with another connection. I tried opening some ports, but it didn't help. The firmware is up to date.
Can anyone suggest me where to start digging?

That's some abnormal behaviour there, I'd be contacting support and/or returning the router.
Maybe you can do a packet analysis with wireshark to see what step exactly makes the router crash. The master server request should be nothing too fancy/unconventional... Definitely a router issue though, even if the protocol is broken somehow your network hardware should be able to deal with that with more grace.

I once had a D-Link that also reliably crashed when many packets got through it at once. It turned out to be a too-weak power supply.

However, I do not recommend you to exchange the power supply by one with same voltage and more current, as that can also end up breaking your router entirely.

You should try this:

net_slist_queriespersecond 10

or even

net_slist_queriespersecond 5

on the game's console, which should fix the crashes.

Can you confirm that?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

So I have already contact Dlink support but i got no response for now. I'll tell you if they fix my problem.

I also changed my power supply and the command in game console. Nothing work ...

Thank you for your quick answer!

Vintre - You don't need to open any ports to get the server list and if your router is crashing when you do so - it is a bug (in the firmware) or a hardware issue.

I had a similar bug with a sh1tty Linksh1t wireless router. Called "support" who didn't know what to do with a customer calling with a bug report, never mind the Wireshark dumps I wanted to send. Ended up getting rid of the router and getting a device that supported DD-Wrt/Openwrt firmware. Now I've a new Asus & Netgear(s) with DD-Wrt and it always works.

Looks like the DIR-601 will even run DD-Wrt (an alternative and much better firmware than D-links.) See

If you want to learn about Wireshark you can see and to download it on any OS you've got.

Remember to start Wireshark first and then Xonotic in a Window (non-full screen) and capture for a min or so. Then when you call D-link you will have some amo to back your case. OR you can just try to replace the firmware with DD-WRT and see if the problemo goes away! I bet it does...

I'd love a dd-wrt device myself, but that's for routers, not modem+router combos... Sad.

Thank you evit for your solution. I will try it this weekend. Seem complicated but it's nice to have finally another solution.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] server denied rcon access ristiisa 3 246 11-20-2020, 09:53 AM
Last Post: ristiisa
  [NEED HELP] Decrease server log level falco 1 920 04-17-2019, 06:11 PM
Last Post: BuddyFriendGuy
  [NEED HELP] setting up server with custom maps le Bork 2 1,104 01-31-2019, 01:06 PM
Last Post: morosophos
  How display server list ? draikhin 2 1,071 01-21-2019, 07:26 AM
Last Post: draikhin
  [NEED HELP] can't join any server in the list psy31 2 1,534 11-02-2018, 10:37 AM
Last Post: psy31
  [NEED HELP] Multiplayer server listed twice - causes glitchy play Space Ace 4 1,541 08-10-2018, 08:55 PM
Last Post: Space Ace
  [SOLVED] Custom Server Downloads Castor 4 1,829 05-24-2018, 07:10 PM
Last Post: Castor
  [NEED HELP] Making a Private Server LordIrish 2 4,702 03-06-2018, 10:37 AM
Last Post: LordIrish
  [SOLVED] Can't connect to a server adem 2 1,820 02-23-2018, 06:49 AM
Last Post: adem
  [SOLVED] Servers list don't show any of servers Ketjow3 8 2,497 01-25-2018, 04:12 AM
Last Post: Ketjow3

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-