Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] Can't set 2k resolution

I recently got a new Laptop with a RTX 3070 and 2560x1600@165Hz resolution screen, so I would like to use this resolution within Xonotic, same as desktop res.
I cannot get it to work, I tried the menue way, console way, config.cfg, etc., way, - nothing works.
Xonotic always bumps me back to some 1536/1707x807 resolution.
I tried all the vid_width 2560, vid_height 1600, vid_desktopfullscreen 1,vid_netwmfullscreen 1, vid_restart stuff recommeded elsewhere in here, but to no effect other than game in lowres.

Console says the following on trying to force mode change (vid_width 2560, vid_height 1600, vid_restart):
You can see it says "Changing to.." but it ends up in the same low res mode. (big)
[Image: Xon-Mode-Change1.png]

Note 1, there seems to be a small pause where it has set resolution, showing (slightly) misaligned screen, which gets adjusted/scaled back to the aformentioned 1536x807 quickly.
Note 2, setting 1707x1067 works, but nothing higher.
Note 3, setting resolution to 2k and enabling window mode sort of works, but only shows upper left quarter of rendered image, rest is outside screen.

Any ideas?
Please, prettty please (Yes, I am way over my head)

This took me a while.
Solution is to NOT use Windows 10 Scaling to make "Text, Apps and other elements" appear bigger (Display Options).
Xonotic seems to take current resolution info from Windows which reports something mathematically related to native resolution und scaling factor, but not the actual native resolution.
Setting Scaling to 100% solves the issue.
I still think this is a serious bug that should be fixed.

Why does..

"vid_width" "2560"
"vid_height" "1600"

..not override the windows scaling settings when windows desktop is running in native 2560x1600?
It should take precendence, shouldn't it..

Please help with a fix, I am a monkey  now

There are several ways to be found on the internet via the Rightclick-menu on the executable (Properties, Compatibility, High DPI settings..) which all do not work for Xonotic.
It seems the application itself needs to be aware of DPI settings and allowing override ort something.
(At least so I read on superuser etc.)

[url=][/url] Can some developer please chime in?

I am sort of disappointed that no one felt inclined to reply.
This a Help & Troubleshooting post, isn't it?

Anyway, I am now changing Windows Scaling to 100% before launching Xonotic.
This works well enough, now that I have found it the culprit.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Can't hear the announcer voice anymore gianmarco 4 383 01-16-2024, 12:26 PM
Last Post: gianmarco
  [INVALID] Resolution can't be changed Majki 17 12,922 08-14-2022, 02:41 AM
Last Post: FAF
  [NEED HELP] How to set stretched res? Achille0072 8 3,021 07-05-2021, 05:48 PM
  [NEED HELP] Can't join anymore fenjrill 5 3,010 07-17-2020, 07:04 AM
Last Post: LegendGuard
  [NEED HELP] Sudden loss of sound in Xonotic, can not get it to return. SeveredinTwain 5 3,810 03-26-2020, 05:55 AM
Last Post: FAF
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 3,471 01-03-2020, 11:31 AM
Last Post: SpiKe
  [SOLVED] how do i set up netradiant bananovenc 2 3,114 12-27-2019, 02:04 PM
Last Post: bananovenc
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 7 4,293 12-25-2019, 03:34 PM
Last Post: illwieckz
  [SOLVED] Can't click on my name in XonStats TheChrississin 4 2,557 03-09-2019, 10:24 AM
Last Post: falco
  [NEED HELP] Xonotic reverts to Stereo sound after having set it to 5.1 STP_KITT 0 1,832 11-27-2018, 05:35 PM
Last Post: STP_KITT

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-