Create an account


Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tweaks for my netbook?

#1
I have an aoa150 netbook with an ubuntu based linux os called joli os. I just swtiched over from red eclipse (because you can't tweak).

First, how do I use tweaks, where do I put them, and do I just copy and paste?

Second, my netbook is pretty bad, so I need a CRAZY amount of tweaks.
Reply

#2
What do you mean with "tweaks" ?
If you mean that you found config files in this forum, you can put them in a file called autoexec.cfg (create it if it doesn't exist) in the same directory as that of config.cfg. On linux, that's in the .xonotic/data directory in your home directory. It's a hidden directory.
Reply

#3
I mean anything to put in autoexec.cfg which will increase my fps.

Here's what I already have:

cl_projectiles_sloppy 1
cl_playerdetailreduction 5
cl_gibs_lifetime 2
cl_minfps_fade 1337

r_motionblur 0.007000
cl_minfps_qualitypower 1337
r_motionblur_maxblur
cl_decals_fadetime 40
cl_decals_time 1
cl_decals_max 300
cl_decals_visculling 0
r_drawdecals_drawdistance 3000

cl_gibs_lifetime 2
cl_gibs_maxcount 30

cl_casings_bronze_time 24
cl_casings_maxcount 500
cl_casings_shell_time 24

cl_explosions_alpha_end 1

r_bloom_resolution 512

r_shadow_deferred 1

r_shadow_shadowmapping 1
r_shadow_shadowmapping_maxsize 768
r_shadow_shadowmapping_minsize 64

r_water 1
r_water_refractdistort 0.019
r_motionblur 0.100000
r_motionblur_maxblur 2
r_motionblur_bmin -0.5
r_motionblur_randomize 0

gl_max_lightmapsize 2048
gl_max_size 768
Reply

#4
r_sky 0 should get you more fps on some maps.
And if the server has sv_allow_fullbright 1 set then r_fullbright 1 might help fps as well.
<[-z-]> have you seen the documentary "happy"?
<Samual_> no
<Samual_> it sounds horrible
Reply

#5
As you did not provide much system info i did a quick google on the netbook model:
Intel® Atom™ processor N270 (1.60 GHz, 533 MHz FSB, 512 KB L2 cache)
512 MB onboard DDR2 533 MHz
Integrated Intel Graphics Media Accelerator 950
  • Microsoft* DirectX* 9 Vertex Shader 3.0 and Transform and Lighting supported in software through highly optimized Processor Specific Geometry Pipeline (PSGP)
  • Texture Decompression for DirectX* and OpenGL*
  • OpenGL* 1.4 support plus ARB_vertex_buffer and EXT_shadow_funcs extensions and TexEnv shader caching

Having a look here http://dev.xonotic.org/projects/xonotic/...quirements does indicate it will be very hard to get decent performance from that machine in Xonotic. None of the components in it is designed for games much more advanced then snake or solitaire - just so you dont get any false hopes of good render speeds.

First off, delete everything in that autoexec.cfg. the main part those tweaks are for a machine still decently gaming capable.
Now try thisin autoexec.cfg:
Quote:vid_dx9 1
vid_width 640
vid_height 480
exec effects-omg.cfg
cl_projectiles_sloppy 1
cl_playerdetailreduction 10
cl_gibs_lifetime 2
cl_minfps 60
cl_minfps_fade 1
cl_minfps_qualitymax 0.5
cl_minfps_qualitymin 0.1
cl_decals 0
cl_gibs 0
cl_casings 0
gl_max_lightmapsize 256
gl_max_size 256

Start it once, close and start again (just need to do this the first time after changing that autoexec).
The only thing i can promise is that after this, the game will look like ass (but hey, most "pro's" have settings with similar visuals.. so maybe not that horrible ,) If if's enough to make it playable or not, i don't know (and that's also very much personal preference what 'playable' fps is)

There's likely further tweaks that can be done to increase speed more, however is this dont get at least close, i dont think anything will do it.
Reply

#6
Ok, I did that and I have no lag (or maybe a little in a massive firefight), but everything's black (except for players and items), I can't see anything.
Reply

#7
Maybe try using OpenGL? Delete you config file again, take the stuff that TZork posted and get rid of the "vid_dx9 1" line and see if it works.... and hope your system doesn't explode.
ECKZBAWKZ HUGE LIST OF ACHIEVEMENTS GOES HERE....


Oh wait.
Reply

#8
Hope my machine doesn't explode? Is that a joke or are you serious, b/c I won't do it if you are.
Reply

#9
(02-11-2012, 12:43 PM)UncleSam Wrote: Hope my machine doesn't explode? Is that a joke or are you serious, b/c I won't do it if you are.

I suspect Lee_Stricklin is referring to garbled images on the screen.
Reply

#10
I removed it from my config, doesn't change anything, the landscape is all black.
Reply

#11
Is this a local game or on some server? if the latter, the map being played failed to download for some reason. If not its something odd.. you could try deleting/renaming your config "my documents/my games/xonotic/data/config.cfg" (winblows) "~/.xonotic/data/config.cfg" (lunix & smac) Also removing vid_dx9 from autoexec does NOT switch back to ogl, you have to change it to "vid_dx9 0" (just removing it keeps it saved / set to dx mode in config.cfg) If dx mode is the reason landscape fails, we need to know abt it (dx mode is mainly there to support intel igp's as they as slow as hell with opengl) so plz test "vid_dx9 0" and tell us if it helped or not.
Reply

#12
vid_dx9 0, nothing happens, landscape is black IN SINGLEPLAYER.
Reply

#13
(re)move the config.cfg and autoexec.cfg and try again. If it still refuse to work, perhaps try a newer (or older) auto-build.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Question Xonotic vs. Nexuiz on a netbook gamingwithnetbooks 8 8,784 03-15-2013, 09:13 AM
Last Post: gamingwithnetbooks
  Subtle Performance Tweaks Lee_Stricklin 6 7,299 12-15-2011, 07:09 AM
Last Post: Lee_Stricklin
  CRAZY tweaks Lee_Stricklin 5 6,430 11-15-2011, 06:12 PM
Last Post: Sarge999

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-