Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't get server list - wireless DC's

This is basically a continuation of (this thread). I downloaded Nexuiz1 and Xonotic last night after I saw the new Nexuiz on steam. I started doing the Nexuiz1 tutorial and once finished I clicked the server browser and it caused my router to stop broadcasting a wireless signal. Now both nexuiz and xonotic cause my router to stop broadcasting wirelessly nearly instantly upon starting. My router doesn't support DD-wrt. I have a Trendnet wireless N router. I have played many other games and this doesn't normally happen. I've tried changing the port number and forwarding that port on my router. The best looking option I have at this point is the suggestion from divVerent - setting "net_slist_queriespersecond" to something lower than the default of 20, maybe 5 or 10. I have been trying to do that but the game doesn't let me save that setting in the advanced options...go figure. I tried making a autoexec.cfg in the root folder and adding "net_slist_queriespersecond 5" but I lose my connection anyway and when I get in game it still says it is at the default setting of 20. Is there another way to change this setting? Thanks for any help in advanced. This game looks really cool, I used to play the unreal tournament series and this looks like a great "new" alternative.

Where exactly did you put the autoexec.cfg file? You have to put it in the data directory, either in your install directory or in your personal directory in your documents.

Does your router have any logging capabilities? See if you can get anything out of that.

Also, does the game work fine with a wired link?

The autoexec.cfg belongs in the data/ directory, next to your config.cfg.

I also will make this setting saved in future Xonotic versions.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

Sorry for the delay. I tested it with a wired connection and it still causes my router to stop broadcasting wireless and it doesn't show any servers. I also tried it on a different computer on my network, same thing. Will the autoexec actually change the paramater on a "locked" setting? I put it in the correct place yet when I go in game it still shows the same value. More help would be appreciated.

You can try adding a "quit" line (no quotes) in your autoexec.cfg to see if it's executed. The game should quit when you start it if everything is right.

I moved the autoexec.cfg from the route folder with the .exe to the data folder and it showed the changes in game. It didn't fix my problem, I tried net_slist_queriespersecond 1, net_slist_queriesperframe 1, net_slist_maxtries 1, net_slist_timeout 100 along with some other values. The only one that seemed to have any effect was net_slist_timeout. With net_slist_timeout at 1 both WAN and WLAN LED indicators instantly stopped flashing on the router. With net_slist_timeout at 100 the WAN led stayed solid while the WLAN flashed 2-3 with a few seconds between flashes before going off. That said, even when the WAN light was on my internet appeared to die regardless, but I figured I would mention it in case that gives you any ideas. I also want to note I didnt have a config.cfg file anywhere in the Xonotic folder, but maybe because that was on the new computer where I hadn't actually loaded into a map yet thus no config was created? Not sure. Thanks for the timely response and additional help.

I'm curious, if you change the various "net_slist_******** #" paramaters to extreme settings on your setup does it cause the internet to drop? It is possible my router is broken in some way, but I'd prefer to try more options instead of buying a new one when I'm not sure that is the problem.

config.cfg is created when the game is exited for the first time. To know where it's located, open the xonotic terminal (shift escape) and type:
which config.cfg
This will show you the path to it.

As for your net issue, can you see if your router has logging capabilities? I asked you this in an earlier post but it seems you didn't notice.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Can't hear the announcer voice anymore gianmarco 4 410 01-16-2024, 12:26 PM
Last Post: gianmarco
  [NEED HELP] Setup Dedicated Server to DL from Map Server mrhip 1 419 10-16-2023, 06:22 AM
Last Post: Freddy
  [INVALID] Resolution can't be changed Majki 17 12,977 08-14-2022, 02:41 AM
Last Post: FAF
  [NEED HELP] Can't set 2k resolution noteven 4 2,854 05-07-2021, 02:33 PM
Last Post: noteven
  [NEED HELP] Can't join anymore fenjrill 5 3,023 07-17-2020, 07:04 AM
Last Post: LegendGuard
  [NEED HELP] Sudden loss of sound in Xonotic, can not get it to return. SeveredinTwain 5 3,833 03-26-2020, 05:55 AM
Last Post: FAF
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 3,485 01-03-2020, 11:31 AM
Last Post: SpiKe
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 7 4,307 12-25-2019, 03:34 PM
Last Post: illwieckz
  [SOLVED] Can't click on my name in XonStats TheChrississin 4 2,560 03-09-2019, 10:24 AM
Last Post: falco
Photo [NEED HELP] How do I get this crosshair (photo) sovietcat 2 2,597 02-23-2019, 03:21 AM
Last Post: sovietcat

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-