Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Help a newbie with settings

#1
So I just started playing and I'm having trouble getting my settings right.

I'd like everything maxed out (I get >300fps with everything maxed) except whichever parts are particularly detrimental to my aim Smile
  • If someone stands in a particularly dark shadow I can't see them, if they have a dark model I can't see them at all. If I up the brightness everything just seems diluted and I still can't see people in shadows very well.
    I read in the beginners guide about "fullbright" - that would work wonderfully. How do I enable that?
    Otherwise is there a way to just disable shadows altogether? (Or make them less dark?)
  • Whenever I get hit this massive haze blurs everything to the point where I can't see, never mind aim. I fixed most of that by disabling "Extra post-process effects", but I still get what looks like dirt on the screen. Is there any way to disable that?
  • Really big explosions can make it hard to see - if someone comes at me spamming a rocket launcher I'm toast. Is there a way to lower rocket brightness and smoke?

I have very little experience with quake type consoles so if one of these needs to be solved with that I'll need step by step instructions.
Reply

#2
For fullbright enemy models, set your player model to "Mega Erebus" (that's the only one that is actually fullbright), then go to "model settings" in the Player Setup tab and force enemy models to yours. You can also force enemy colors to yours, I played without that until playing an minsta match on solarium against a light blue guy with a decent aim... so think about if you want to be able to tell one player from another by color or if you just want to see enemies everywhere.

The dirt on the screen... I thought there was a setting for that in the menu? After experimenting a bit, I was able to reproduce it. So the image gets enabled when gore effects are enabled. You can specify its intensity in the Player Setup tab under "HUD Editor", where you can play around with the values for "damage". I agree this can be very annoying. Thanks for pointing me to that, this will go into the manual eventually.

About the explosions I am not sure, I think you cannot set them exclusively via the menu, this would need cvar editing I suppose.

Oh, and also: Welcome! :o)

Edit: updated the basic basics thread accordingly, thanks!
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply

#3
Thanks! I got rid of the dirt on screen and switched to mega-erebus, that will fix most of my problems Smile

For setting enemies to your colors, which would you suggest would stand out against most maps? Bright green?
Reply

#4
Bright green or white, works best for me. Smile
Reply

#5
I use yellow.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply

#6
I would recommend you lock your maximum fps to 120 or even 60 (unless you have a 120hz screen). To do that, drop the console (~ or shift-esc) then type "cl_maxfps 120" (input and render runs in the same thread in Xonotic, so having a stable render speed means more predictable response).

You can also use the console to get rid of the hud splatter, but keep gibs, if you like. To do that open the console and enter "hud_damage 0"

Lowering particle quality can make the explosions less obstructive. There are also ways to turn off individual particle elements, like blood, smore, rain etc if one of those are especially irritating to you - type in "apropos particle" in the console to get a lost of relevant settings.
Reply

#7
I find 125 fps is the real deal. Anything can be a little bit jerky.
Reply

#8
Great tips, renabled gibs w/o hud damage thanks to tz's tip, but now my aliases aren't sticking. I made an alias that toggled gl_picmip_world but when I close the program the alias dissapears. How do I make it stick?

Edit: figured it out, just added it to the config file rather than just in the console:

alias tex "toggle gl_picmip_world 1 32; vid_restart"
Reply

#9
Don't add it to config.cfg, it will disappear as soon as you save your config. Just create a file called autoexec.cfg next to config.cfg and put your aliases in there Smile
Reply

#10
(07-31-2012, 10:07 AM)Mr. Bougo Wrote: Don't add it to config.cfg, it will disappear as soon as you save your config. Just create a file called autoexec.cfg next to config.cfg and put your aliases in there Smile

Awesome thanks, it did in fact dissapear Tongue
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEEDS INFO] Xonotic settings file on linux ArchBerrie 2 4,948 07-15-2021, 03:18 AM
Last Post: ArchBerrie
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 3,186 09-23-2020, 12:05 AM
Last Post: fabzor3
  Newb seeks help on Oilrig Pallama 7 4,677 10-08-2018, 09:39 PM
Last Post: illwieckz
  [NEEDS INFO] Need help with xonotic on andoird Arctic_fly71 3 3,201 01-17-2018, 07:23 PM
Last Post: Arctic_fly71
  [NEED HELP] Help cant play IdekehBruh 1 2,017 05-05-2017, 08:21 AM
Last Post: Mario
Information [META] Thread Prefixes for Help & Troubleshooting -z- 0 3,918 03-07-2017, 08:19 PM
Last Post: -z-
Sad [NEED HELP] Help with compiling. ImSoAwesome 2 2,988 09-06-2016, 02:54 AM
Last Post: ImSoAwesome
  [NEED HELP] Mapping help shanajer_ 1 2,777 08-04-2016, 05:30 PM
Last Post: end user
  [SOLVED] Gib Settings Danfun64 1 3,673 09-10-2015, 02:16 PM
Last Post: Smilecythe
  [SOLVED] Please help: -sessionid and an unique session name error anish01 2 5,283 05-10-2014, 03:30 AM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-