Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] NetRadiant startup error

Was trying to give mapping a go and I got stuck at getting NetRadiant starting. I'm new at this so I have no idea whats happening.

runtime error: Didn't find any valid game file
descriptions, aborting

GetLastError: The system cannot find the file specified

An unrecoverable error has occured.


Stacktrace is disabled on this compiler
Please report this error to the developers

What's your OS, where did you get NetRadiant?

Win7 64bit, I tried the one that came with Xonotic.

Does NetRadiant come in Xonotic's distribution?

Also, is that all of the error message?

I'm not sure what you mean with the first question, but it came along with the 0.6 files. Found at saved games/xonotic/mapping.

Error message, first it says:

Quote:Radiant failed to start properly the last time it was run.
The failure may be related to current global preferences.
Do you want to reset global preferences to defaults?


Either selection brings the error message in my first post.

There is an extra package for netradiant, check (

I don't know what you are executing... netradiant is not distributed with xonotic releases.

Also if this is netradiant you are executing, you need this package, because the game is released with dds textures and netradiant cannot read these.

These are the same files and the same problem, so something somewhere goes wrong. Am I supposed to merge that package with the Xonotic folder? (I did)

Did you put the pk3 file contained in the mappingsupport zip file in your personal home directory? Did you set up the game path in netradiant to the install directory?

(By the way, never work in the install directory, because it will get wiped if you use update scripts, people have lost work over this.)

Yes, well the .pk3 is in a lot of places now. I wasn't sure where it should be like I said I really don't know this routine.

No I haven't been able to do any set ups with the netradiant.

Oh, right... I don't know about windows, and even less about radiant... I really don't know what to say. Maybe a mapper can help.

Another alternative in mapping would be converting Blender files into Xonotic maps, I heard this was possible somehow. Of course I don't know how to do this, but the bottom line is that I can use blender without an issue.

You still need radiant for entity placement and caulk brushing.

Possibly Related Threads…
Thread Author Replies Views Last Post
Sad [SOLVED] Segmentation fault (HTTP error 422) at the end of the first map John 1 1,122 11-04-2022, 10:05 AM
Last Post: John
Question [NEEDS INFO] how to make the model smoother? (netradiant) Beylet 2 1,293 06-20-2022, 11:50 PM
Last Post: Beylet
  [NEED HELP] Netradiant, xonotic-mapping-support and maps dir? Gwlanbzh 1 1,526 02-02-2021, 06:57 PM
Last Post: AriosJentu
Heart [SOLVED] BUG IN NETRADIANT Kotangens 5 2,746 12-06-2020, 08:53 AM
Last Post: Julius
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 3,424 09-23-2020, 12:05 AM
Last Post: fabzor3
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 4,022 01-03-2020, 11:31 AM
Last Post: SpiKe
  [SOLVED] how do i set up netradiant bananovenc 2 3,438 12-27-2019, 02:04 PM
Last Post: bananovenc
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 7 5,174 12-25-2019, 03:34 PM
Last Post: illwieckz
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 1,650 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 1,702 04-24-2019, 10:41 PM
Last Post: Space Ace

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-