Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] NetRadiant startup error

#1
Was trying to give mapping a go and I got stuck at getting NetRadiant starting. I'm new at this so I have no idea whats happening.

Quote:radiant/error.cpp:123
runtime error: Didn't find any valid game file
descriptions, aborting

GetLastError: The system cannot find the file specified

An unrecoverable error has occured.

-----------

Stacktrace is disabled on this compiler
-----------
Please report this error to the developers
Reply

#2
What's your OS, where did you get NetRadiant?
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
Win7 64bit, I tried the one that came with Xonotic.
Reply

#4
Does NetRadiant come in Xonotic's distribution?

Also, is that all of the error message?
Reply

#5
I'm not sure what you mean with the first question, but it came along with the 0.6 files. Found at saved games/xonotic/mapping.

Error message, first it says:

Quote:Radiant failed to start properly the last time it was run.
The failure may be related to current global preferences.
Do you want to reset global preferences to defaults?

[Y/N]

Either selection brings the error message in my first post.
Reply

#6
There is an extra package for netradiant, check http://www.xonotic.org/download/ (http://dl.xonotic.org/xonotic-0.6.0-mappingsupport.zip)

I don't know what you are executing... netradiant is not distributed with xonotic releases.

Also if this is netradiant you are executing, you need this package, because the game is released with dds textures and netradiant cannot read these.
Reply

#7
These are the same files and the same problem, so something somewhere goes wrong. Am I supposed to merge that package with the Xonotic folder? (I did)
Reply

#8
Did you put the pk3 file contained in the mappingsupport zip file in your personal home directory? Did you set up the game path in netradiant to the install directory?

(By the way, never work in the install directory, because it will get wiped if you use update scripts, people have lost work over this.)
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#9
Yes, well the .pk3 is in a lot of places now. I wasn't sure where it should be like I said I really don't know this routine.

No I haven't been able to do any set ups with the netradiant.
Reply

#10
Oh, right... I don't know about windows, and even less about radiant... I really don't know what to say. Maybe a mapper can help.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#11
Another alternative in mapping would be converting Blender files into Xonotic maps, I heard this was possible somehow. Of course I don't know how to do this, but the bottom line is that I can use blender without an issue.
Reply

#12
You still need radiant for entity placement and caulk brushing.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 347 08-18-2019, 10:11 PM
Last Post: Lyberta
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 291 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 385 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 563 03-29-2019, 11:19 AM
Last Post: Freddy
  [SOLVED] linux compile/link error BuddyFriendGuy 3 1,488 11-27-2017, 08:55 PM
Last Post: Lyberta
  [NEED HELP] Netradiant compiling? Raxno 2 1,348 11-11-2017, 04:50 AM
Last Post: It'sMe
  [SOLVED] NetRadiant crashing (Xonotic 0.8.2, NR 1.5.0-20120301) munyul 2 1,597 07-09-2017, 11:21 AM
Last Post: munyul
  [NEED HELP] video glitches in netradiant on windows 10 fabzor3 2 1,095 05-26-2017, 02:09 AM
Last Post: PinkRobot
  [NEEDS INFO] Custom map - Host Error: Mod_MAP_Mode: not yet implemented teratorn 6 2,361 03-07-2017, 04:29 AM
Last Post: SpiKe
  [SOLVED] NetRadiant crash "Got to split the buffer" PinkRobot 7 2,573 08-27-2016, 06:16 AM
Last Post: PinkRobot

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-