Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Running Xonotic on Linux Mint

I just installed Linux Mint 17.2 Cinnamon 64 bit. Had some trouble with installing drivers for my gpu (HD 5450), but found a little guide online. Now i downloaded Xonotic to test out how it works on linux. The problem is i can't seem to start the game, i run in terminal and i get greeted with a message:

"You have reached this menu due to a missing or unlocatable content/data. You may consider adding -basedir /path/to/game to your launch commandline"

I believe the issue is in my gpu drivers, but i'm not sure since this is my first time using linux.
Hopefully someone can help me!

EDIT: Apparently the zip didn't get extracted completely so i had to mount it and copy paste the folder from it, But now i have a new problem, i can't run anymore, i allowed it to be executed as a program and still nothing. Tried executing through terminal, says permission denied even though i have root. Now i have no idea what could be wrong.

EDIT2: Figured out why i couldn't run anymore, every file with the name linux in it's name should be set to read and write which it wasn't by default. Game works now although the performance is not too satisfying on my Radeon HD 5450, around half of the fps i was getting on windows.

Hello, you can try to run as well, it might work better than the GLX version.

As for the AMD Catalyst drivers on Linux, they are often a source of problems.
Did you try the open-source radeon driver? It works very good with old AMD GPUs like yours.

First never run this game as root (or any other game)!
Second, there are permission flags, and you must set that the file can be executed.
'chmod u+x'
(So no idea how you broke it Smile)

However you can also resync the complete game directory (basedir) via the provided rsync script.
Check 'Xonotic/misc/tools/rsync-updater/'
Be aware that it deletes all modifications in your game directory (basedir).

Your user specific stuff is in $HOME/.xonotic/ so it's normally save to run the script.

I'm running Xon on Linux Mint XFCE 17 using AMD 10 5800 with no issues with both Radeon and AMD drivers although the FPS sucks but I haven't bothered fixing that as I haven’t had a change to play the game atm.
[MoFo] Servers - North America - Hosted in Montreal Canada - Admin DeadDred [MoFo]

I run Linux mint 17.2 Cinnamon 16 bit/Ubuntu the command I use is ~/Xonotic/xonotic-linux64-glx -basedir ~/Xonotic

Did it worked?

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEEDS INFO] Xonotic settings file on linux ArchBerrie 2 5,110 07-15-2021, 03:18 AM
Last Post: ArchBerrie
  USB Mouse input on Linux dagelf 1 2,330 10-07-2020, 06:14 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 1,696 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Missclick on Linux Mint Mate 19 RanDoom 4 3,172 04-23-2019, 01:41 PM
Last Post: RanDoom
  [NEEDS INFO] Linux install Old_Geekdad 7 4,685 01-16-2019, 06:03 PM
Last Post: Zoommair
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 9,664 04-19-2018, 02:42 AM
Last Post: cefiar
  [SOLVED] linux compile/link error BuddyFriendGuy 2 3,587 11-27-2017, 05:18 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 3,396 03-06-2017, 08:35 PM
Last Post: -z-
  [SOLVED] How do you open dat files on linux? Beagle 10 8,045 04-21-2016, 11:54 PM
Last Post: Beagle
  [SOLVED] Im to stupid to run NetRadiant under Linux HirnloserHering 3 4,435 08-13-2015, 11:51 AM
Last Post: SpiKe

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-