Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Game displays [x] joined the [y] team upon connecting

#1
I searched the gitlab page for this but didn't find it there or anywhere in here.

When I or other players join a server the game displays some messages in the bottom left corner of my HUD; usually:

[Player name] has joined the [BLUE or RED] team.
[Player name] connected.
[Player name] is spectating.

Since the player will always initially be spectating, the first line, claiming that the player joined a team, is wrong.
I play a regularly updated git build on this server (usually), and I've noticed this for about a month now (sorry, can't be more specific about the exact point in time this bug was introduced). While playing around a bit I noticed that changing my character model color in my profile while spectating also triggered the message (without me joining anything), however this only works the first time I change the colors in the profile.

This bug is a bit annoying because it makes is less obvious when someone joined a team. So if I'm currently playing and trying to concentrate on the game, the capital letters in BLUE or RED in their respective colors are a good way of letting me know that someone joined my team or the opponent's team without me having to check with the TAB key or look closely at the message (I can discern this by noticing it in my peripheral field of view, without actually diverting attention down to the message field). Because of this bug, however, I now have to either regularly check TAB or divert attention from the game to the message field so I can see if the message was caused by a joining player or a connecting player.
Reply

#2
This was an unfortunate side effect of me fixing the teamplay code in several steps. For some reason JoinBestTeam was called inside ClientConnect. I have no idea why someone put it there. It is fixed in the latest git.
Reply

#3
Okay cool, thanks.
I still see this after updating but I assume it's probably the server that needs to be updated for this to take effect.
Reply

#4
Yes. The message is server-side.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Question [NEED HELP] Certain maps crash my game :( flexo 2 1,175 4 hours ago
Last Post: Pendulla
  [NEED HELP] cant start the game/ session lock problem skyghost47 0 48 10-20-2020, 08:16 AM
Last Post: skyghost47
  [NEED HELP] Sound dissapears mid game mastablasta 0 101 10-01-2020, 12:27 PM
Last Post: mastablasta
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 11 26,573 09-09-2020, 02:04 PM
Last Post: dixius99
  [BUG] Rebound "R" key, still occasionally does "team say" anyways Cynical 2 671 06-27-2019, 08:54 AM
Last Post: Cynical
  [NEED HELP] View MOTD without connecting falco 1 830 03-26-2019, 04:35 AM
Last Post: _para
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 797 02-17-2019, 02:10 AM
Last Post: martin-t
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 2 1,148 01-06-2019, 05:15 AM
Last Post: SpiKe
  [NEED HELP] Custom Game Modes 3agle427 5 1,379 12-30-2018, 12:44 AM
Last Post: Lyberta
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 1,168 07-25-2018, 07:20 AM
Last Post: Bloodthorn

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-