Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[BUG] Graphics become really choppy and laggy on Level 18

#1
I've played Xonotic for years, starting with the older version 1.8.1 which never presented me with the issues I am facing with this newest version 0.8.2.
I have had no problem with the new version until I reached level 18 "oilRig" Deathmatch, in which my input lags less than 1 second very constantly, rendering gameplay virtually impossible. using weapons, jumping and moving is triggering significant lag. I checked my graphics settings in both the game by lowering the graphics, as well as lowering the settings in my Nvidia control centre, still to no avail.
I ruled out graphics issues by playing all older versions of Xonotic starting from 0.1.0.
I know this isn't because of my rig and it must be a bug of some sorts in this new release, since all other levels before level 18 work just fine with graphics settings on MAX, with the exception of a half second freeze during gameplay on some of the lower levels.
I will be playing the older version until this bug is found and fixed.
It is definitely the game and not my PC since all the older games work and the issue starts at level 18 playing version 0.8.2.
I previously posted under a similar name about this issue possibly being due to the new weapon models, and still no resolve.
I am starting to fear this fantastic game is being butchered. But I have a gut feeling this is some bug that needs to be patched.
Many thanks.
Dedicated Player
Reply

#2
The engine wasn't made for open maps like this, new weapon models might have hurt perf a bit too and i also think bot AI has gotten a lot better and more demanding (for sure in autobuild/git but i think some of those changes are in 0.8.2 already).

As for the fix, oilrig is most likely gonna be removed from 0.8.3, long term we hope to switch engines and languages to avoid these limitations. (Gradually, no big rewrites to calm down people who see "rewrite" and wanna scream "BAD IDEA" at the screen)
[Image: 30381.png]
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 3,351 04-19-2018, 02:42 AM
Last Post: cefiar
  [NEED HELP] Strange input lag and graphics lag in 0.8.2 mrdoklata 3 1,833 04-21-2017, 11:00 PM
Last Post: -z-
  [NEED HELP] Stuttery/Choppy Demo Playback Iokast 1 1,172 08-23-2016, 04:36 AM
Last Post: Smilecythe
  [SOLVED] Crash Upon Starting Second Level After Quitting First ehrenbrav 2 1,774 06-10-2015, 09:41 AM
Last Post: ehrenbrav
  [BUG] Stuck at level 21 of campaign mode simbian 4 2,734 02-20-2014, 04:43 PM
Last Post: Mr. Bougo
  [SOLVED] Change level settings in single player inini 3 3,202 02-24-2013, 05:23 PM
Last Post: Mr. Bougo
  [SOLVED] Texture corruption with Intel graphics zykure 9 8,107 12-16-2012, 04:41 AM
Last Post: adem
  [NEEDS INFO] Very choppy for some reason - please help Zorai 2 1,321 12-04-2012, 04:32 AM
Last Post: edh
Sad [SOLVED] Laggy while connect to servers tingxyu 7 4,057 08-31-2012, 11:59 PM
Last Post: tingxyu
  [SOLVED] Can't beat level 21 in singleplayer mode hhyloc 5 8,165 08-24-2012, 02:33 AM
Last Post: hhyloc

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-