Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Cant get latest version on Mac

I downloaded the auto updater and i followed the instructions (on my mac). When i type in ./ i get this error message:
rsync: on remote machine: --extended-attributes: unknown option
rsync error: requested action not supported (code 4) at clientserver.c(841) [sender=3.0.7]
rsync: read error: Connection reset by peer (54)
rsync error: error in rsync protocol data stream (code 12) at /SourceCache/rsync/rsync-40/rsync/io.c(603) [receiver=2.6.9]

As far as I am informed, the daily autobuild does only builds for Linux and Windows. For Mac, I use git compile. You can find the instructions how to do that here: (don't forget to install XCode as first thing if you haven't done so already)

This eats up more space and loads significantly slower (at least first time you connect to a server each time you start the game). But you're always on the bleeding edge of Xonotic development then and the game runs as fast as autobuilds do once you finished loading eventually.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


No, it is supposed to support OS X. You have a weird rsync version there. Will probably have to make a new autobuild downlooader package to fix that.

Please redownlooad the autobuild downloader and try again. The issue is that Apple decided to change the meaning of the -E option.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

Oh well then I failed at discovering that - I tried to set up the autobuild for my mac yesterday as well and couldn't figure it out. I'll have a look at it again.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


thanks that worked! XD <3

Possibly Related Threads…
Thread Author Replies Views Last Post
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 2,566 08-12-2020, 01:33 AM
Last Post: Kotangens
  [SOLVED] No stats for the player Ubuntu 19.04 - just don't use the flathub version Fiorentino 2 2,800 04-20-2020, 07:42 AM
Last Post: Fiorentino
  [SOLVED] Weird key hold issue with official version Bloodthorn 9 4,406 05-21-2018, 07:56 AM
Last Post: Bloodthorn
  [BUG] SDL version not loading, glx version buggy rendering Halogene 3 3,494 10-19-2017, 06:04 AM
Last Post: Freddy
  [NEED HELP] Netradiant Xonotic support version BuddyFriendGuy 0 2,518 04-27-2016, 04:36 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Dl' d new version, but still showing as 0.8.0 KingPimpCommander 1 2,445 10-13-2015, 01:07 AM
Last Post: Halogene
  [SOLVED] Remove translucent version text? cyborgamer 2 3,116 10-08-2015, 02:02 PM
Last Post: cyborgamer
  [SOLVED] Version 8.0 won't start on OSX Yosemite oger 12 13,649 07-04-2015, 12:28 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] NetRadiant fails to compile with latest nvidia driver Maddin 6 5,823 03-25-2015, 06:02 AM
Last Post: Maddin
  [SOLVED] Latest Autobuild Will Not Start No Matter What Orbiter Sunblast 8 7,504 10-05-2013, 08:15 PM
Last Post: Orbiter Sunblast

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-