Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] HELP: Linux Server Setup Issue

#1
Well hey everybody! I sure haven't been on these forums in a while, but I finally got around to setting up a Linux installation on my PC again and so of course that means I installed Xonotic in it, and btw I love the updates put into v0.5.

Only problem is, I can't get a server up and running! Last time my issue was that I had to set up port forwarding, but I know all about that now and have it set up properly; this time the issue appears to be that Xonotic is trying to use the loopback connection in my Fedora 15 installation.

Here is what has led me to believe this. When I went to set up port forwarding, I obviously needed to know my local IP adress, so I opened up a terminal and entered 'ip addr', which listed the following:

Code:
[luke@localhost ~]$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 6c:f0:49:e3:bb:6a brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:22:3f:05:2c:80 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.4/24 brd 192.168.1.255 scope global wlan0
    inet6 fe80::222:3fff:fe05:2c80/64 scope link
       valid_lft forever preferred_lft forever

Ok, great, so now I know what IP address to forward to. And Xonotic seems to take the IP just fine, but then I get this in the terminal for the server:

Code:
...
Server using port 26000
Server listening on address 192.168.1.4:26000
Server listening on address [0:0:0:0:0:0:0:0]:26000
execing server.cfg
...

If I launch up Xonotic and manually enter in the IP address and port, I can connect to the game and play in my server just fine, but of course nobody else in the world can, and I want to set up a server so a friend of mine who lives in Ireland can play with me (I live in the US). And going off of the ip addr list, what the game is choosing is to go with that loopback connection, which doesn't go anywhere.

So first of all, am I even interpreting this correctly, or is something else going on? And second, what can I do to fix the problem so I can run a public server again?
[Image: myvFI.png]
Reply

#2
Not sure what is going on there but did you try setting your net_address in your server cfg? it might be the solution but i'm just speculating here.

Code:
net_address


"network address to open ipv4 ports on if empty, use default interfaces)"

Code:
net_address_ipv6

"network address to open ipv6 ports on if empty, use default interfaces)"
<[-z-]> have you seen the documentary "happy"?
<Samual_> no
<Samual_> it sounds horrible
Reply

#3
Nope; tried both commands in my server.cfg and no dice.

What's weird is, I copied my Fedora Xonotic folder over to Windows and ran the server from there without changing a single thing--and it worked! So now I'm really confused...the setup is exactly the same on both OS's, yet for some reason the server just won't run non-locally from Fedora Huh
[Image: myvFI.png]
Reply

#4
Quote:Server listening on address 192.168.1.4:26000
That's not your loopback interface but wlan0.

That's what you need:
1. Forward port 26000 from your router to 192.168.1.4
2. Make sure that net_address is set to 192.168.1.4
3. Get to know what your internet ip is (your router knows this, http://whatismyip.org/ knows it too)
4. Let your friend connect on yourinternetip:26000
5. Have fun

In case you got a dynamic ip you might need to check your internet ip every time before you play with your friend, or use something like dyndns.
Reply

#5
(10-23-2011, 03:51 AM)asy7um Wrote:
Quote:Server listening on address 192.168.1.4:26000
That's not your loopback interface but wlan0.

That's what you need:
1. Forward port 26000 from your router to 192.168.1.4
2. Make sure that net_address is set to 192.168.1.4
3. Get to know what your internet ip is (your router knows this, http://whatismyip.org/ knows it too)
4. Let your friend connect on yourinternetip:26000
5. Have fun

In case you got a dynamic ip you might need to check your internet ip every time before you play with your friend, or use something like dyndns.

Thanks for the clear reply Smile

That's exactly what I'm doing, though. What I thought was the loopback interface was the "[0:0:0:0:0:0:0:0]:26000", not "192.168.1.4:26000". After running the server in Windows, however, I'm less certain this is a problem, because I get that exact same result, but the server runs through myinternalip:26000 just fine in there. Under Fedora, however, the only way to connect to the server is by entering 192.168.1.4:26000; entering my internal IP will not connect to the server, and obviously if my friend enters 192.168.1.4:26000 on his end, it will not work.

At this point I'm thinking I'll run the server on a Windows box and run the client on Fedora, but if possible I'd still like to get this figured out. It's probably some really simple switch I need to flip in my network settings and I'm just totally missing it... Tongue
[Image: myvFI.png]
Reply

#6
[0:0:0:0:0:0:0:0] is an ipv6 address. You don't seem to have ipv6 configured on your system so you don't have one (and don't need one for what you want to do).
You need to allow connecting to port 26000 in your fedora firewall too, read here how: http://www.techotopia.com/index.php/Basi...figuration
Alternatively you can try disabling it. As root user in console type:
Code:
/etc/init.d/iptables save
/etc/init.d/iptables stop
And to re-enable it (should be re-enabled after a restart anyways):
Code:
/etc/init.d/iptables start

I assume that with "myinternalip" you mean the ip you get from your isp?
Reply

#7
(10-24-2011, 02:50 AM)asy7um Wrote: You need to allow connecting to port 26000 in your fedora firewall too...

Blush DOH! Yep, that's exactly what I needed to do. Once I let wlan0 and port 26000 through the firewall, everything started working!

Once again, my server troubles were just from me being dumb Tongue

Thanks for helping get that cleared up!

And now that this is working, if you want to play some deathmatch (with jetpacks!!) just look for "LukeSkillz's Xonotic 0.5 Server"...I don't run it 24/7 but I try to keep it open whenever I'm home. Smile
[Image: myvFI.png]
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] server denied rcon access ristiisa 3 176 11-20-2020, 09:53 AM
Last Post: ristiisa
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 646 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Missclick on Linux Mint Mate 19 RanDoom 6 1,292 04-23-2019, 01:41 PM
Last Post: RanDoom
  [NEED HELP] Decrease server log level falco 1 878 04-17-2019, 06:11 PM
Last Post: BuddyFriendGuy
  [NEED HELP] setting up server with custom maps le Bork 2 1,055 01-31-2019, 01:06 PM
Last Post: morosophos
  How display server list ? draikhin 2 1,027 01-21-2019, 07:26 AM
Last Post: draikhin
  [NEEDS INFO] Linux install Old_Geekdad 7 1,599 01-16-2019, 06:03 PM
Last Post: Zoommair
  [NEED HELP] can't join any server in the list psy31 2 1,478 11-02-2018, 10:37 AM
Last Post: psy31
  [NEED HELP] Multiplayer server listed twice - causes glitchy play Space Ace 4 1,487 08-10-2018, 08:55 PM
Last Post: Space Ace
  [SOLVED] Custom Server Downloads Castor 4 1,745 05-24-2018, 07:10 PM
Last Post: Castor

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-