Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Audio issues with Linux

I'm currently using Debian as my distro. I have a 5.1 surround sound setup also. When listening to music I usually have the "Center" and "Surround Sound" speakers checked (to have stereo sound "upmixed" to surround sound.

However, I disable these options (via the GNOME sound applet). I try to enable 5.1 surround sound in the game but nothing comes out of the center speakers or rear speakers.

This is the output from the terminal.

Loading OpenGL driver
GL_VERSION: 4.2.0 NVIDIA 290.10 1
vid.mode.samples 0 1
Video Mode: fullscreen 1920x1080x32x0.00hz (4x AA)
S_Startup: initializing sound output format: 48000Hz, 16 bit, 2 channels...
SndSys_Init: using the ALSA module
SndSys_Init: PCM device is "default"
Sound format: 48000Hz, 2 channels, 16 bits per sample
CDAudio_Init: No CD in player.
Initial CD volume: 1
CD Audio Initialized
MQC Build information: xonotic-v0.5.0

What is your version of Xonotic? (just in case) 0.5 alright
What is the output when you go into the audio menu in Xonotic, select 5.1 and click apply? It works fine here in ALSA.
Can you post the output of aplay -L too?

Wanted audio Specification:
    Channels  : 6
    Format    : 0x8010
    Frequency : 48000
    Samples   : 2048
Obtained audio specification:
    Channels  : 6
    Format    : 0x8010
    Frequency : 48000
    Samples   : 2048

Is this under SDL or GLX? They may work a little differently soundwise.
I'm at least a reasonably tolerable person to be around - Narcopic

Both use ALSA, I don't think it matters.

(02-19-2012, 05:29 AM)Mr. Bougo Wrote: Both use ALSA, I don't think it matters.

I used to have issues with GLX in 0.1 preveiw, but not SDL. I think they interact with alsa differently.

/layman speculation

nexuiz and xonotic GLX always went silent for me after a few secs/minutes, use SDL executable

Wow, that's what did it. I launched the SDL version and I have surround sound working Smile


Well that's good then. It may be that some more troubleshooting can be done here to try and get the GLX version sound working correctly. It might be that the SDL version might perform better for you but maybe we can help someone else out in the process by resolving this sound issue?
I'm at least a reasonably tolerable person to be around - Narcopic

Perhaps SDL doesn't use alsa. Can we get a startup log from the sdl binary?

Maybe he's missing a surround51 pcm device in his alsa config (which is why I'd like to know what aplay -L shows)

mb updating of ALSA drivers should help?

Why would one do that instead of using package management? Surely this is a way to interfere with ubuntu's package manager.

Besides, the link you gave is for ubuntu, and OP uses Debian.

And it's probably a better idea to try to understand the problem before applying fixes at random Tongue

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEEDS INFO] Xonotic settings file on linux ArchBerrie 2 4,941 07-15-2021, 03:18 AM
Last Post: ArchBerrie
  USB Mouse input on Linux dagelf 1 2,242 10-07-2020, 06:14 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 1,594 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Missclick on Linux Mint Mate 19 RanDoom 4 2,958 04-23-2019, 01:41 PM
Last Post: RanDoom
  [NEEDS INFO] Linux install Old_Geekdad 7 4,380 01-16-2019, 06:03 PM
Last Post: Zoommair
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 9,394 04-19-2018, 02:42 AM
Last Post: cefiar
  [BUG] Command line typing issues teratorn 5 2,895 04-12-2018, 04:02 AM
Last Post: teratorn
  [SOLVED] linux compile/link error BuddyFriendGuy 2 3,461 11-27-2017, 05:18 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 3,299 03-06-2017, 08:35 PM
Last Post: -z-
  [SOLVED] Demo issues 0.8.1 Totally_Cool 2 3,164 06-03-2016, 12:45 PM
Last Post: Totally_Cool

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-