Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't turn right / multihead issues

#1
Hi all - has anyone gotten Xonotic working in a multi-head set up? I am trying under Linux with Xinerama, and so far I have it working across three screens except for one annoying issue - I can't turn right using the mouse!

Well rather I can turn right, but it stops at a particular angle. I can turn left no problems, but when I turn right again it stops at the exact same place. If I turn right *really* slowly then I can move past the sticking point, but that's not really practical in-game...plus it sticks again the instant I move right too quickly.

Pressing ESC to get back to the menu also exhibits the same problem - I can move the mouse cursor over the *left* half of the screen, but it's like there's an invisible barrier down the middle of the screen and the cursor is unable to cross it, so I can't click on anything on the right-hand side of the screen.

I'm assuming it's doing something weird like applying the geometry of one screen onto the other (the first screen is 600 pixels wide and the second is 1280, which is as good as half), so does anyone know anything about this? Is there any way to override the screen geometry? Is there any information at all about multihead Xonotic? I can't find much with Google.
Reply

#2
Does it work fine when windowed? Do you use glx or sdl?
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
Thanks for the reply. I'm using glx - sdl doesn't work at all, it grabs my mouse and keyboard and then ignores any input from them, so the only thing I can do is switch to a text console and kill it. But glx seems to work.

It behaves the same when in windowed mode. It works fine when run on a single screen, the problem only seems to occur when the output spans more than one screen and the middle of the window is not on the left-most screen.

What seems to be happening is that as the mouse moves around, it is warped back to the middle of the screen to ensure a continuous range of movement (which is normal.) The problem is the mouse movement is also limited to the window size, so the cursor doesn't accidentally fly out into another app and activate it when you click. But the size of this limited area seems to have been miscalculated, and it's using the size of the wrong monitor, instead of the size of the whole window.

Any ideas where in the code this is set? Maybe I can play around and come up with a solution.
Reply

#4
After looking at the code for a bit, I think I found a workaround! If you set vid_stick_mouse to 1 in the config file then the problem goes away!
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 4,766 04-19-2018, 02:42 AM
Last Post: cefiar
  [BUG] Command line typing issues teratorn 5 1,163 04-12-2018, 04:02 AM
Last Post: teratorn
  [SOLVED] Demo issues 0.8.1 Totally_Cool 2 1,793 06-03-2016, 12:45 PM
Last Post: Totally_Cool
  [BUG] Having some serious issues here Lee_Stricklin 8 5,859 01-24-2015, 12:55 AM
Last Post: Mario
Sad [NEED HELP] Connection issues/ Inactive netstat Totally_Cool 0 1,751 12-23-2014, 11:56 AM
Last Post: Totally_Cool
  [NEED HELP] Tearing issues since last update Halogene 0 2,150 01-16-2014, 05:28 AM
Last Post: Halogene
  [NEEDS INFO] 5.1 support and other issues with running under Windows 8 Lee_Stricklin 10 8,151 06-13-2013, 02:09 PM
Last Post: Mr. Bougo
  [SOLVED] Wierd ping issues. aa 5 3,726 03-27-2013, 03:27 AM
Last Post: Cyber Killer
Bug [SOLVED] Severe Vehicle Server Lag and other issues Squigger 1 2,428 09-08-2012, 11:35 AM
Last Post: tZork
  [SOLVED] Force model issues Micha 3 2,766 08-11-2012, 05:31 AM
Last Post: rocknroll237

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-