Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Mac OS X 10.8.2: No Sound

Hi Guys,

i'm using the latest release of Xonotic (0.6.0) on my 2012 MacBook Pro running OS X 10.8.2 (Mountain Lion). But I can't hear any sound. Playing music in iTunes works fine, also sound output from other Games (tested with Minecraft) works fine, only xonotic isn't "playing" any sounds, no matter if I play online or offline.

Is this a problem generally occurs with OS X 10.8.2 or on 2012 MacBook Pro?
And most important: How can I fix this issue? I played Xonotic on my WindowsPC before and I loved it.

PS: Xonotic works great on my Mac, the only thing not working is sound.

Are you using the SDL executable?

Also, what does your cmd prompt tell you. It should say if sound hasn't initialised.

Yes, I'm using the SDL executabele (At least I think so. I downloaded the .zip file from and unziped it. There was a .app file inside. I used that one) There Is no cmd promt showing up

Try to launch the game from a cmd prompt then.

In the app "Console" I found the following error:
08.10.12 21:24:25,904 xonotic-osx-sdl-bin[13853]: Error loading /Library/Audio/Plug-Ins/HAL/SeratoVirtualAudioPlugIn.plugin/Contents/MacOS/SeratoVirtualAudioPlugIn: dlopen(/Library/Audio/Plug-Ins/HAL/SeratoVirtualAudioPlugIn.plugin/Contents/MacOS/SeratoVirtualAudioPlugIn, 262): no suitable image found. Did find: /Library/Audio/Plug-Ins/HAL/SeratoVirtualAudioPlugIn.plugin/Contents/MacOS/SeratoVirtualAudioPlugIn: mach-o, but wrong architecture

And right after that error ist this error:
09.10.12 21:48:22,492 xonotic-osx-sdl-bin[798]: Cannot find function pointer New_SHP_PlugIn for factory 834FC054-C1CC-11D6-BD01-00039315CD46 in CFBundle/CFPlugIn 0x103b35a80 </Library/Audio/Plug-Ins/HAL/SeratoVirtualAudioPlugIn.plugin> (bundle, not loaded)

Doesn't seem to be the problem. (Deleted the plugin and tried again: same result as before deleting *sad*)

btw: how do i launch xonotic from a cmd promt? (I'm very new to Mac and UNIX)

Look for a quick howto on how to cd into a directory (cd is a command that means "change directory"). Then, cd into the directory containing the app file, and launch it by typing open (or whatever the name of the app file is).

EDIT: Do you have anything special installed that is audio-related?

I have some DJ-related Software installed (Ableton; Serato Scratch Live, Itch and DJ Intro)

Can you do a condump from when you start Xonotic? To do so, start Xonotic and open the Xonotic terminal by pressing shift escape. In there, type condump startdump.log. Then, type which startdump.log to see where the file was placed. Put the contents in here or on a pastebin.

Here's the file. Hope, this wil help.

Attached Files
.txt   startdump.log.txt (Size: 53.27 KB / Downloads: 4)

Weird, sound seems to work fine from Xonotic's point of view. Something must be wrong with your system, it might be due to interaction with weird drivers installed by your audio software... I really don't know anything about that.

You should seek support at Serato, tell them you're using a SDL-based game and show them the errors that appear in your system log.

But Sound works fine with ALL other Applications.....

Yet you get errors related to Serato when you start Xonotic, and Xonotic sees everything as being alright. Serato is quite probably interacting with SDL...

Do you have any other SDL application to test?

So uninstalling all Serato Software could be a solution? I'll check that.

I don't know. If their uninstaller is stupid (which is a possibility even for commercial software) it might leave components behind that still mess up your sound.

Try Battle for Wesnoth for example - it also uses SDL and see if you have sound there.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie

Sound works perfect when using Battle for Wesnoth

This is a complicated issue. You should PM merlijn about this, he's the only Xonotic user or staff I know who uses a Mac.

Just had a quick look at what's going on here, and it does seem that Serato is doing some weird interactions with Xonotic.

However I see 2 issues happening, of which I am unsure whether they are related or not. One of them is the issue regarding SDL and Serato that's been talked about earlier in this thread. The other appears to be with the libraries used for audio, that cannot be loaded. To quote your condump:

Quote:^7Trying to load library... "libvorbis.dylib" "/Users/martinwackerbauer/Applications/Xonotic/" - failed.
^7Trying to load library... "libmodplug.dylib" "/Users/martinwackerbauer/Applications/Xonotic/" - failed.
^7Trying to load library... "libogg.dylib" "/Users/martinwackerbauer/Applications/Xonotic/" - failed.

In order to debug this I'd like you to run the following commands in a terminal, I'll make it easy for you by supplying the full pathnames:

Quote:otool -L /Users/martinwackerbauer/Applications/Xonotic/
otool -L /Users/martinwackerbauer/Applications/Xonotic/
otool -L /Users/martinwackerbauer/Applications/Xonotic/
otool -L /Users/martinwackerbauer/Applications/Xonotic/

The otool command lists dependencies for these specific libraries, I'd like to compare those results to what I get - because I do just get sound on my 10.8.2 installation.
Before posting a reply, please read about the bikeshed.

Oof, I totally missed this. Thank you, merlijn.

I just did copy and paste and that's what terminal "replied": (first command worked, the other three seem to be in wrong context)

Martins-MacBook-Pro:~ martinwackerbauer$ otool -L /Users/martinwackerbauer/Applications/Xonotic/
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.4)
/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
@executable_path/../Frameworks/SDL.framework/Versions/A/SDL (compatibility version 1.0.0, current version 1.0.0)
/System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 12.0.0)
/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 227.0.0)
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 476.19.0)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 34.0.0)
/System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 677.26.0)
/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 949.54.0)
Martins-MacBook-Pro:~ martinwackerbauer$ otool -L /Users/martinwackerbauer/Applications/Xonotic/
/Users/martinwackerbauer/Applications/Xonotic/ is not an object file
Martins-MacBook-Pro:~ martinwackerbauer$ otool -L /Users/martinwackerbauer/Applications/Xonotic/
/Users/martinwackerbauer/Applications/Xonotic/ is not an object file
Martins-MacBook-Pro:~ martinwackerbauer$ otool -L /Users/martinwackerbauer/Applications/Xonotic/

I have XCode this cause the trouble?

speakers , sounds and music needs speakers on nerd computers.
volume , required to produce the sounds and music.
ask a nerd , nerds needs nerds to help nerds.
source code , sounds like something complex , but its just a movie.



heheheh , sorry , i hope u find ya problem :p
[Image: 227.png]

Something is obviously going wrong there with those libraries, which is very odd.

I'll give you a couple of commands that can help us further debug this issue:

Quote:ls -al Users/martinwackerbauer/Applications/Xonotic/
file /Users/martinwackerbauer/Applications/Xonotic/
file /Users/martinwackerbauer/Applications/Xonotic/
md5 /Users/martinwackerbauer/Applications/Xonotic/

Also for the sake of testing, could you extract the file somewhere else and run that - just to see if the issue persists?
Before posting a reply, please read about the bikeshed.

Terminal Output:
Martins-MacBook-Pro:~ martinwackerbauer$ cd /Users/martinwackerbauer/Applications/Xonotic/
Martins-MacBook-Pro:MacOS martinwackerbauer$ ls -al
total 49392
drwxr-xr-x 21 martinwackerbauer staff 714 9 Sep 13:00 .
drwxr-xr-x 7 martinwackerbauer staff 238 9 Sep 13:00 ..
-rwxr-xr-x 1 martinwackerbauer staff 201016 8 Mär 2012 libd0_blind_id.0.dylib
-rwxr-xr-x 1 martinwackerbauer staff 2615064 8 Mär 2012 libfreetype.6.dylib
-rwxr-xr-x 1 martinwackerbauer staff 19 8 Mär 2012 libfreetype.dylib
-rwxr-xr-x 1 martinwackerbauer staff 573968 8 Mär 2012 libjpeg.62.dylib
-rwxr-xr-x 1 martinwackerbauer staff 1362744 8 Mär 2012 libmodplug.1.dylib
-rwxr-xr-x 1 martinwackerbauer staff 18 8 Mär 2012 libmodplug.dylib
-rwxr-xr-x 1 martinwackerbauer staff 86104 8 Mär 2012 libogg.0.dylib
-rwxr-xr-x 1 martinwackerbauer staff 14 8 Mär 2012 libogg.dylib
-rwxr-xr-x 1 martinwackerbauer staff 625136 8 Mär 2012 libpng12.0.dylib
-rwxr-xr-x 1 martinwackerbauer staff 901800 8 Mär 2012 libtheora.0.dylib
-rwxr-xr-x 1 martinwackerbauer staff 17 8 Mär 2012 libtheora.dylib
-rwxr-xr-x 1 martinwackerbauer staff 584520 8 Mär 2012 libvorbis.0.dylib
-rwxr-xr-x 1 martinwackerbauer staff 17 8 Mär 2012 libvorbis.dylib
-rwxr-xr-x 1 martinwackerbauer staff 6512896 8 Mär 2012 libvorbisenc.2.dylib
-rwxr-xr-x 1 martinwackerbauer staff 20 8 Mär 2012 libvorbisenc.dylib
-rwxr-xr-x 1 martinwackerbauer staff 141544 8 Mär 2012 libvorbisfile.3.dylib
-rwxr-xr-x 1 martinwackerbauer staff 21 8 Mär 2012 libvorbisfile.dylib
-rwxr-xr-x 1 martinwackerbauer staff 649 8 Mär 2012 xonotic-osx-sdl
-rwxr-xr-x 1 martinwackerbauer staff 11622896 8 Mär 2012 xonotic-osx-sdl-bin
Martins-MacBook-Pro:MacOS martinwackerbauer$ file libogg.dylib
libogg.dylib: ASCII text, with no line terminators
Martins-MacBook-Pro:MacOS martinwackerbauer$ file libogg.0.dylib
libogg.0.dylib: Mach-O universal binary with 3 architectures
libogg.0.dylib (for architecture ppc7400): Mach-O dynamically linked shared library ppc
libogg.0.dylib (for architecture i386): Mach-O dynamically linked shared library i386
libogg.0.dylib (for architecture x86_64): Mach-O 64-bit dynamically linked shared library x86_64
Martins-MacBook-Pro:MacOS martinwackerbauer$ md5 libogg.0.dylib
MD5 (libogg.0.dylib) = 085a98a2b90c918c79cbb00b626a825a
Martins-MacBook-Pro:MacOS martinwackerbauer$ md5 libogg.dylib
MD5 (libogg.dylib) = 4b694e17c2d084186a5580c96e560f84

Extracting it somewhere you mean on another Mac or another place on my HDD?

For the test it is sufficient if you just extract the zip somewhere else on the same Mac.

I do see the problem now, but I don't have any clue what actually caused it. What's supposed to happen is that libogg.dylib (the general name which is loaded by the engine) is a symlink to libogg.0.dylib (the file name which actually has the library stuff, which can be versioned). Somehow that symlink got broken, which really is quite odd. The output for both the file and md5 command should be the same for both libogg.dylib and libogg.0.dylib.

Can you check what the contents are from the libogg.dylib file? It says it's just ASCII text, which could mean it has some useful information as to what caused this, so just try to cat that file.
Before posting a reply, please read about the bikeshed.

I just downloaded the .zip again and extracted it to the same place on my HDD as it was before, and this time I have sound!!!!! What might have caused the problem: I downloaded the .zip about a month ago on my PC (Windows) and extracted the files under Win7 using 7-Zip. The I moved the files over to my external HDD (wich is formated NTFS) in order of my change from PC to Mac. So maybe something didn't worked the way it should with that process, but hey, sound works great right now. Thanks a lot for your patience and your help

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] NO Sound in Xonotic-0.86-GLX FinBiteLeaf 3 337 03-18-2024, 07:49 PM
Last Post: bones_was_here
  [SOLVED] No sound in Xonotic Draena 6 2,807 11-20-2021, 05:54 PM
Last Post: Draena
  [NEED HELP] Sound not precached Leeloo 3 5,296 07-12-2021, 10:27 PM
Last Post: cushinga
  [NEED HELP] Sound dissapears mid game mastablasta 0 1,257 10-01-2020, 12:27 PM
Last Post: mastablasta
  [NEED HELP] Sudden loss of sound in Xonotic, can not get it to return. SeveredinTwain 5 4,151 03-26-2020, 05:55 AM
Last Post: FAF
  [NEED HELP] "Nasty" Sound when a lot is going on. Aguaumreal 0 1,802 10-13-2019, 03:27 PM
Last Post: Aguaumreal
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 1,686 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 2,806 03-29-2019, 11:19 AM
Last Post: Freddy
  [NEED HELP] Xonotic reverts to Stereo sound after having set it to 5.1 STP_KITT 0 1,927 11-27-2018, 05:35 PM
Last Post: STP_KITT
  [SOLVED] Character Sound Files Castor 7 4,843 06-05-2018, 05:22 PM
Last Post: Castor

Forum Jump:

Users browsing this thread:
2 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-