Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] netRadiant - Viewports no longer show and render trails instead (Linux, ATI)

Approximately three months ago I moved from Windows 7 to Linux openSUSE. I made sure that Xonotic and netRadiant are running well, which they did at the time and I even started working on a new map. But a while later after several package updates, I noticed netRadiant broke, and I couldn't find a solution ever since.

The issue is that all 2D and 3D viewports no longer render. I get "views to infinity" / trails in their place whenever I drag something around the screen, though between frames I also see pieces of what should be rendered sometimes. No other program or game on my machine has any similar issues... glxgears also shows fine. Using KDE with desktop effects disabled while running Radiant. I compile netRadiant from the Xonotic GIT. Here's a screenshot, I dragged my IRC window in front of netRadiant as a test:

[Image: 4rlnqbv3mvh5sth77bz_thumb.png]

The most likely cause is an update to the Linux video driver. I have an ATI card (Radeon HD 6800) with the proprietary driver for my distribution. It could be something else as well however. Please don't suggest downgrading the driver to test... I no longer have the rpm of the old driver, and even if I did I feel unsafe about playing with system packages. If anyone knows how to fix the problem or can suggest a safe way to test, please let me know what to try. It could also be an issue on netRadiant's end.
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)

I tried digging into the issue again, and made a surprising discovery; netRadiant renders properly again when desktop compositing is enabled. So as long as I leave desktop effects on, the viewports show as they should. I was disabling compositing for Radiant because I thought that could cause glitches... turns out it's the other way around Tongue

Odd fact: Some weeks ago when I was testing this issue, I toggled desktop effects on and off while in netRadiant, but the issue still happened. It's only now that running Radiant with effects on fixes the problem. Maybe someone keeps messing up the ATI driver each update and putting it back... or rather the X11 server?

This might be linked to another problem on my system; Youtube videos in FireFox play very slowly (lag / low framerate) when desktop compositing is disabled. So again, I NEED desktop effects to watch videos on YT. It seems that having them off causes rendering to be delayed in some circumstances. Very weird... but since I always want desktop effects on, this doesn't bother me normally. Still an issue that should be fixed otherwise.

In other news: netRadiant just crashed my system to the login screen a few minutes ago when I started it up, though it works fine again after restarting the computer. It generated a radiant.log file that might be useful, in case this is part of the same issue:

Started logging to /home/mircea/.netradiant/1.5.0/radiant.log
Today is: Tue Jan 15 15:29:32 2013
This is NetRadiant '1.5.0n-git-590aae4' compiled Jan 14 2013
Custom build
accelerator already in-use: <Primary>g
Processing .xlink file '/windows/D/Nexuiz/Xonotic_GIT/netradiant/install/global.xlink'
Processing .xlink file '/windows/D/Nexuiz/Xonotic_GIT/netradiant/install/'
OpenGL window configuration: colour-buffer = 32bpp, depth-buffer = 24bpp
GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: AMD Radeon HD 6800 Series
GL_VERSION: 4.2.11931 Compatibility Profile Context
GL_EXTENSIONS: GL_AMDX_debug_output GL_AMDX_vertex_shader_tessellator GL_AMD_conservative_depth GL_AMD_debug_output GL_AMD_depth_clamp_separate GL_AMD_draw_buffers_blend GL_AMD_multi_draw_indirect GL_AMD_name_gen_delete GL_AMD_performance_monitor GL_AMD_pinned_memory GL_AMD_query_buffer_object GL_AMD_sample_positions GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_stencil_export GL_AMD_shader_trace GL_AMD_texture_cube_map_array GL_AMD_texture_texture4 GL_AMD_transform_feedback3_lines_triangles GL_AMD_vertex_shader_layer GL_AMD_vertex_shader_tessellator GL_AMD_vertex_shader_viewport_index GL_ARB_ES2_compatibility GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_indirect GL_ARB_draw_instanced GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_
conventions GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_image_load_store GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_stencil_export GL_ARB_shader_subroutine GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_shadow_ambient
GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_snorm GL_ARB_texture_storage GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_
window_pos GL_ATI_draw_buffers GL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_meminfo GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_buffer GL_EXT_copy_texture GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_
shader_image_load_store GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_bptc GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bit GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_conditional_render GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_explicit_
multisample GL_NV_float_buffer GL_NV_half_float GL_NV_primitive_restart GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hint
Anisotropic filtering possible (max 16x)
Loaded Texture: "/windows/D/Nexuiz/Xonotic_GIT/netradiant/install/bitmaps/notex.bmp"
OpenGL window configuration: colour-buffer = 32bpp, depth-buffer = none
OpenGL window configuration: colour-buffer = 32bpp, depth-buffer = none
OpenGL window configuration: colour-buffer = 32bpp, depth-buffer = none
Unable to find default tag file /windows/D/Nexuiz/Xonotic_GIT/netradiant/install/ No tag support.
OpenGL window configuration: colour-buffer = 32bpp, depth-buffer = none
Loaded Texture: "textures/common/caulk"
Start writing prefs
saving global preferences to /home/mircea/.netradiant/1.5.0/global.pref
saving local preferences to /home/mircea/.netradiant/1.5.0/
Done prefs
filesystem shutdown
Shutting down OpenGL module...Done.
Closing log file at Tue Jan 15 15:29:43 2013
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)

I did a test on my laptop a while ago and could confirm it's because of the fglrx driver (the issue goes away with the radeon one). Curse fglrx... if only the open-source radeon driver could run 3D games too Tongue Since this is a general issue and not netRadiant I'll see how I can live with it until I can get rid of fglrx.
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)

Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Netradiant, xonotic-mapping-support and maps dir? Gwlanbzh 1 257 02-02-2021, 06:57 PM
Last Post: AriosJentu
Heart [SOLVED] BUG IN NETRADIANT Kotangens 5 345 12-06-2020, 08:53 AM
Last Post: Julius
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 5 1,385 09-23-2020, 12:05 AM
Last Post: fabzor3
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 1,217 01-03-2020, 11:31 AM
Last Post: SpiKe
  [SOLVED] how do i set up netradiant bananovenc 2 1,466 12-27-2019, 02:04 PM
Last Post: bananovenc
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 8 1,420 12-25-2019, 10:07 PM
Last Post: Lyberta
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 703 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 841 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 840 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] Missclick on Linux Mint Mate 19 RanDoom 6 1,403 04-23-2019, 01:41 PM
Last Post: RanDoom

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-