Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[FIXED] netRadiant fails to compile on openSUSE 12.3

#1
A few days ago I upgraded my Linux distribution (openSUSE 12.2 to 12.3). Now I'm trying to compile the latest netRadiant from Xonotic GIT, and noticed it fails with this error:

Code:
/usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: libgtkutil.a(cursor.o): undefined reference to symbol 'XWarpPointer'
/usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: note: 'XWarpPointer' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [install/radiant.x86] Error 1

Someone on IRC said it works for them and suggested I check libX11, so in case that matters I have version 1.5.0-4.2.1 of all libX11 packages as well as the file libX11.so.6.3.0. Anyone know why this compile error and how to fix it?
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)
Reply

#2
Fixed by divVerent in GIT, it was due to some pointer issue.
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)
Reply

#3
does radiant still crash when compiling a map? ... I had this problem on opensuse last year (im on mint now)
Reply

#4
(04-01-2013, 02:21 PM)hutty Wrote: does radiant still crash when compiling a map? ... I had this problem on opensuse last year (im on mint now)

Not that I know of. Already made a full map and no issues with q3map2.
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Netradiant, xonotic-mapping-support and maps dir? Gwlanbzh 1 75 02-02-2021, 06:57 PM
Last Post: AriosJentu
Heart [SOLVED] BUG IN NETRADIANT Kotangens 5 257 12-06-2020, 08:53 AM
Last Post: Julius
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 5 1,308 09-23-2020, 12:05 AM
Last Post: fabzor3
  [SOLVED] how can i get defrag entities in netradiant? bananovenc 5 1,091 01-03-2020, 11:31 AM
Last Post: SpiKe
  [SOLVED] how do i set up netradiant bananovenc 2 1,375 12-27-2019, 02:04 PM
Last Post: bananovenc
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 8 1,287 12-25-2019, 10:07 PM
Last Post: Lyberta
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 798 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 794 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 1,252 03-29-2019, 11:19 AM
Last Post: Freddy
  [SOLVED] Menu fails to load after recent update Bloodthorn 2 1,275 09-25-2018, 08:11 AM
Last Post: Bloodthorn

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-