Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[FIXED] netRadiant fails to compile on openSUSE 12.3

#1
A few days ago I upgraded my Linux distribution (openSUSE 12.2 to 12.3). Now I'm trying to compile the latest netRadiant from Xonotic GIT, and noticed it fails with this error:

Code:
/usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: libgtkutil.a(cursor.o): undefined reference to symbol 'XWarpPointer'
/usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: note: 'XWarpPointer' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [install/radiant.x86] Error 1

Someone on IRC said it works for them and suggested I check libX11, so in case that matters I have version 1.5.0-4.2.1 of all libX11 packages as well as the file libX11.so.6.3.0. Anyone know why this compile error and how to fix it?
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)
Reply

#2
Fixed by divVerent in GIT, it was due to some pointer issue.
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)
Reply

#3
does radiant still crash when compiling a map? ... I had this problem on opensuse last year (im on mint now)
Reply

#4
(04-01-2013, 02:21 PM)hutty Wrote: does radiant still crash when compiling a map? ... I had this problem on opensuse last year (im on mint now)

Not that I know of. Already made a full map and no issues with q3map2.
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 73 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 226 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 290 03-29-2019, 11:19 AM
Last Post: Freddy
  [SOLVED] Menu fails to load after recent update Bloodthorn 2 528 09-25-2018, 08:11 AM
Last Post: Bloodthorn
  [SOLVED] linux compile/link error BuddyFriendGuy 3 1,295 11-27-2017, 08:55 PM
Last Post: Lyberta
  [NEED HELP] Netradiant compiling? Raxno 2 1,213 11-11-2017, 04:50 AM
Last Post: It'sMe
  [SOLVED] NetRadiant crashing (Xonotic 0.8.2, NR 1.5.0-20120301) munyul 2 1,419 07-09-2017, 11:21 AM
Last Post: munyul
  [NEED HELP] video glitches in netradiant on windows 10 fabzor3 2 928 05-26-2017, 02:09 AM
Last Post: PinkRobot
  [BUG] xonotic-maps ebuild does not compile ZyX 0 855 05-01-2017, 10:10 PM
Last Post: ZyX
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 2,677 09-06-2016, 08:40 PM
Last Post: RedScale12

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-