Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Xonotic can't be played on fullscreen...

#1
Exclamation 
Hello,

I have installed the latest version of Xonotic (0.7) in my new Mac Book Pro (retina)...but whenever I launch the application I get stuck on this:    

The mouse pointer doesn't move downwards any further than the position it is in. So, I can't play on fullscreen and the worse bit: there isn't an option where I could disable fullscreen so that I may play it.
Reply

#2
(06-18-2013, 10:11 AM)Knyghtmare Wrote: Hello,

I have installed the latest version of Xonotic (0.7) in my new Mac Book Pro (retina)...but whenever I launch the application I get stuck on this:

The mouse pointer doesn't move downwards any further than the position it is in. So, I can't play on fullscreen and the worse bit: there isn't an option where I could disable fullscreen so that I may play it.

Shouldn't there be some switch to choose windowed mode instead of fullscreen somewhere in the settings screen?? Anyway, you can also disable fullscreen mode by opening the ingame console (Shift+Esc for me, you can change the key in the settings) and entering these commands:
Code:
vid_fullscreen 0
vid_restart

Alternatively, you could edit your config.cfg (under ~/.xonotic/data/) and change the vid_fullscreen setting accordingly.

EDIT: I didn't get that you can't even get to the settings screen when I wrote my reply. So maybe editing your config.cfg is the easiest solution to get rid of the fullscreen mode Smile
[Image: 9216.png] Web: YouTubeSoundCloudFlickrzykure.de[unconnected]
IRC: #uc.xonotic #xonotic #xonotic.de #xonotic.pickup
Reply

#3
Hmm that's odd. The problem appears to have fixed itself. Even before I could edit anything...But, I will post, if the problem still persists. Thanks for the advice.
Reply

#4
Exclamation 
The problem returned again and it's worseDodgy!

The fullscreen mode shows only 1/16th of the screen now:


   

What I did after the problem temporarily disappeared:
1. I edited the resolution to the maximum possible, assuming that the problem was gone for good. My biggest mistake so far...

Okay, I tried that typing that code you posted but that didn't work. Any other suggestions?
Reply

#5
(06-20-2013, 09:03 AM)Knyghtmare Wrote: The problem returned again and it's worseDodgy!

The fullscreen mode shows only 1/16th of the screen now:




What I did after the problem temporarily disappeared:
1. I edited the resolution to the maximum possible, assuming that the problem was gone for good. My biggest mistake so far...

Okay, I tried that typing that code you posted but that didn't work. Any other suggestions?

Ehrm okay, that's interesting...

Anyway, screensize is also controlled by cvars, so you can try to change them the same way - either via console, or by editing your config.cfg:
Code:
vid_width 800
vid_height 600
vid_restart
(Of course you don't need vid_restart in config.cfg)

Could you post your exact system specs here? I think this problem needs to be investigated more closely =)
[Image: 9216.png] Web: YouTubeSoundCloudFlickrzykure.de[unconnected]
IRC: #uc.xonotic #xonotic #xonotic.de #xonotic.pickup
Reply

#6
Okay, I have managed to solve the problem. I opened the config.cfg file in the userdata folder and resetting the width and height to 1440 and 900 respectively. But, what do you mean by system specs?
Reply

#7
System specifications: how your system is set up (hardware and software): OS, desktop/laptop, graphics card, screen resolution, ...
Reply

#8
Oh, okay:

Hardware:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP101.00EE.B03
SMC Version (system): 2.3f35
Serial Number (system):
Hardware UUID:

Resolution: 15-inch (2880 x 1800)

Software:

System Version: OS X 10.8.4 (12E55)
Kernel Version: Darwin 12.4.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name:
User Name:
Secure Virtual Memory: Enabled
Time since boot: 5:58

Graphics:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

Displays:

Color LCD:
Display Type: LCD
Resolution: 2880 X 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Anything else?
Reply

#9
Hehe, that's probably more than enough. I removed some info from your post just in case (serial number, UUID, full name).

Now we wait for zykure Smile
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Low FPS when using FullScreen mode TheLastCrawler 0 1,836 09-06-2015, 10:02 AM
Last Post: TheLastCrawler
  [SOLVED] Flickering when Fullscreen - Mac Mini OS X undone 9 9,680 11-27-2012, 03:45 PM
Last Post: undone

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-