Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] cant download map, black map area

New to the game. Running UbuntuStudio. Downloaded the game from the website. Unzipped and placed Xonotic folder in /home/jay. Run the game by a toolbar launcher with the command: /home/jay/Xonotic/xonotic-linux64-sdl

Every time I try to join a game online i get a black map area because I don't have the map. I was told they are supposed to download by themselves. I get ??? in the status bar near the bottom when it is trying to download. I read on here to do a comdump command after I was unable to laod a map. That file is attached. Any and all help would be greately appreciated!

Attached Files
.txt   1.txt (Size: 50.88 KB / Downloads: 5)

You seem to be having proxy issues. Apparently there's a gateway running ClearOS throwing an error page at you when Xonotic tries to download stuff. Note that Xonotic uses a special user agent and referrer, which has been a problem for some people behind firewalls before.

Talk to your network administrator.


@Mr. Bougo - I was afraid it was something to do with that. I live in an apartment complex that gives free wifi with access through an authenticaed proxy. It is setup through ClearOS. .......darn Sad

@Smilecythe - The default maps will load and play fine in online multiplayer. Just get a blank map with people running around when trying a non stock map. Same thing happened with Nexuiz but I thought it was from me not personally downloading and installing maps.

Thanks for the input guys.

You're saying that the game itself works though... That means only http seems to be affected so far.

I'm still not quite sure what the current problem is. That error page that's dumped in your log tells you to configure your browser with certain proxy settings. Can you try setting the environment variable http_proxy to what your ClearOS gateway expects? Libcurl should be honoring that. The http_proxy variable should be documented somewhere, look it up to see the format. You can then set it by launching Xonotic from a terminal in this way:
cd /home/jay/Xonotic
http_proxy='socks5://' ./xonotic-sdl
http_proxy='http://jay:password@' ./xonotic-sdl

If that doesn't work because of user agents or something else, perhaps you could try to run a local proxy of some sort to make the http queries Xonotic a little more friendly to your apartment proxy?

Can you make sure you have libcurl installed? IIRC, it does not automatically come with Ubuntu(Studio), try "sudo apt-get install curl" and check if it still won't work.

Edit: ah, I see from your condump that libcurl has successfully been loaded. Ok, then this is not the problem :o)
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Models, items, and sky black after 0.8.5 update htsm92 0 726 08-15-2022, 07:34 PM
Last Post: htsm92
  [SOLVED] Black and transparent elements in old maps h0tc0d3 1 941 08-01-2022, 03:24 AM
Last Post: h0tc0d3
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 2,994 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Help cant play IdekehBruh 1 2,115 05-05-2017, 08:21 AM
Last Post: Mario
  [SOLVED] invertigo black sky BuddyFriendGuy 6 4,432 01-11-2017, 02:21 PM
Last Post: BuddyFriendGuy
  [SOLVED] Map has some black things(?) Brot 3 3,246 10-29-2015, 03:22 PM
Last Post: Brot
  [SOLVED] Cant build bsp? Brot 1 2,415 08-23-2015, 08:04 PM
Last Post: end user
  [SOLVED] Mouse limited to reduced area at higher resolutions / DPI Ishatix 5 6,845 03-14-2015, 06:54 AM
Last Post: Mr. Bougo
  [FIXED] how to download and use the maps on this site? zwz 2 4,174 09-20-2014, 05:14 PM
Last Post: end user
  [SOLVED] Maps don't download in online play Divergence 4 6,208 10-19-2013, 12:21 PM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-