Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Xonotic is not working

when i try to enter the game the screen go black and the hard drive light is on all the time ( i gave the computer time to load the game, but nothing was happening ) help please Exclamation

Please provide some specifics about your situation. Operating system, CPU, GPU, how did you launch the game? Did you extract the zip file, and have you tried starting the game from a terminal to get some verbose output while it loads? Do you use the official version from this website?
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


sorry for the late reply...
my pc -
GeForce gtx 560 ( if it's needed, 1920x1080, 60Hz. driver version : 337.50 )
intel Core i3 2120, 3.30 GHz
8.00 GB RAM
operating system - windows 7 home premium 64 bit

i exracted the game in a dedicated file for it from the zip, not in the program file in c (or the downloads file ).
i needed to write at launch not enter ( i was tired, sorry )
when im launching the game the screen is black for as long as i let it
but some times the game works or the windows fail to load the game and crashes to desktop .
i tried to launch the xonotic dadicated exe (to see if it help, one time the game worked the other times not )
and now im trying to lunch it but it's says the file cen not be found ( i dont remember the exact note )
i downloaded it for this website
i tried to give the pc some input to see if something happend with no terminal and nothing, there was that time when it has load me in to a screen that saied that the game need a patch. all the rest of the time i did not.

Thank you for providing details.

If you launch the dedicated executable, you will start a dedicated server that runs in the background, which you might not even notice. If you start the client while the dedicated server is still running, the client will not start unless you specify another "home" directory for the client instance. So what I would like you to do to find out what is wrong is the following:

1) after having cleanly booted up, open the terminal (you can just type "cmd" after pressing the start button and hit "enter")

2) Navigate in the terminal to the folder where you extracted your Xonotic copy to (you can change directories with "cd" followed by a space and the directory name, so if the path to the extracted Xonotic directory is C:\Users\<yourusername>\Xonotic, you enter "cd C:\Users\<yourusername>\Xonotic")

3) Execute the Xonotic binary by entering the executable's name (probably something like "xonotic64.exe" or so, I don't have a windows around at the moment) and hitting enter. You can see what files are in the folder you are currently in by entering "dir", if you need to determine the name of the executable.

If the game does not start properly, could you post the output that the terminal shows you after it has crashed or you aborted it?
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


for some resone i click on the " xonotic-x64.exe " and it's work. the game runs fine, when in fact it did not .as of yet.... if i'll run into this problem again i'll post it.
(sorry....i did not understand how to execute what you wrote with the terminal and user name, but it dos not matter,for now )

Can you try what I say in my second post in this thread, with the "+vid_fullscreen 0" thing?

i don't have the option to show the shortcut section...can i do anything else?

You didn't follow the instructions, then. You have to create a shortcut first. I think you missed that step and went into the executable's properties directly. Create a shortcut to it, then go in the preferences for that.

sorry...i did it, it works. thank you very much!

That was just one step of the troubleshooting, though!

What you want to do now is try to see if you can configure a good resolution, and enable fullscreen. Apparently, the default fullscreen settings are your problem, but maybe it's just the resolution.

Hi . I downloaded the game and extracted but when i tried to run the sh. the pc is not showing anything !!!! I tried with all the files . PLS help.
Distro : linux mint 17
processor fx 6300
video : gt 610 1gb ram


Can you run the sh file from a terminal window and paste the output here?

You can try with both


Also, what video driver do you use? Open-source nouveau driver or nVidia proprietary driver?

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Sudden loss of sound in Xonotic, can not get it to return. SeveredinTwain 5 3,841 03-26-2020, 05:55 AM
Last Post: FAF
  [NEED HELP] Spacebar not working on Erbium Deathmatch. Pallama 2 2,289 09-24-2019, 03:44 PM
Last Post: Pallama
  [BUG] Fkeys F-keys F keys not working Mac OS Sierra 0.8.22 Space Ace 8 4,119 10-02-2017, 10:04 PM
Last Post: Space Ace
  [BUG] xonotic-maps ebuild does not compile ZyX 0 2,160 05-01-2017, 10:10 PM
Last Post: ZyX
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 3,304 03-06-2017, 08:35 PM
Last Post: -z-
  [SOLVED] Motion blur not working? Beagle 0 2,176 01-25-2016, 05:45 PM
Last Post: Beagle
  [NEEDS INFO] can not start xonotic (xubuntu 14.10) kamp 5 6,962 11-09-2014, 01:05 PM
Last Post: Mr. Bougo
  [SOLVED] Preferences not saved when playing portable Xonotic on USB? Matoro 2 3,702 01-04-2014, 07:04 AM
Last Post: Mr. Bougo
  [SOLVED] Stopped working after Kernel upgrade Indigo340 10 7,446 09-28-2013, 09:35 AM
Last Post: Indigo340
  [NEEDS INFO] How i Can Xonotic play on the second Monitor (not Main) Berputo 3 5,886 08-16-2013, 02:03 PM
Last Post: edh

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-