Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] can not start xonotic (xubuntu 14.10)

#1
Hi,

I can not start xonotic anymore.

I recently upgraded to Xubuntu Utopic.

Code:
$ ./xonotic-linux64-glx
Game is Xonotic using base gamedir data
Xonotic Linux 03:08:11 Jun  5 2013 - release
Current nice level is below the soft limit - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
couldn't exec quake.rc
couldn't exec default.cfg
execing config.cfg
couldn't exec autoexec.cfg
Client using an automatically assigned port
Client opened a socket on address 0.0.0.0:0
Client opened a socket on address [0:0:0:0:0:0:0:0]:0
Loading OpenGL driver libGL.so.1
GL_VENDOR: Intel Open Source Technology Center
GL_RENDERER: Mesa DRI Intel(R) Haswell Mobile
GL_VERSION: 3.0 Mesa 10.3.0
vid.support.arb_multisample 1
vid.support.gl20shaders 1
Received signal 11, exiting...
Reply

#2
Hm, that log doesn't seem very helpful. Do you know by chance how to use gdb?

Where did you get Xonotic from?
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
It was from http://dl.xonotic.org/xonotic-0.7.0.zip but for several days, the download link is broken.

after starting with gdb:
Code:
Loading OpenGL driver libGL.so.1
warning: Corrupted shared library list: 0x38cc490 != 0x38d0180
Reply

#4
(11-09-2014, 06:21 AM)kamp Wrote: It was from http://dl.xonotic.org/xonotic-0.7.0.zip but for several days, the download link is broken.

after starting with gdb:
Code:
Loading OpenGL driver libGL.so.1
warning: Corrupted shared library list: 0x38cc490 != 0x38d0180

Is it broken, really? For me it gets redirected to this link, but perhaps you get a dead one instead. I'll let the admins know.

As for the error in gdb, I'll ask other people. I don't know how to help :X
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#5
Please post output of "glxinfo". The issue may very well be in the graphics driver.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#6
As for the mirror issue, can you please issue either of these two commands and tell me what output you get?

Code:
wget --spider http://dl.xonotic.org/xonotic-0.7.0.zip
or
Code:
curl -I http://dl.xonotic.org/xonotic-0.7.0.zip
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Unabel to start xonotic in xubuntu 18.04 prateekgs555 1 445 12-25-2018, 12:16 PM
Last Post: Lyberta
  [NEED HELP] XUbuntu playing with drivers and now Xonotic doesn't start Bla1 10 1,763 05-15-2018, 10:00 PM
Last Post: Lyberta
  [SOLVED] Version 8.0 won't start on OSX Yosemite oger 12 9,171 07-04-2015, 12:28 PM
Last Post: BuddyFriendGuy
  [SOLVED] How can i make an icon to quick-start Lan-game ? Old Enzo 3 3,960 12-07-2014, 06:58 AM
Last Post: GoregeousGuy
  [SOLVED] Latest Autobuild Will Not Start No Matter What Orbiter Sunblast 8 4,791 10-05-2013, 08:15 PM
Last Post: Orbiter Sunblast
Bug [SOLVED] Cant start server in linux xxen0nxx 12 6,458 11-30-2012, 05:07 AM
Last Post: xxen0nxx
  [SUGGESTION] Xonotic and NetRadiant: Start Animated Model with trigger event? Soelen 4 3,322 05-28-2012, 01:58 AM
Last Post: Mr. Bougo
  [SOLVED] Xonotic fails to start under Debian Testing Kwisatz_Haderach 5 8,041 10-08-2011, 01:38 PM
Last Post: Kwisatz_Haderach
  [SOLVED] Xonotic fails to start in OSX 10.7 lion theShadow 3 4,416 09-01-2011, 03:54 AM
Last Post: Halogene
Bug [SOLVED] black screen and lockup on start noteven 3 3,139 07-23-2011, 06:03 AM
Last Post: noteven

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-