Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] No 3840x2160 "4K" support?

#1
I just built myself a new PC, and my love for Nexuiz/Xonotic made it one of the first games for me to install. But I can't seem to get the game to run at 3840x2160? Every other game I have installed runs perfectly fine at this resolution, but when I try in Xonotic, it just bumps me back to 2560x1440, even if I try to force it in the console and restart the video. What gives? I know DarkPlaces is a little older, but I had no problem forcing even vanilla Quake 3 to run at this resolution? Thanks for your time, guys. Let me know if you need my specs of dxdiag or anything.
Reply

#2
For what it's worth, I managed to get it running at 4k even though my monitor is 1080p (was testing video recording)...

Try setting it in console and restarting the entire game instead of restarting video.
[Image: 230.png]
Reply

#3
I'll give it a shot. Thanks brother.
Reply

#4
No luck. Sad
Reply

#5
I can actually reproduce this. If I try to set the resolution to 3840x2160, it sets it to 1600x900 although the resolution of the screen I tested is 1920x1080.

I've tried writing the value into config.cfg, via console and putting the cvars into autoexec.cfg.
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#6
(01-25-2018, 09:45 PM)Mirio Wrote: I can actually reproduce this. If I try to set the resolution to 3840x2160, it sets it to 1600x900 although the resolution of the screen I tested is 1920x1080.

I've tried writing the value into config.cfg, via console and putting the cvars into autoexec.cfg.

So at least I'm not the only one. lol.

Was hoping to find a solution... game doesn't look right forced out of native resolution.
Reply

#7
Maybe try vid_resizable 1 and disable v-sync in-game. Also, check the value of vid_desktopfullscreen, it might not be detecting things properly.
[Image: 230.png]
Reply

#8
(02-03-2018, 02:16 AM)Mario Wrote: Maybe try vid_resizable 1 and disable v-sync in-game. Also, check the value of vid_desktopfullscreen, it might not be detecting things properly.

I tried all three, and made sure the resolutions were in the .cfg file. Nothing. It still reverts to lower resolution 100% of the time. Sad
Reply

#9
AHA!!!!!!! I FIXED IT!!! The problem was Windows 10 scaling in Display Settings not playing well with Xonotic. I had the exact same issue in Enemy Territory: Quake Wars, and I had enough of this crap so I really dug into it... turns out it was the scaling. Sure enough, Xonotic worked equally as perfect after I fixed it for ET:QW! It's annoying having to reduce scaling to 100% every single time I want to play ET:QW or Xonotic, but the games look great in 3840x2160, so good enough for me! lol
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Netradiant Xonotic support version BuddyFriendGuy 0 1,037 04-27-2016, 04:36 PM
Last Post: BuddyFriendGuy
  [SOLVED] Problem with NetRadiant - shadertags.xml. No tag support. tobster 23 16,356 03-29-2015, 07:58 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] 5.1 support and other issues with running under Windows 8 Lee_Stricklin 10 6,922 06-13-2013, 02:09 PM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-