Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Help with a Model: OBJ textures missing

#1
So I'm working on another map, Lost Temple (purely assault), and I'm hoping to finish the work and be ready for the first compile when my new graphics card arrives (nVidia GTX-470 based). So I started mapping it out, I have the layout ready and some concept of doing this. One of the concepts is to create a terrain with model details. I'm using OBJ format since no MD3 exporter would work for me (Blender 2.55). So I've created first few elements today - the Temple (defenders' base), and a rock on which the temple would stand. The latter one was created in Blender, and is pretty high-poly (since I used the sculpting tool for this). However, when I import it into Radiant, the textures wouldn't show (however the UV was preserved).

I tried renaming the texture paths that worked in Blender into relative game paths (ie.
//xonotic-maps.pk3dir/textures/terrain01x/ground/ice01.tga → /textures/terrain01x/ground/ice01.tga), but it didn't work. How can I fix this?
(08-10-2012, 02:37 AM)Mr. Bougo Wrote: Cloud is the new Web 2.0. It makes no damn sense to me.
Reply

#2
If if only uses one texture, the simple fix is using the _remap misc_model key, like this: add a key to your misc_model named "_remap", enter its value as "*;some/texture-shader/youwant"
Blender has a rather low limit on how long material names can be, unfortunately, this often messes things up.
Another option is to use .ase instead of obj, as ase is a text-file its easy to correct the material names whit your favorite text-editor.
Reply

#3
(11-28-2010, 12:36 AM)tZork Wrote: If if only uses one texture, the simple fix is using the _remap misc_model key, like this: add a key to your misc_model named "_remap", enter its value as "*;some/texture-shader/youwant"
Blender has a rather low limit on how long material names can be, unfortunately, this often messes things up.
Another option is to use .ase instead of obj, as ase is a text-file its easy to correct the material names whit your favorite text-editor.

Will _remap work with a shader? I mean, ice01 _has_ a shader script.
(08-10-2012, 02:37 AM)Mr. Bougo Wrote: Cloud is the new Web 2.0. It makes no damn sense to me.
Reply

#4
no, its only works as a entity key. If it has a shader, its either referenced with the wrong name in the model, or the shader is broken.
Reply

#5
.obj models are text files as well. You can open them in a text editor.
Look for the line starting with usemtl.
Shader names should not include the file extension. They should be identical to the shader name that is used in the respective .shader file.

In your case, it should be something like this: usemtl textures/terrain01x/ground-ice01
(which is the shader name defined in scripts/terrain01x.shader)
Reply

#6
when I add the launchpad model in radiant, the textures do not show, but once I compile it and load it into the game, they do.

might this be what is happening?
Master of mysterious geometries

Imgur Gallery
Reply

#7
Hi all, I use this topic because i got similar problem using a .obj model inside Nexuiz/Xonotic.
First of all my question is : obj model needs UV map when i’m using only a texture for all the model ??? Yes or not, dunno because i going to be crazy for this model.

My problem is born when i tryed to export my noob creation : http://www.midiverto.net/images/2021.khe_Screenshot.jpg
and using it inside Nexuiz.
After compiling i gain this : http://www.midiverto.net/images/485nexuiz000002.jpg

The texture is missing Sad, i’ve tried to resolve the problem like Sev wrote but it doesnt work in my case.
Another problem is : wtf is the .mtl file obtained with the .obj file after exporting ???
Can anyone help me plz ???
[Image: bartucnexuiz.png]
Reply

#8
(12-10-2010, 09:48 AM)BARTUC Wrote: Hi all, I use this topic because i got similar problem using a .obj model inside Nexuiz/Xonotic.
First of all my question is : obj model needs UV map when i’m using only a texture for all the model ??? Yes or not, dunno because i going to be crazy for this model.

My problem is born when i tryed to export my noob creation : http://www.midiverto.net/images/2021.khe_Screenshot.jpg
and using it inside Nexuiz.
After compiling i gain this : http://www.midiverto.net/images/485nexuiz000002.jpg

The texture is missing Sad, i’ve tried to resolve the problem like Sev wrote but it doesnt work in my case.
Another problem is : wtf is the .mtl file obtained with the .obj file after exporting ???
Can anyone help me plz ???

Not being very knowledgeable on mapping, I can't help you much there, but I can answer your question on the .MTL's.
An .MTL file is a Materials definition for the .OBJ file. Basically, it stores info of the different surfaces in your mesh, such as reflectivity and color. The .OBJ reads this file and applies the properties listed there. It's a pretty important file, IMHO. You can find more info on .MTL's here.

Hope this helped! Smile
Reply

#9
Thank you very much for your infos ... ok one step is done Big Grin
[Image: bartucnexuiz.png]
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
Question [NEEDS INFO] how to make the model smoother? (netradiant) Beylet 2 1,287 06-20-2022, 11:50 PM
Last Post: Beylet
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 3,422 09-23-2020, 12:05 AM
Last Post: fabzor3
  [NEED HELP] Need old rifle model(solved) Kotangens 8 3,390 08-27-2020, 01:42 AM
Last Post: Kotangens
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 3,115 08-12-2020, 01:33 AM
Last Post: Kotangens
  [SOLVED] Textures don't load at other side of warpzone bananovenc 6 3,170 06-11-2020, 12:56 PM
Last Post: bananovenc
  [BUG] some textures won't load with git builds lister 2 2,569 01-17-2020, 06:09 PM
Last Post: LuckyStripe
  Newb seeks help on Oilrig Pallama 7 5,179 10-08-2018, 09:39 PM
Last Post: illwieckz
  [NEEDS INFO] Need help with xonotic on andoird Arctic_fly71 3 3,369 01-17-2018, 07:23 PM
Last Post: Arctic_fly71
  [NEED HELP] Help cant play IdekehBruh 1 2,137 05-05-2017, 08:21 AM
Last Post: Mario
  [SOLVED] Mortar model missing Dr. Midget 11 6,653 04-30-2017, 11:46 AM
Last Post: martin-t

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-