Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Error: "couldn't exec maps/courtfun.cfg"

Hey, I just "installed" Xonotic on Ubuntu 11.10. When opening the third single player level (CTF) only the basic outlines show up: [Image: Screenshot%20at%202011-11-24%2021%3A15%3A40.png]

Running from the command line (so that I can run it as root, it refuses to work otherwise) I find the following error in the output:
couldn't exec maps/courtfun.cfg

All files in the Xonotic folder (which I placed in /use/share/games) are 777.

What's going wrong? And how can I fix it?

2 questions:

How did you install Xonotic? (e.g., via some package manager or from the .zip file provided by the website or through an autobuild/git development checkout) .... and.. have you used Xonotic 0.1 or Nexuiz before? I bring this up because to me it looks like you PROBABLY have some old files in your data directory for Xonotic in this case (maybe you copied a config over from nexuiz for example), and that could possibly be one explanation.

Additionally, don't worry about the "couldn't exec maps/courtfun.cfg" thing -- that's completely normal... Still, could you pastebin your ENTIRE output from running the game for us? (either paste it into a code box or onto

The only other thing I can think of is either an engine bug (this can really almost only happen if you're on a development build) or an issue with your driver/graphics set up...

I suppose you got more interesting messages on the console. Please paste the whole. I expect some GLSL compile errors.

BTW, the couldn't exec message is fixed now.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

I downloaded the .ZIP through BitTorrent yesterday. Never had it installed before.

When running xonotic-linux32-sdl I receive:

When running xonotic-linux32-glx I receive: (My terminal didn't save unlimited scroll back as instructed, so the top I-don't-know-how-many lines are missing.)

When running xonotic.exe (which loads via Wine) my progress through the first two levels isn't accessed so I can't test the third level.

Thanks for the help! Smile

This problem also occurs on most multi-player maps.

I really have no idea here, specifically if you've never used Xonotic/Nexuiz before then it SHOULD work -- Also, your font doesn't seem to work properly either.. That's another thing which I have no idea why else it wouldn't work than having an old config/package in your user directory.

I'm sure if I was actually at the desktop I could figure it out, but I have no idea what to look for other than that.

What is your video card and which drivers do you use for it? (specific model/versions please) -- The only other thing I can think of would be some issue with your system. Curious, does everything work fine with other games?

Edit: Apologies for slower responses btw, been really quite busy over the holiday especially.

I have some sort of integrated Intel video.

Could I wipe the config info and start over? If so, how?

Well, your user directory should be in ~/.xonotic/ -- All you'd have to do is rename the .xonotic folder to .xonotic_backup (which essentially gets rid of the old folder to the game) so this way it starts clean and fresh.

If that isn't your user directory for whatever reason, go to the console in game (Shift + Escape to open it) and type the command:
which config.cfg
That'll show you what directory your config file is in.

Hopefully this would be a simple solution, if not I would probably need more specific information about your graphics. (additionally the other questions I asked in that previous post too.. like does it work with other games, etc etc)

Okay, so I removed both the program and the data folder and reinstalled.

Still no success.

How can I find my system specs to post? (I assume there's a terminal command that will list everything?)

The output of "glxinfo" should be good.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

glxinfo output:

Can you try with vid_gl20 0?

Can you try the command line option "-safe"?

Other than that - can you try a Gallium3D enabled driver?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Netradiant, xonotic-mapping-support and maps dir? Gwlanbzh 1 82 02-02-2021, 06:57 PM
Last Post: AriosJentu
Question [NEED HELP] Certain maps crash my game :( flexo 4 1,405 12-07-2020, 09:25 AM
Last Post: Ecthelion
  [NEED HELP] cl_gunalign doesn't seem to work on some servers/maps Aguaumreal 2 919 09-10-2019, 03:42 AM
Last Post: Aguaumreal
  [NEED HELP] setting up server with custom maps le Bork 2 1,102 01-31-2019, 01:06 PM
Last Post: morosophos
  [SOLVED] linux compile/link error BuddyFriendGuy 3 2,120 11-27-2017, 08:55 PM
Last Post: Lyberta
  [SOLVED] Xonotic load downloaded maps Bla1 3 2,940 10-01-2017, 06:11 PM
Last Post: Mirio
  [BUG] xonotic-maps ebuild does not compile ZyX 0 1,344 05-01-2017, 10:10 PM
Last Post: ZyX
  [NEEDS INFO] Custom map - Host Error: Mod_MAP_Mode: not yet implemented teratorn 6 3,067 03-07-2017, 04:29 AM
Last Post: SpiKe
Bug [SOLVED] troubleshooting how to install maps Eonman 2 3,200 03-06-2017, 10:14 PM
Last Post: -z-
  [SOLVED] Where do I put maps in Xonotic? greasem0nkey 12 21,008 02-19-2016, 03:53 PM
Last Post: Exibar

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-