Create an account


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Client fails to connect to server Crypto_DecryptPacket Failed?

#1
Hey,

I'm running server 0.5.0 and clients GIT and 0.5.0 stock and I'm getting a bunch of problems connecting to my 0.5.0 server.

When I try to connect on Xonotic Git and 0.5.0 client I see the client attempt to connect to server and then it (the client) just sits there and eventually drops from server. Server console says this crud:

Authenticated connection to x.x.x.x:41152 has been established: client is gbLgzXelYOW7alklaew5tplHpoFo+BmhAMo=@Xon//Ks, I am -@-
Crypto_DecryptPacket failed (not enough space: 9 bytes in, 65575 bytes out)
Crypto_DecryptPacket failed (not enough space: 9 bytes in, 65575 bytes out)
Crypto_DecryptPacket failed (not enough space: 9 bytes in, 65575 bytes out)
Client "unconnected" connection timed out
Client "unconnected" dropped
Authenticated connection to x.x.x.x:34604 has been established: client is gbLgzXelYOW7FasdfadfasplHpoFo+BmhAMo=@Xon//Ks, I am -@-
Client "unconnected" connection timed out
Client "unconnected" dropped
quit
Saving persistent data...
done!
url_fclose: failure in crypto_uri_postbuf

Any ideas on further investigations in to this?
Reply

#2
I'm a bit lost with your versions, is that when the client is 0.5.0 and the server is git? They aren't very compatible anymore, we'll need a new release to fix that.

(Sorry, this isn't very helpful, maybe there are workarounds for your specific issue but I'm not really informed about that)
Reply

#3
This MAY be caused by a rare case of packet delay/loss. Does it happen every time?

Also, from the messages, the "I am -@-" is likely a problem. Can you post output of "crypto_keys" on the server?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#4
I think I had a few buggy maps which were causing the issue. I've removed them and did a fs_rescan on the console and I'm all set.

Thanks!
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  I can't see my listen server on server list fnmain 1 460 10-07-2023, 07:28 AM
Last Post: Grimnack
  Server not visible on the server browser for others or me DankoLord 1 1,628 02-21-2023, 08:02 PM
Last Post: ballerburg9005
  BaI server | South American Xonotic server (located in Chile) z411 0 2,612 01-02-2022, 11:36 PM
Last Post: z411
  Full server tutorial start-2-finish with maps & config from live server xonotic.us.to ballerburg9005 0 6,338 09-03-2021, 10:21 AM
Last Post: ballerburg9005
  [NEED HELP] Server failed to open socket on address... Hexactinal 2 2,115 11-21-2020, 04:28 PM
Last Post: Hexactinal
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 4,743 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  Server error "Weapon stats writing failed: -404" FlufyBuny 2 2,733 04-08-2020, 02:41 PM
Last Post: jwabbitt
  [NEED HELP] Server dont appear in server browser abslimit 0 2,454 03-15-2020, 04:13 AM
Last Post: abslimit
  How to change server cfg on modified server veecho 4 4,051 04-24-2019, 08:15 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Server show on the browser list, but I can't connect! Professor 1 4,231 12-19-2018, 11:39 AM
Last Post: Professor

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-