Create an account


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Client fails to connect to server Crypto_DecryptPacket Failed?

#1
Hey,

I'm running server 0.5.0 and clients GIT and 0.5.0 stock and I'm getting a bunch of problems connecting to my 0.5.0 server.

When I try to connect on Xonotic Git and 0.5.0 client I see the client attempt to connect to server and then it (the client) just sits there and eventually drops from server. Server console says this crud:

Authenticated connection to x.x.x.x:41152 has been established: client is gbLgzXelYOW7alklaew5tplHpoFo+BmhAMo=@Xon//Ks, I am -@-
Crypto_DecryptPacket failed (not enough space: 9 bytes in, 65575 bytes out)
Crypto_DecryptPacket failed (not enough space: 9 bytes in, 65575 bytes out)
Crypto_DecryptPacket failed (not enough space: 9 bytes in, 65575 bytes out)
Client "unconnected" connection timed out
Client "unconnected" dropped
Authenticated connection to x.x.x.x:34604 has been established: client is gbLgzXelYOW7FasdfadfasplHpoFo+BmhAMo=@Xon//Ks, I am -@-
Client "unconnected" connection timed out
Client "unconnected" dropped
quit
Saving persistent data...
done!
url_fclose: failure in crypto_uri_postbuf

Any ideas on further investigations in to this?
Reply

#2
I'm a bit lost with your versions, is that when the client is 0.5.0 and the server is git? They aren't very compatible anymore, we'll need a new release to fix that.

(Sorry, this isn't very helpful, maybe there are workarounds for your specific issue but I'm not really informed about that)
Reply

#3
This MAY be caused by a rare case of packet delay/loss. Does it happen every time?

Also, from the messages, the "I am -@-" is likely a problem. Can you post output of "crypto_keys" on the server?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#4
I think I had a few buggy maps which were causing the issue. I've removed them and did a fs_rescan on the console and I'm all set.

Thanks!
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  Latest Beta Server evit 1 318 04-02-2021, 04:06 PM
Last Post: end user
  Server does not start saddesad 2 312 11-25-2020, 04:39 AM
Last Post: saddesad
  [NEED HELP] Server failed to open socket on address... Hexactinal 2 337 11-21-2020, 04:28 PM
Last Post: Hexactinal
  Server Hosting Issue Saevus 3 956 11-11-2020, 02:53 PM
Last Post: :[:{b_e*r^f}:]:
  Docker Xonotic Dedicated Server ich777 15 3,427 10-08-2020, 11:15 AM
Last Post: BuddyFriendGuy
  BuddyFriendGuy Fun Server BuddyFriendGuy 22 8,837 10-08-2020, 11:14 AM
Last Post: BuddyFriendGuy
Rainbow Kotangєns' independent server Kotangens 2 651 10-07-2020, 05:08 AM
Last Post: L497
  RaspberryPi4 Server ablyveiled 2 1,050 08-19-2020, 10:36 PM
Last Post: ballerburg9005
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 2,655 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  [SOLVED] I can't create my server. Kotangens 11 1,670 07-22-2020, 04:42 AM
Last Post: Kotangens

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-