Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10%

#1
Question 
Hello!
I am currently running a nexuiz server on my raspberry pi 3 which uses at most 10% CPU.
Now I would like to switch to a xonotic server, so I cloned it from github, I ran ./all update -l best, compiled it with ./all compile -r dedicated and now I run it with ./all run dedicated.
Everything seems to work fine, the only problem is that the server uses 40% of my CPU although it's only me vs a bot.


So my question is, did I do something wrong or is there something I can do to decrease the CPU usage?
Reply

#2
Have you tried it without bots and monitored the CPU?
Reply

#3
Right now if I run the server, no bots no players on it, it uses 35 to 50% of my CPU.
No clue what I am doing wrong...
And as I said, the nexuiz server with 10 bots on it never used more then 10 or maybe 15% of my CPU...
edit: was mistaken here it's a bit more then 10 to 15% with 10  bots but still way better then the xonotic server...
Reply

#4
Are you using the 0.8.2 release, or are you running one of the autobuilds?

0.8.2 has known CPU speed issues in certain cases, particularly with bots.

In the Xonotic directory, go into misc/tools/rsync-updater/ and run ./update-to-autobuild.sh to update the install to the latest autobuild version.

There's also a ./update-to-release.sh which will bring you back to 0.8.2 if you run it now, or to whatever the latest release version (eg: if 0.8.3 got released, you could run the sdcript and it'd get you 0.8.3).
[Image: 21975.jpg]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams
Reply

#5
tested both, doesn't change anything. uses 40% CPU on both...
but thanks for showing me those scripts, didn't know they exist.
Reply

#6
Anymore ideas?
Would love to host a xonotic server but right now it seems impossible...
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  LAN server console commands dbl 1 136 06-13-2019, 04:55 AM
Last Post: martin-t
  How to change server cfg on modified server veecho 4 472 04-24-2019, 08:15 PM
Last Post: BuddyFriendGuy
  Server error "Weapon stats writing failed: -404" FlufyBuny 1 226 04-13-2019, 04:36 AM
Last Post: It'sMe
  Dedicated server setup Rec0d 5 393 04-03-2019, 02:00 PM
Last Post: Rec0d
  South American Dedicated Server Professor 3 534 03-03-2019, 07:02 PM
Last Post: end user
Information [TUTORIAL] Xonotic Server behind OPNSense (and pfSense) gurbe 0 353 01-27-2019, 09:07 AM
Last Post: gurbe
  Xonotic server running behind UDP proxy not working doombringeroperator 2 507 01-07-2019, 02:23 PM
Last Post: doombringeroperator
  [NEED HELP] Server show on the browser list, but I can't connect! Professor 1 489 12-19-2018, 11:39 AM
Last Post: Professor
  Server Setup for Dummies litvinenkotea 7 4,129 12-08-2018, 01:20 PM
Last Post: tehjester78
  Local LAN Xonotic game server player Stats animatedjay 3 952 11-23-2018, 12:38 AM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-