Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Hard FPS drops while having 2 cpus active

#1
Hi guys,

I got a strange error which I can reproduce but I do not have a solution for that. My desktop system has 2 Intel Xeon cpus hyperthreaded running with Gentoo X86_84. So in fact there are 16 cores active.

When I play Xonotic with that configuration, I have every time, when I shoot or someone got fragged in my view, a huge FPS-drop from 300 to 70 or sth. like that. This results in a giantic lag so that the game is unplayable.

If I disable one cpu in the BIOS, there are no such problems, everything works fine.

Maybe somebody of you has a hint for me? I 'd be very grateful.

Regards,
vienna
Reply

#2
just guessing here ... try loweing your particle effects really low (or off) and turn off gibs ... does that help?

I don't know anything about cpus ... but narrowing the issue to a single effect might help
Reply

#3
Try to disable sound as well: start xonotic with the -nosound commandline parameter.
EDIT: that's the only part of xonotic that's multithreaded so it might be worth giving this a shot?

I vaguely remember someone having this issue a while ago, in nexuiz perhaps. Hm.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Jitter and FPS drops in 0.7 TourianTourist 4 3,813 08-14-2013, 12:20 PM
Last Post: edh
  [NEEDS INFO] Fps drops [xonotic-git][mesa-r600g-git] Bitiquinho 10 8,194 06-03-2013, 01:16 PM
Last Post: Mr. Bougo
Sad [NEEDS INFO] First Launch = Hard Reboot fr00ty_l00ps 9 5,599 10-04-2012, 11:56 PM
Last Post: Mr. Bougo
  [SOLVED] huge FPS drops - Engine changes? noteven 3 3,045 10-01-2012, 04:53 PM
Last Post: noteven
  [BUG] Major FPS Drops master[mind] 3 3,209 08-23-2010, 10:04 AM
Last Post: master[mind]

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-