Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error response from keygen server: Not allowed

#1
Exclamation 
Hi, when I try to use the server_linux.sh, I get the message on the thread subject.

I did the copy of the linux_server.sh to the /Xonotic directory and the server.cfg too.

This is a copy of the server_linux.sh executation: http://pastebin.com/NDvFYa6L

And here the server.cfg: http://pastebin.com/B48iAHt3


Thank you Blush
Reply

#2
Are you sure that your server.cfg is in the right place? It seems like it isn't.

The default server.cfg is in Xonotic/server, the right place to copy server.cfg is NOT Xonotic/. Make sure you read server/readme.txt, it's explained there. See the quoted paragraph below. But please read the entire readme, this is only an excerpt.
Quote:You will need to copy the right script for your system into your
Xonotic main directory, where the normal binaries are. You then need
to copy and ADJUST the config file which is called server.cfg. You
can copy it either into the Xonotic/data directory where the big
data*.pk3 file is or when running on linux or mac you can as well copy
it into a special directory named '~/.xonotic/data'.
After you have
setup everything and have adjusted the config file you can start the
server by running the server script.

As for the keygen error, I'm not sure. The keygen server will not generate more than one key per week per IP if I remember correctly. But it doesn't look like that's the problem.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
(06-23-2012, 05:37 AM)Mr. Bougo Wrote: Are you sure that your server.cfg is in the right place? It seems like it isn't.

The default server.cfg is in Xonotic/server, the right place to copy server.cfg is NOT Xonotic/. Make sure you read server/readme.txt, it's explained there. See the quoted paragraph below. But please read the entire readme, this is only an excerpt.
Quote:You will need to copy the right script for your system into your
Xonotic main directory, where the normal binaries are. You then need
to copy and ADJUST the config file which is called server.cfg. You
can copy it either into the Xonotic/data directory where the big
data*.pk3 file is or when running on linux or mac you can as well copy
it into a special directory named '~/.xonotic/data'.
After you have
setup everything and have adjusted the config file you can start the
server by running the server script.

As for the keygen error, I'm not sure. The keygen server will not generate more than one key per week per IP if I remember correctly. But it doesn't look like that's the problem.

Yes, before posting this thread, I read it.

I just have moved the server.cfg to the xonotic/server, but I still get the same error Sad

Any suggestion? Thanks for answering Blush


EDIT:

After waiting a while, I get this:

Error response from keygen server: Not allowed
Saving persistent data...
Can't write DB to server.dbdone!


EDIT2:

I moved the server.cfg to the data/ directory but I'm on the same situation... I don't know what to do :S
Reply

#4
server.cfg must be in one of the two data directories, not in Xonotic/server and not in Xonotic/. I guess you realized this in your EDIT2. Check that there's nothing complaining about server.cfg in your log.

As for the other messages... Maybe you can try renewing your keys. To do this, just move the existing ones into a backup directory:
Code:
cd ~/.xonotic
mkdir key-backup
mv key_0.d0si key_0-public-fp.txt key-backup

And make sure that the directory ~/.xonotic/data/data exists and is readable. That's where server.db is stored. ("server.dbdone" seems odd, are you sure that's what it said?) EDIT: maybe it's just a missing linebreak in the message printing code
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#5
Thanks for helping me, Mr Bougo, but I can't set up the server, I get the same error always. Sad
Reply

#6
Be patient, hopefully divVerent catches this and helps you find out what's going wrong with the key server. About the database thing, you have to double-check permissions in $HOME/.xonotic. Does $HOME/.xonotic even exist?

Also, is your server.cfg correctly loaded now? In the log you posted in the top post, you had
Code:
You have not written any server.cfg file yet.
The server will therefore run at default settings.

For information on how to set up a dedicated server,
look at the files in the server/ subdirectory of your
Xonotic install.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#7
I created a new user called xonuser. After, I downloaded again the game files inside the /home/xonuser/. I copied the server.cfg to the Xonotic/data directory and server_linux.sh to Xonotic/.
Then, I edited the Xonotic/data/server.cfg (only adding bots and the tdm mode)

Finally, I checked the xonuser/.xonotic and yes, the direcrory exists. The permissions are: drwxrwxrwx xonuser xonuser .xonotic

My log when I execute the server script: http://pastebin.com/jFpk94ak

I see a lot of errors and warnings, but I don't know how to solve them. I'm waiting, but the console doesn't stop saying the same:

Saving persistent data...
done!
Initializing ClientSide information entities
Saving persistent data...
done!
Initializing ClientSide information entities


Thank you very much Smile


EDIT: I get a new line:

Initializing ClientSide information entities
Mod_LoadModel: models/weapons/g_akordeon.md3 not found

Still waiting Wink
Reply

#8
I don't think I can help any further, be patient and if no answer comes, feel free to ask on irc, in #xonotic on irc.freenode.net.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  South American Dedicated Server Professor 3 383 03-03-2019, 07:02 PM
Last Post: end user
Information [TUTORIAL] Xonotic Server behind OPNSense (and pfSense) gurbe 0 224 01-27-2019, 09:07 AM
Last Post: gurbe
  Xonotic server running behind UDP proxy not working doombringeroperator 2 349 01-07-2019, 02:23 PM
Last Post: doombringeroperator
  [NEED HELP] Server show on the browser list, but I can't connect! Professor 1 263 12-19-2018, 11:39 AM
Last Post: Professor
  Server Setup for Dummies litvinenkotea 7 3,766 12-08-2018, 01:20 PM
Last Post: tehjester78
  Local LAN Xonotic game server player Stats animatedjay 3 698 11-23-2018, 12:38 AM
Last Post: BuddyFriendGuy
  Deploying a server across multiple machines ar5n1c 1 355 11-21-2018, 11:08 AM
Last Post: martin-t
  Fix Duel on Server Australis Antares* 0 345 09-30-2018, 11:45 PM
Last Post: Antares*
  Xonotic server monitoring Sl@va 5 1,265 09-18-2018, 07:07 PM
Last Post: MarisaG
  Running a config script when the server becomes empty? Notavi 3 502 08-18-2018, 12:10 AM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-