Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Xonotic Random Crashes!

#1
Hey Xonotic team!
I found this game by looking for a good free game.
And it looks really great but I have one problem which causes the game to be unplayable.
Everytime when I join a server or do singleplayer this game crashes by entering the map. Sometimes it take a few seconds but it crashes for no reason. It is very annoying. But once I was able to play it over 2 minutes.
Windows says something with AppHangB1.

Here is my Hardware Info:
CPU: AMD Phenom II X4 965 3,40Ghz
GPU: AMD Radeon HD 5830
Ram: 4Gb
Operating System: Windows 7 64Bit

What I already tryed:
Using different Game settings (Graphics)
Using different executables like xonotic 64bit, sdl.
Updating Video Drivers (Up To Date)

I don't know anything more so I decided to ask in the Xonotic Forum.
I hope somebody is able to solve this problem.
If you need some additional Infos ask me. ^^
Xonotic is the only game with this problems, and I play around 30.
Reply

#2
From what I've Google'd AppHangB1 appears to be a Windows 7 error of some kind that only effects the x86-64 version. There are a few ideas out there but they generally involve testing in safe mode which won't work for a game properly anyway as there will be no hardware acceleration.

Other people are running similar systems so it sounds like some kind of Windows breakage. Have a look at some of the MS topics about the error and see if any of their steps are able to isolate or resolve the issue.
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#3
Hm. I think AppHangB1 is just one of those windows high detailed descriptions which doesnt help at all.
The most people have this problem with random programs.

Xonotic is for me the only program with this problem.
But at least Xonotic is still at beta. (0.6.0)
This issue will maybe be solved in future.
But is there maybe one of the developers who knows more about this crash?
Reply

#4
I would doubt there is anything to fix in Xonotic as it is a Windows error. In addition the underlying engine (Darkplaces) is very mature by now. A possibility for why it only causes problems in Xonotic and not anything else is that Xonotic is OpenGL. You could as a test get another OpenGL game like Sauerbraten and see how it runs.

You could try updating to the latest development build to see if there is any difference anyway:
http://forums.xonotic.org/showthread.php?tid=1863

Some other things to try would be running the xonotic-sdl.exe executable instead. The SDL version sometimes fixes problems and is generally faster but it depends on the system supporting SDL correctly. Also have you tried the 64-bit executables?

You could also try running a demo from within Xonotic and see if it can run that correctly and try switching pretty much all of the graphics off with:
Code:
exec effects-omg.cfg
vid_restart
It might like awful but this switches things to the bare minimum.

Plus you could also try software rendering:
Code:
vid_soft 1
vid_restart

This uses the CPU instead of the graphics card for rendering so is much slower and does require SSE2 but might be worth a shot.

You could also try disabling OpenGL 2 if you haven't already done so, this could be a cause for concern with a broken driver.

Edit:
An interesting resolution here for the same error in a Need for Speed game:
Quote:For those who need it: I had that same problem recently (8/20/11) and found that the solution is to uninstall the DivX Web Player ... If you need to use a web player, choose to use any other than that.
http://www.tomshardware.co.uk/forum/3424-63-apphangb1
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#5
Tried all your tips.
I noticed that it always crashes when the shoot sound is playing!
Because I joined a server with no players. When I started to shoot the game directly crashed.
Is that a help for you? Is there a file bugged? Don't think so because I already redownloaded it.
Reply

#6
(04-25-2013, 01:22 PM)PostalDude Wrote: I noticed that it always crashes when the shoot sound is playing!
Interesting. From the information given when Googling on this pretty non-descript error message it appears that device driver issues are blamed by some. Maybe an audio driver or some other part of the sound system is the cause? To test this try running the game from Start > Run but adding -nosound to the command. Eg:
Code:
c:\Xonotic\Xonotic.exe -nosound

This will totally disable the sound system and allow you to test without it for exclusion purposes.

(04-25-2013, 01:22 PM)PostalDude Wrote: Is there a file bugged? Don't think so because I already redownloaded it.
No, you'd expect it either to give some error message internally or just not start if that was the case.
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#7
Hey!
I just wanted to say that this crash issues are fixed since Xonotic v0.7.
Reply

#8
Nice! Thanks for reporting.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 796 04-24-2019, 10:41 PM
Last Post: Space Ace
  [SOLVED] Random failures to register mouse input Halogene 2 1,559 06-15-2017, 01:04 PM
Last Post: Halogene
  [NEEDS INFO] Game crashes while loading - could not load texture "overkillbullet" |OSiRiS| 5 3,746 10-17-2015, 03:44 PM
Last Post: BuddyFriendGuy
  [SOLVED] Xonotic causes severe system crashes (Linux + fglrx driver) MirceaKitsune 7 7,215 03-24-2013, 08:17 PM
Last Post: Samual
Exclamation [BUG] Game crashes after joining server on AMD BULLDOZER CPU Droid 18 13,767 09-28-2012, 09:11 AM
Last Post: Droid
  [NEEDS INFO] Xonotic crashes as soon as I click 'Apply changes' in the config/video menu tuxator 5 6,446 07-29-2012, 02:37 PM
Last Post: Mr. Bougo
Exclamation [NEEDS INFO] Whenever i luanch xonotic the 2nd time it crashes. nvme 2 2,369 05-12-2012, 05:07 PM
Last Post: Spaceman
  [SOLVED] Xonotic crashes upon joining server wormed 10 8,931 03-10-2012, 06:08 PM
Last Post: edh
  [NEEDS INFO] Race Map Crashes BFea 2 2,613 10-27-2011, 03:28 PM
Last Post: BFea
  [NEEDS INFO] Xonotic Git crashes on startup Gam0rdude 5 5,397 05-10-2011, 11:21 AM
Last Post: Mepper

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-