Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Random failures to register mouse input

#1
I'm encountering random failures to register mouse input recently. It started about this week, I first thought, it would be network issues, but then I tried it locally and it happens there too.

What is happening: mouse clicks don't get registered randomly. Some times the release event doesn't register as well. At one point I even had the mouse going from continuous primary fire (left click) to secondary fire (right click) WITHOUT me even touching the mouse - I was chatting about the weird behavior! This happens a lot, especially but not exclusively in fights. Some times several clicks fail to register in a row, I think 4 or 5 clicks in a row is personal best score. Basically I don't survive an opponent encounter because I am unable to fire a single shot.

I am running Arch Linux on an intel i5 /GTX660 TI. I even did a clean install of Arch linux today and made a fresh clone of Xonotic git. The issue persists.

I tried also with a different mouse.

Now I believe this may not at all be caused by Xonotic, but is someone else maybe experiencing similar issues (even on local games)?
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply

#2
Hi Halogene,

I encountered the same issue on ArchLinux after Plasma 5.10 update.
If you use KDE/Plasma: disable the left touchscreen action (System Configuration -> Workspace behavior -> Touchscreen -> uncheck the left action).
Restart kwin afterwards, or simply reboot your PC.

I didn't find this solution alone, EACFreddy did.
Thanks Freddy! Smile

Relevant KDE bug report: https://bugs.kde.org/show_bug.cgi?id=380476
Reply

#3
AWESOME.

You guys really rock. Thanks for sharing this, you made my day!

Will mark as solved when I can verify it's fixed
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Input layout problem in Xonotic-SDL FinBiteLeaf 4 285 03-19-2024, 05:24 AM
Last Post: FinBiteLeaf
  [BUG] Dropping mouse input FPS Null 1 586 04-29-2023, 08:06 AM
Last Post: bones_was_here
  [NEED HELP] My mouse binds do not work in GLX? FAF 5 1,652 07-29-2022, 08:39 AM
Last Post: FAF
  [SOLVED] Input flickering in Ubuntu 20.04 NAPALM 3 1,687 03-28-2021, 11:38 AM
Last Post: SpiKe
  USB Mouse input on Linux dagelf 1 2,296 10-07-2020, 06:14 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 1,652 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Strange input lag and graphics lag in 0.8.2 mrdoklata 3 5,201 04-21-2017, 11:00 PM
Last Post: -z-
  [NEEDS INFO] Input lag? dylstew 11 10,051 10-06-2016, 05:07 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Menu mouse cursor stuck in invisible box nAnXiety 1 3,147 09-16-2016, 03:30 PM
Last Post: martin-t
  [NEEDS INFO] mouse lag mumin 3 3,495 03-17-2016, 05:29 AM
Last Post: Maddin

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-