Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Xonotic menu lag

#1
Hey there I am meeting a serious lag problem on my Xonotic.

When everytime I started my Xonotic, the menu will always laggy(include music). Seems the problem was caused by the server list loading and refreshing. When I plug-off my ethernet cable which my pc is in offline mode the problem solved.

But I don't want to plug-off my cable everytime when I am going to play Xonotic. Any solution for this? To prevent the laggy in menu.
Reply

#2
When you start up, there's a lot of traffic because the server list is polled, then every server from that list is also polled.

To confirm that this is indeed the issue, try to click "pause" in the server list and see if the lag disappears.

If that works, you can then try to lower the server polling rate by changing the values of net_slist_queriesperframe and net_slist_queriespersecond. The first has a default of 4 and the second a default of 20, try to use lower values. You can change those settings in the Xonotic console (shift escape), typing in there such commands as
Code:
net_slist_queriesperframe 2
or you can use the "advanced settings" editor in the "misc" tab of the settings window (which will be more tedious if you're lagging).

Do you get any lag when you're playing on a server? If your network can't handle the server list polling, I have to wonder how well the game itself works. Check your firewall settings or your router's logs to see if there's any throttling or flood protection being triggered.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Menu fails to load after recent update Bloodthorn 2 1,227 09-25-2018, 08:11 AM
Last Post: Bloodthorn
  [NEED HELP] Menu freezes falco 2 1,263 11-25-2017, 06:45 AM
Last Post: falco
  [NEEDS INFO] Menu mouse cursor stuck in invisible box nAnXiety 1 1,981 09-16-2016, 03:30 PM
Last Post: martin-t
  [SOLVED] Video menu causes the game to crash Divergence 8 6,264 11-02-2013, 04:55 PM
Last Post: edh
  [NEEDS INFO] Xonotic crashes as soon as I click 'Apply changes' in the config/video menu tuxator 5 6,399 07-29-2012, 02:37 PM
Last Post: Mr. Bougo
  [NEED HELP] Menu Navigation with Joy-pads instead mouse jdumont007 17 10,621 06-01-2012, 05:38 AM
Last Post: Mr. Bougo
  [SOLVED] menu fails to load. theShadow 8 6,737 01-05-2011, 01:23 PM
Last Post: theShadow

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-