Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Quake Error "Video modes failed" on 2nd startup

After 'installation' (copied to Programs (x86) directory), I ran Xonotic and it worked... yes it did.
But later, probably after tweaking settings the first time, it would not start up at all from my desktop shortcut. Just displayed a small window titled 'Quake error', and the text 'Video modes failed.' [OK]
It's now fixed (sort of), thanks to a post elsewhere in another topic, from Mr. Bougo...

"...put the line "vid_fullscreen 0" in ~/.xonotic/data/autoexec.cfg..."

Created a new file, autoexec.cfg, (as it was non-existent) in the xonotic/data directory, and edited that empty file to include the line:

vid_fullscreen 0

...and saved it, and I was able to start Xonotic again (in a silly window that's almost fullscreen except for the lower window border about 1/8" above bottom of screen). However, I can't seem to run fullscreen... checkmark it, click 'Apply immediately' and it pauses then blinks/restarts back to video settings, uncheckmarked.
(Toshiba PC755 laptop, Windows 8 Pro) In a window is alright.

Just an FYI for anyone else that gets 'Quake Error, Video modes failed' window, when trying to start Xonotic.

Hi, welcome and thanks for your report! And I'm glad my posts helped Big Grin

This seems strange, though! It sounds like you were using a resolution that is not supported by your hardware (screen or video board). And are you saying that enabling vid_fullscreen and applying still gets you in windowed mode and disables fullscreen as you apply the settings?

You can have a look at the vid_fullscreen configuration variable (cvar) from the menu by opening the Xonotic console (that's shift escape) and typing in there vid_fullscreen
If it's set to 0, that means fullscreen should be disabled. 1 means it's enabled. You can change the cvar's value to 1 for example by doing
vid_fullscreen 1
which will only be applied if you then do vid_restart (which the "Apply immediately" button also does).

That said, can you try setting the resolution to your native resolution in the menu, then open the console and type:
vid_fullscreen 1
and see what happens? If you go back to windowed mode, check the value of vid_fullscreen.

Well... the first run worked fine. I checked a few different resolutions, which changed well enough... maybe I set a bad resolution, but I prefer native setting (1366x768) of my external HDTV and that's how I run Win8Pro. I had tried re-installing over top of existing, then a completely fresh copy. Perhaps certain settings are saved in Win registry? Anyway, no change with error window, so I came looking for config help (your post).

After getting back into Xonotic, I tried setting vid_fullscreen 1 and vid_restart through console as you mentioned, and had the same results as using the menu... the Xonotic window (only the bottom border visible) would go white for a few moments then return to Xonotic logo, then starshine over planet edge cutscreen(?) and back to Video menu (fullscreen UNchecked).

-- I have had no real problem with Nexuiz... so I checked settings there... 1366x768. I noted that I had knocked Xonotic down to 16bit colors and returned it to 32... I had also not bumped up Brightness, or Ambience... so I moved those up to match Nexuiz settings (fairly bright).

Strangely enough... after that fussing, I tried fullscreen via the Video menu again. It worked. I shutdown the game, restarted... still working.
I don't know... there were a couple other tiny oddities, but now it runs pretty much like I've come to expect with Nexuiz. Just got a bit(s) stuck, I guess.

Oh well!

Just for your information, though. Xonotic doesn't touch the registry, it instead stores all of its data and configuration files somewhere in your personal documents directory. It's typically in "My Saved Games". If you can't find it, open the Xonotic console (shift escape) and type
which config.cfg
That will show you the path to your config.cfg file (which is what you wanted to remove instead of re-extracting the game to reset the config to defaults).

Yes! Thanks... that's what I wanted to find.

It's in...

C:\Users\{username}\Saved Games\xonotic\data\config.cfg

Thanks again. Game is running great >;}
Just need some wall jumping practice and figure a good key for changing to best weapon. Otherwise, it seems it takes more damage to down an opponent, than in Nexuiz.

Possibly Related Threads…
Thread Author Replies Views Last Post
Video [NEED HELP] Render Replay Directly to Video File cushinga 3 798 09-11-2023, 07:11 PM
Last Post: cushinga
Sad [SOLVED] Segmentation fault (HTTP error 422) at the end of the first map John 1 1,170 11-04-2022, 10:05 AM
Last Post: John
  [NEED HELP] Custom Game Modes 3agle427 2 3,436 12-29-2018, 07:34 PM
Last Post: 3agle427
  [SOLVED] linux compile/link error BuddyFriendGuy 2 3,665 11-27-2017, 05:18 PM
Last Post: BuddyFriendGuy
  [NEED HELP] video glitches in netradiant on windows 10 fabzor3 2 3,082 05-26-2017, 02:09 AM
Last Post: PinkRobot
  [NEED HELP] Video Editing and cl_capturevideo (ogv) Antares* 10 9,156 04-12-2017, 09:19 PM
Last Post: -z-
  [NEEDS INFO] Custom map - Host Error: Mod_MAP_Mode: not yet implemented teratorn 6 5,656 03-07-2017, 04:29 AM
Last Post: SpiKe
  [NEED HELP] game modes/mods/types clarification BuddyFriendGuy 13 11,960 06-12-2016, 12:18 AM
Last Post: BuddyFriendGuy
  [SOLVED] Posting Video Dustinym 1 2,732 01-29-2016, 05:13 AM
Last Post: Mirio
  [SOLVED] RegisterNotification_Done error Keziolio 5 6,720 08-06-2014, 03:32 PM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-