Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Segmentation fault @ Xonotic(git)

Today while playing xonotic i got 2 segmentation faults.

I'm running Xonotic(git) up to date @ latest build
i play @ (SMB) CTF Minsta+Hook - MONTREAL [git]

The segmentation faults both happened when opening a map (in the transition after a game was over and the next one is started) i already had the maps so it wasn't a download involved.

The first time was after loading implosion and the second was after loading eggandbacon, i played eggandbacon more than once and the second time was not an error involving with the loading so i think that's not involved.

i ran xonotic as
./all run sdl
both times that i got the error.

I tried to make the bug report as useful as possible(is there a better place for bug reports by the way?) and it seems as the culprit is the darkplaces engine (attached the console output of both segmentation faults).


I don't think that my specs help but just in case, I have Debian Whezzy on a 3.2 Phenom II AMD proccesor, 4GB ram and Nvidia 240GT Graphic card with non-free driver.

The error only closes the game, so it isn't a big deal for me, but i hope this will help in fixing it.

Attached Files
.txt   errorlog.txt (Size: 34.52 KB / Downloads: 0)
.txt   errorlog2.txt (Size: 34.46 KB / Downloads: 0)
[Image: 9074.png]

Thanks a lot for the detailed report. The best place to submit those is our bug tracker, located on Otherwise, bugs reported on the forum can easily get lost.

How frequent is this segfault? Did you have a lot of other map changes without encountering it?

Thanks for the link, bug reported

Today i found the bug twice, i played/spected around 15 games.

Actually, this looks like a known issue is quite similar or maybe the same
[Image: 9074.png]

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-