Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Segmentation fault @ Xonotic(git)

#1
Today while playing xonotic i got 2 segmentation faults.

I'm running Xonotic(git) up to date @ latest build
i play @ (SMB) CTF Minsta+Hook - MONTREAL [git]

The segmentation faults both happened when opening a map (in the transition after a game was over and the next one is started) i already had the maps so it wasn't a download involved.

The first time was after loading implosion and the second was after loading eggandbacon, i played eggandbacon more than once and the second time was not an error involving with the loading so i think that's not involved.

i ran xonotic as
Code:
./all run sdl
both times that i got the error.

I tried to make the bug report as useful as possible(is there a better place for bug reports by the way?) and it seems as the culprit is the darkplaces engine (attached the console output of both segmentation faults).


Code:
Backtrace:
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../matrixlib.c:1361(Matrix4x4_ToArray12FloatD3D)[0x59bcbe]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../model_alias.c:82(Mod_Skeletal_BuildTransforms)[0x5a6101]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../gl_rmain.c:4966(R_AnimCache_GetEntity)[0x53fcf3]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../gl_rmain.c:5046(R_AnimCache_CacheVisibleEntities)[0x540142]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../gl_rmain.c:7280(R_RenderView)[0x54a544]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../clvm_cmds.c:3271(VM_CL_R_RenderScene)[0x49f3fb]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../prvm_execprogram.h:504(CLVM_ExecuteProgram)[0x66dc9b]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../csprogs.c:492(CL_VM_UpdateView)[0x4c6aab]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../cl_screen.c:2194(SCR_DrawScreen)[0x482cb5]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../cl_screen.c:2939(CL_UpdateScreen)[0x485011]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../host.c:1024(Host_Main)[0x57a0d1]
/home/ari/xonotic/darkplaces/build-obj/debug/darkplaces-sdl/../../../sys_sdl.c:225(main)[0x404c19]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xfd)[0x7f8003eafead]
??:0(_start)[0x404789]

I don't think that my specs help but just in case, I have Debian Whezzy on a 3.2 Phenom II AMD proccesor, 4GB ram and Nvidia 240GT Graphic card with non-free driver.

The error only closes the game, so it isn't a big deal for me, but i hope this will help in fixing it.


Attached Files
.txt   errorlog.txt (Size: 34.52 KB / Downloads: 0)
.txt   errorlog2.txt (Size: 34.46 KB / Downloads: 0)
[Image: 9074.png]
Reply

#2
Thanks a lot for the detailed report. The best place to submit those is our bug tracker, located on dev.xonotic.org. Otherwise, bugs reported on the forum can easily get lost.

http://dev.xonotic.org/projects/xonotic/issues

How frequent is this segfault? Did you have a lot of other map changes without encountering it?
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
Thanks for the link, bug reported http://dev.xonotic.org/issues/1891

Today i found the bug twice, i played/spected around 15 games.

Actually, this looks like a known issue http://dev.xonotic.org/issues/1885 is quite similar or maybe the same
[Image: 9074.png]
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-