Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] GUI Mouse Problem with GLX

#1
In the settings etc gui, when I move the mouse to change an option or click a button etc. the mouse will snap back to some central point, so it's nigh impossible to use. It works fine in the game though.

This is only in glx; sdl works fine. My mouse is a logitech mx518 USB mouse. Nothing fancy.

Any ideas what to change to fix that?
Reply

#2
What's your OS? What's your Xonotic version? Do you play windowed or fullscreen? Do you have anything special about your setup that we should know? (Compositing / Desktop effects?)

Open the xonotic console (shift escape when in the menu) and type in there
Code:
vid_stick_mouse
What do you get from this?

I haven't seen this issue before. Usually, when only one of glx and sdl does not work, we'll tell you to use the one that works, as that's why we distribute both Wink
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
Sorry, was a bit tired when I wrote that and didn't give any info, but:

Running on slackware 14.1 64bit:
Linux raven 3.13.5-blarg #9 SMP PREEMPT Fri May 9 20:34:16 BST 2014 x86_64 Intel® Core™ i5-2520M CPU @ 2.50GHz GenuineIntel GNU/Linux
Xonotic 0.7.0 built from slackbuilds.org slackbuild
Playing fullscreen @ 1366x768
No compostite/effects
WM = fluxbox

vid_stick_mouse returns 0
I tried setting it to 1 but no difference.

Hope this helps
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Windows 10 -basedir problem BlazedRasta 2 105 06-13-2019, 05:12 AM
Last Post: martin-t
  Chat key bind problem BuddyFriendGuy 4 430 01-26-2019, 11:12 PM
Last Post: BuddyFriendGuy
  [SOLVED] Random failures to register mouse input Halogene 2 996 06-15-2017, 01:04 PM
Last Post: Halogene
  [NEEDS INFO] Menu mouse cursor stuck in invisible box nAnXiety 1 1,371 09-16-2016, 03:30 PM
Last Post: martin-t
  [NEEDS INFO] Dedicated server problem. kreestenrx1234 2 1,331 04-27-2016, 03:30 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] mouse lag mumin 3 1,480 03-17-2016, 05:29 AM
Last Post: Maddin
  [NEED HELP] Player model problem hysik 2 1,780 12-15-2015, 11:35 AM
Last Post: hysik
  [SOLVED] Problem with NetRadiant - shadertags.xml. No tag support. tobster 23 18,234 03-29-2015, 07:58 PM
Last Post: BuddyFriendGuy
  [SOLVED] Mouse limited to reduced area at higher resolutions / DPI Ishatix 5 3,664 03-14-2015, 06:54 AM
Last Post: Mr. Bougo
  [SOLVED] Problem with screen being too large and off center. Cow_Fu 2 2,467 03-11-2015, 02:14 PM
Last Post: Ishatix

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-