Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server not showing up in servers list

#1
I set up a Xonotic server (0.8.1) some time ago. It was sv_public 0 for most of the time, I had it added to favorites and it showed in the servers list just fine.

Since yesterday it's sv_public 1, but there is some problem with it showing up on the servers list. Even on machines where I have it favored it doesn't show up. Once in a while it pops up, but mostly not Undecided.

The server is behind NAT, but it's forwarded on firewall and works fine. Are tyhere any other ports except 26000 that need to be forwarded? Or maybe it's the NAT problem? The server might be reporting the internal IP, instead of the one needed to connect to it - how do I make it report the correct address? I tried setting net_address, but that's not it.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply

#2
Can you see the server here? Can you connect to it manually (using 'connect <ip>:<port>' in console)?
[Image: 30381.jpg]

<packer> when i see martin-t's name my blood pressure increases

<[BOT]Hоtdоg> anyone here lives near martin?
<[BOT]Hоtdоg> will pay monies for shooting him
Reply

#3
I checked earlier on that list & it's also not there, but it's totally connectible & working, you can try yourself: 94.42.83.193:26000
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply

#4
I have this problem too sometimes. I'll be looking for a certain server and it doesn't show up on the server list. I have to connect manually even though I know other people can see the same server on the list.
[Image: 38443.png]
Reply

#5
I had similar problems a few times but with the git version (are you sure you're using 0.8.1 and not autobuild?). One time nothing helped except using a different linux user for the server. The other time, i reverted the 24e0784d14f2f7c24e7a44701162e1f988f11672 commit in darkplaces as it sometimes has issues with IPv6.
[Image: 30381.jpg]

<packer> when i see martin-t's name my blood pressure increases

<[BOT]Hоtdоg> anyone here lives near martin?
<[BOT]Hоtdоg> will pay monies for shooting him
Reply

#6
I'm fully sure it's running from the official zip on the website & it's running as a normal (non-root) user.

Anyway - are there any docs (except analyzing the code) on how the registering on the master server works? Perhaps it could shed some light on this. I checked the wiki & found nothing.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  I can't see my listen server on server list fnmain 1 718 10-07-2023, 07:28 AM
Last Post: Grimnack
  Server not visible on the server browser for others or me DankoLord 1 1,851 02-21-2023, 08:02 PM
Last Post: ballerburg9005
  Let's make our servers community-like! xord86_64 3 1,048 02-03-2023, 05:36 PM
Last Post: xord86_64
  Xonotic server running behind UDP proxy not working doombringeroperator 3 4,111 11-21-2022, 11:00 AM
Last Post: Zaphod
  [META] Deploying Xonotic using GKE Game Servers? FAF 4 1,875 09-14-2022, 08:32 AM
Last Post: cushinga
  A certain server seems to manipulate stats of it's players by not listing some games nj 7 3,162 08-14-2022, 02:48 AM
Last Post: FAF
  BaI server | South American Xonotic server (located in Chile) z411 0 2,789 01-02-2022, 11:36 PM
Last Post: z411
  Full server tutorial start-2-finish with maps & config from live server xonotic.us.to ballerburg9005 0 8,343 09-03-2021, 10:21 AM
Last Post: ballerburg9005
  [ MoFo ] Servers Master Thread end user 5 5,010 11-27-2020, 09:33 PM
Last Post: end user
  Server does not start saddesad 2 2,236 11-25-2020, 04:39 AM
Last Post: saddesad

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-