Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't respawn sometimes

#1
Hi, I have a strange problem: occasionally, after I get fragged, I can't respawn. No matter how many times I press Space, nothing happens. The only way I can continue playing is to press F3 (losing my points), and then rejoining. Sometimes that doesn't work either, I have to restart Xonotic. Sometimes when this happens, if I do nothing, I respawn after like half a minute, sometimes I don't even after a long time.

The issue happens on multiple servers (perhaps most often on the Jeff&Julius Resurrection Server, but on other servers as well), and even in local games if I create a server on my computer. On some days it doesn't happen at all; when it happens, it often happens multiple times (but inconsistently, usually not after every time I get fragged). The issue affects at least one other player, Ernie, who usually plays on the Resurrection Server.

I use Xonotic 0.8.1 on openSUSE Linux 13.2, xonotic-sdl, AMD graphics with open source driver.

Has anyone seen this problem and managed to solve it, or have any idea how to solve it?
Reply

#2
Never seen that happen.

Is it be possible that you were typing by accident maybe? = Pressing chat key by accident

Is it possible that the OS occasionally throws you to another process which starts to receive input instead?
Reply

#3
Pretty sure not. If another process was receiving output, F3 and other keys wouldn't work either. It happened many times. Also, I fully see the game going on, no lag or anything, I just can't respawn.
Reply

#4
I've noticed that sometimes after Alt-Tabbing out of Xon that when it gains focus again, the Alt key is permanently in the "Down" state in Xon (it sees it go down, then loses focus so never sees it lift).

You might want to try tapping all the meta keys (Alt, Shift, Control) and then trying again. I think Alt-Space might be something interpreted by the Window Manager, whereas Xon probably doesn't care.

Note: I only noticed it cos I have Alt secondary mapped to Crouch.
[Image: 21975.jpg]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams
Reply

#5
(12-08-2016, 05:08 PM)cefiar Wrote: I've noticed that sometimes after Alt-Tabbing out of Xon that when it gains focus again, the Alt key is permanently in the "Down" state in Xon (it sees it go down, then loses focus so never sees it lift).

You might want to try tapping all the meta keys (Alt, Shift, Control) and then trying again. I think Alt-Space might be something interpreted by the Window Manager, whereas Xon probably doesn't care.

I also noticed the Alt+Tab thing, but I don't think it causes my problem (it doesn't happen only right after an Alt+Tab). I'll try it, though I think I already tried pressing pretty much all modifier keys. Also, Xonotic doesn't actually handle key combinations at all, so a Space is supposed to be a jump/respawn even if Alt happens to be pressed.
Reply

#6
I may have found the reason. It looks like the hook key (which I put on Ctrl, and which is the nade key when they are enabled) gets stuck sometimes, and that blocks respawning (even though it doens't block jumping).
Reply

#7
This is also possible: http://forums.xonotic.org/showthread.php?tid=6261
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-