Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[BUG] Rebound "R" key, still occasionally does "team say" anyways

So, this bug is basically rendering the game unplayable -- I always bind "R" to Rocket Launcher, but in this game, I've got Devestator bound to "R" on my options screen, Team Say bound to ";" and nothing else, but once every few minutes, when I try to switch to rockets, I lose all inputs and the "team say" bar comes up instead with me mashing "wasasaswassad" into it.

EDIT: I've figured out how to reproduce it every time.  R and click at the same time.  Brings up team say every single time, no matter what.

It could be a bug in Xonotic or some weird shortcut in your OS. What happens when you press R and click at the same time outside Xonotic, for example in a text editor? Does it type ";"? What happens when you're inside Xonotic in chat mode already? Does it type ";"?

If it's a bug, you could try updating to autobuild: - i think it uses a newer version of the input library (though it might have other issues). Also let us know which OS you're on and which executable you're using to launch xon (some OSes have more choices) in case somebody else runs into it so we can narrow it down.
[Image: 30381.jpg]

<packer> when i see martin-t's name my blood pressure increases

<[BOT]Hоtdоg> anyone here lives near martin?
<[BOT]Hоtdоg> will pay monies for shooting him

Nothing weird in the OS, and it was happening in an Autobuild.  Windows 10, Xonotic.exe.  I think my config.cfg got corrupted somehow; the in-game control menu showed mouse 1 as "fire 1", but the config.cfg showed it as "say team" (although why it only happened when R and mouse were clicked at the same time, I have no idea).  When I switched mouse 1 in config.cfg to "fire 1", in the in-game menu it showed up as "last weapon" and that's what it did in game.  I deleted the line in config.cfg entirely, rebound "fire 1" to "mouse 1" in-game, and it seems to be working now.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Two weapons on each key? FAF 18 7,482 07-27-2022, 03:55 PM
Last Post: FAF
  Chat key bind problem BuddyFriendGuy 4 3,081 01-26-2019, 11:12 PM
Last Post: BuddyFriendGuy
  [SOLVED] Game displays [x] joined the [y] team upon connecting Bloodthorn 1 2,799 09-16-2018, 01:44 PM
Last Post: Bloodthorn
  [SOLVED] Weird key hold issue with official version Bloodthorn 9 5,268 05-21-2018, 07:56 AM
Last Post: Bloodthorn
  [BUG] Grappling hook breaks if no new key is pressed while it is midair (new since 8.2) reth 2 3,015 05-13-2017, 06:52 AM
Last Post: reth
  [NEED HELP] console send key or calling menus BuddyFriendGuy 3 4,317 05-07-2017, 09:17 AM
Last Post: -z-
  [BUG] xonotic-maps ebuild does not compile ZyX 0 2,258 05-01-2017, 10:10 PM
Last Post: ZyX
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 3,425 03-06-2017, 08:35 PM
Last Post: -z-
  [SOLVED] How does the defer command work? nightspawn9911 4 3,836 07-18-2016, 07:34 PM
Last Post: nightspawn9911
  [NEEDS INFO] Dl' d new version, but still showing as 0.8.0 KingPimpCommander 1 2,692 10-13-2015, 01:07 AM
Last Post: Halogene

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-