Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Error compiling DP after update GIT on linux

#1
Hi, first I want to thank you to all of xonotic team for your big work.
Since last week I got compiling error after update GIT. The compiling was a success just befor the weekend test (XWIT). I'll apreciate if a "programing guru" would help me to resolve my probleme. Here the end of the log of the process. Sry for my poor english.

LDFLAGS="-g -ggdb -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math -DSVNREVISION=`{ test -d .svn && svnversion; } || { test -d .git && git describe --always --dirty; } || echo -` -DBUILDTYPE=debug -lm -ljpeg ../misc/builddeps/dp.linux32/lib//libd0_blind_id.a ../misc/builddeps/dp.linux32/lib//libgmp.a ../misc/builddeps/dp.linux32/lib//libd0_rijndael.a -lrt -ldl" LEVEL=2
error: unknown option `dirty'
usage: git describe [options] <committish>*

-+-+-+-+-+-+ and -+-+-+-+-+-+

gcc -DSUPPORTIPV6 -o darkplaces-dedicated builddate.c sys_linux.o vid_null.o thread_null.o snd_null.o cd_null.o bih.o cap_avi.o cap_ogg.o cd_shared.o crypto.o cl_collision.o cl_demo.o cl_dyntexture.o cl_gecko.o cl_input.o cl_main.o cl_parse.o cl_particles.o cl_screen.o cl_video.o clvm_cmds.o cmd.o collision.o common.o console.o csprogs.o curves.o cvar.o dpsoftrast.o dpvsimpledecode.o filematch.o fractalnoise.o fs.o ft2.o utf8lib.o gl_backend.o gl_draw.o gl_rmain.o gl_rsurf.o gl_textures.o hmac.o host.o host_cmd.o image.o image_png.o jpeg.o keys.o lhnet.o libcurl.o mathlib.o matrixlib.o mdfour.o menu.o meshqueue.o mod_skeletal_animatevertices_sse.o mod_skeletal_animatevertices_generic.o model_alias.o model_brush.o model_shared.o model_sprite.o mvm_cmds.o netconn.o palette.o polygon.o portals.o protocol.o prvm_cmds.o prvm_edict.o prvm_exec.o r_explosion.o r_lerpanim.o r_lightning.o r_modules.o r_shadow.o r_sky.o r_sprites.o sbar.o sv_demo.o sv_main.o sv_move.o sv_phys.o sv_user.o svbsp.o svvm_cmds.o sys_shared.o vid_shared.o view.o wad.o world.o zone.o -g -ggdb -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math -DSVNREVISION=- -DBUILDTYPE=debug -lm -ljpeg ../misc/builddeps/dp.linux32/lib//libd0_blind_id.a ../misc/builddeps/dp.linux32/lib//libgmp.a ../misc/builddeps/dp.linux32/lib//libd0_rijndael.a -lrt -ldl
dpsoftrast.o: In function `DPSOFTRAST_Interpret_Draw':
/home/user/jeux/xonotic/darkplaces/dpsoftrast.c:4907: undefined reference to `__sync_add_and_fetch_4'
/home/user/jeux/xonotic/darkplaces/dpsoftrast.c:5324: undefined reference to `__sync_add_and_fetch_4'
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [darkplaces-dedicated] Erreur 1
make[2]: quittant le répertoire « /home/user/jeux/xonotic/darkplaces »
make[1]: *** [bin-debug] Erreur 2
make[1]: quittant le répertoire « /home/user/jeux/xonotic/darkplaces »
make: *** [sv-debug] Erreur 2

I can show or attach all the log file if necessary. Thank you for your attention.
Reply

#2
Looks like you have to update your version of git. Or wait a bit, I don't think we really need that feature.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#3
(06-01-2011, 05:45 AM)divVerent Wrote: Looks like you have to update your version of git. Or wait a bit, I don't think we really need that feature.

Thank you for your tip, I updated GIT to the v1.7.5.4 but I have the same result when compiling Xono:
/home/user/jeux/xonotic/darkplaces/dpsoftrast.c:4907: undefined reference to `__sync_add_and_fetch_4'
/home/kuku/jeux/xonotic/darkplaces/dpsoftrast.c:5324: undefined reference to `__sync_add_and_fetch_4'

So I will wait a bit as you told me and see later if its works. Also I'll wait for an other tip to debug that ;-)
Ciao
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
Question [NEED HELP] After a successful build & compile (0.8.5): This script is not properly set up yet. John 1 492 01-27-2024, 12:07 AM
Last Post: John
  Why ClanArena ends after round 6 despite server setting to infinite? zwz 2 1,997 08-11-2023, 10:20 AM
Last Post: zwz
Sad [SOLVED] Segmentation fault (HTTP error 422) at the end of the first map John 1 1,122 11-04-2022, 10:05 AM
Last Post: John
  [NEED HELP] Models, items, and sky black after 0.8.5 update htsm92 0 765 08-15-2022, 07:34 PM
Last Post: htsm92
Question [SOLVED] How to disable the update banner Sawag 5 2,032 07-02-2022, 05:01 PM
Last Post: Sawag
  [NEEDS INFO] Xonotic settings file on linux ArchBerrie 2 5,160 07-15-2021, 03:18 AM
Last Post: ArchBerrie
  USB Mouse input on Linux dagelf 1 2,346 10-07-2020, 06:14 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Compiling on Elbrus DJs3000 1 1,666 07-03-2020, 04:57 AM
Last Post: poVoq
  [BUG] some textures won't load with git builds lister 2 2,586 01-17-2020, 06:09 PM
Last Post: LuckyStripe
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 1,710 08-18-2019, 03:14 AM
Last Post: FAF

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-