Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Problem with GIT update - Possible DNS spoofing detected [SOLVED]

When I tried to update my local GIT repo, I got the warning below.
I don't know if this is serious (i.e. attack) or not. I found a pastebin entry from someone else with the same message, so I'm not the only one.

What am I supposed to do? Reconfigure something, ignore it?

Quote:sev@####:~/xonotic> ./all update
Repository . enabled because it already exists
Repository data/xonotic-data.pk3dir enabled because it already exists
Repository data/xonotic-music.pk3dir enabled because it already exists
Repository data/xonotic-nexcompat.pk3dir disabled by default, create data/xonotic-nexcompat.pk3dir.yes to enable
Repository darkplaces enabled because it already exists
Repository netradiant enabled because it already exists
Repository div0-gittools disabled by default, create div0-gittools.yes to enable
Repository data/xonotic-maps.pk3dir enabled because it already exists
Repository mediasource disabled by default, create mediasource.yes to enable
Repository fteqcc enabled because it already exists
+ cd /home/sev/xonotic/.
+ git config core.autocrlf input
+ git config remote.origin.url ssh://
+ git config remote.origin.fetch +refs/heads/*:refs/remotes/origin/*
+ git pull
The RSA host key for has changed,
and the key for the corresponding IP address
is unknown. This could either mean that
DNS SPOOFING is happening or the IP address for the host
and its host key have changed at the same time.
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /home/sev/.ssh/known_hosts to get rid of this message.
Offending key in /home/sev/.ssh/known_hosts:1
RSA host key for has changed and you have requested strict checking.
Host key verification failed.
fatal: The remote end hung up unexpectedly
Pulling failed. Press ENTER to continue, or Ctrl-C to abort.

The fingerprint (07:b7:44:20:b5:60:f8:97:c8:f3:da:d3:08:0d:93:45) is correct, you can fix this by opening a shell (if you're on windows, a msys shell) and typing
ssh-keygen -R

ssh-keygen -R
Seems to work fine again, thanks for your quick reply. Smile

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Windows 10 -basedir problem BlazedRasta 4 3,914 03-21-2023, 07:34 PM
Last Post: AlexVelasquez
  [BUG] A font-rendering performance problem (of upstream DarkPlaces) NaitLee 11 2,765 08-20-2022, 01:23 AM
Last Post: NaitLee
  [NEED HELP] Models, items, and sky black after 0.8.5 update htsm92 0 642 08-15-2022, 07:34 PM
Last Post: htsm92
  [NEED HELP] Inconsistency detected by BuddyFriendGuy 3 1,105 07-23-2022, 12:18 AM
Last Post: BuddyFriendGuy
Question [SOLVED] How to disable the update banner Sawag 5 1,774 07-02-2022, 05:01 PM
Last Post: Sawag
Question [NEED HELP] Problem with charset of names in XonStat API NAPALM 0 876 11-11-2021, 08:38 AM
Last Post: NAPALM
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 2,708 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Need old rifle model(solved) Kotangens 8 3,095 08-27-2020, 01:42 AM
Last Post: Kotangens
Question [NEED HELP] How to create warpzones? (solved) Kotangens 10 4,558 08-19-2020, 07:05 AM
Last Post: Kotangens
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 2,866 08-12-2020, 01:33 AM
Last Post: Kotangens

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-