Create an account


Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] How to compile from last git ?

#1
Hello everyone,

I NEED Help to compile and get all gits files from the latest git, I use Ubuntu x86 10.10.

I tried many time to get xonotic.git and do ./all compile, but I've always so much errors ! And I can't understand anything !
DarkRedman
Reply

#2
Mind pasting the errors you get here? That could help us figure it out.
Reply

#3
Here is the command output :


Repository . enabled because it already exists
Repository data/xonotic-data.pk3dir enabled by default
Repository data/xonotic-music.pk3dir enabled by default
Repository data/xonotic-nexcompat.pk3dir disabled by default, create data/xonotic-nexcompat.pk3dir.yes to enable
Repository darkplaces enabled because it already exists
Repository netradiant enabled by default
Repository div0-gittools disabled by default, create div0-gittools.yes to enable
Repository d0_blind_id enabled by default
Repository data/xonotic-maps.pk3dir enabled by default
Repository mediasource disabled by default, create mediasource.yes to enable
Repository fteqcc enabled by default
+ cd /home/manuel/Bureau/mytemp/xonotic/d0_blind_id
cd: 1950: can't cd to /home/manuel/Bureau/mytemp/xonotic/d0_blind_id
DarkRedman
Reply

#4
Well I'm no expert on the compile script and such, but using:

Code:
./all clean --reclone

has fixed issues for me a few times in the past.
Reply

#5
Thanks a lot ! It works now, i can play Smile
DarkRedman
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [BUG] wonky user stats (I'm in a game today, by I'm last seen 1 month ago?) snailtrail 6 3,441 09-25-2022, 05:40 AM
Last Post: SpiKe
  Change campaign last level beat permanently Pallama 2 3,456 02-07-2020, 02:22 PM
Last Post: DarkFox
  [BUG] some textures won't load with git builds lister 2 2,529 01-17-2020, 06:09 PM
Last Post: LuckyStripe
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 2,804 03-29-2019, 11:19 AM
Last Post: Freddy
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 2,871 07-25-2018, 07:20 AM
Last Post: Bloodthorn
  [SOLVED] linux compile/link error BuddyFriendGuy 2 3,581 11-27-2017, 05:18 PM
Last Post: BuddyFriendGuy
  [BUG] xonotic-maps ebuild does not compile ZyX 0 2,226 05-01-2017, 10:10 PM
Last Post: ZyX
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 6,458 09-06-2016, 08:40 PM
Last Post: RedScale12
  [SOLVED] cannot compile git code dingus 5 5,105 07-27-2016, 05:13 PM
Last Post: sev
  [SOLVED] Can't compile my map machine! 1 2,887 05-09-2015, 08:47 AM
Last Post: Mirio

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-