Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Cannot join Overkill server. CS progs CRC mismatch?

#1
Every time I try connecting to Overkill server it fails. here is full console output from Xonotic:

Code:
$ ./xonotic-linux-sdl.sh
Game is Xonotic using base gamedir data
Xonotic Linux 17:18:28 Mar  8 2012 - release
Current nice level is below the soft limit - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
Failed to init SDL joystick subsystem:
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
execing sRGB-disable.cfg
menu: program is not loaded
execing weapons.cfg
execing cdtracks.cfg
execing balanceXonotic.cfg
execing ctfscoring-ai.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing vehicles.cfg
execing vehicle_racer.cfg
execing vehicle_raptor.cfg
execing vehicle_spiderbot.cfg
execing vehicle_bumblebee.cfg
execing crosshairs.cfg
execing commands.cfg
execing _hud_common.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
execing config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
Warning: Could not expand $scr_centersize
client: program is not loaded
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnnN4sgg8H+koTbBn5JTi37BAW1Q=)
Loaded private ID key_0.d0si for key_0.d0pk (public key fingerprint: FE7xFpUjgVZ4Cv5fCvKYgsXvafdGZRgKDIjGLRxGhAw=)
there is already a signed private key for 0
Client using an automatically assigned port
Client opened a socket on address 0.0.0.0:0
Client opened a socket on address [0:0:0:0:0:0:0:0]:0
Linked against SDL version 1.2.12
Using SDL library version 1.2.14
GL_VENDOR: Tungsten Graphics, Inc
GL_RENDERER: Mesa DRI Intel(R) Ironlake Mobile
GL_VERSION: 2.1 Mesa 7.11
vid.support.arb_multisample 1
vid.support.gl20shaders 1
NOTE: requested 1x AA, got 0x AA
Video Mode: fullscreen 1366x768x32x0.00hz
S_Startup: initializing sound output format: 48000Hz, 16 bit, 2 channels...
Wanted audio Specification:
    Channels  : 2
    Format    : 0x8010
    Frequency : 48000
    Samples   : 2048
Obtained audio specification:
    Channels  : 2
    Format    : 0x8010
    Frequency : 48000
    Samples   : 1024
Sound format: 48000Hz, 2 channels, 16 bits per sample
CDAudio_Init: No CD in player.
Can't get initial CD volume
CD Audio Initialized
MQC Build information: xonotic-v0.6.0
ERROR: Texture compression is required but not supported.
Expect visual problems.
Host_Mingled: time stepped forward (went from 0.000000 to 1336124265.766034, difference 1336124265.766034)
ERROR: Texture compression is required but not supported.
Expect visual problems.
ERROR: Texture compression is required but not supported.
Expect visual problems.
Authenticated connection to 87.250.159.246:27000 has been established: server is -@-, I am -@-
Connection accepted to 87.250.159.246:27000
--> client to server keepalive
<-- server to client keepalive

Server: Xonotic build 21:03:37 Mar 20 2012 xonotic-v0.6.0-34-g04e4c71 debug (progs 48433 crc)

<===================================>

greatwall_overloaded by tZork and Cortez
--> client to server keepalive
<-- server to client keepalive
Your csprogs.dat is not the same version as the server (CRC is 65535/0 but should be 47168/1028536)
models/weapons/h_ok_hmg.iqm: could not load texture "overkillbullet"
models/weapons/v_ok_hmg.md3: could not load texture "overkillbullet"
models/weapons/g_ok_hmg.md3: could not load texture "overkillbullet"
FS_OpenVirtualFile("models/ok_player/okrobot1.dpm models/ok_player/okrobot2.dpm models/ok_player/okrobot3.dpm models/ok_player/okrobot4.dpm", false): nasty filename rejected
FS_OpenVirtualFile("models/ok_player/okmale1.dpm models/ok_player/okmale2.dpm models/ok_player/okmale3.dpm models/ok_player/okmale4.dpm", false): nasty filename rejected
FS_OpenVirtualFile("models/ok_player/okrobot1.dpm models/ok_player/okrobot2.dpm models/ok_player/okrobot3.dpm models/ok_player/okrobot4.dpm models/", false): nasty filename rejected
Model models/ok_player/okrobot1.dpm models/ok_player/okrobot2.dpm models/ok_player/okrobot3.dpm models/ok_player/okrobot4.dpm not found
FS_OpenVirtualFile("models/ok_player/okrobot1.dpm models/ok_player/okrobot2.dpm models/ok_player/okrobot3.dpm models/ok_player/okrobot4.dpm", false): nasty filename rejected
Model models/ok_player/okmale1.dpm models/ok_player/okmale2.dpm models/ok_player/okmale3.dpm models/ok_player/okmale4.dpm not found
FS_OpenVirtualFile("models/ok_player/okmale1.dpm models/ok_player/okmale2.dpm models/ok_player/okmale3.dpm models/ok_player/okmale4.dpm", false): nasty filename rejected
Model models/ok_player/okrobot1.dpm models/ok_player/okrobot2.dpm models/ok_player/okrobot3.dpm models/ok_player/okrobot4.dpm models/ not found
FS_OpenVirtualFile("models/ok_player/okrobot1.dpm models/ok_player/okrobot2.dpm models/ok_player/okrobot3.dpm models/ok_player/okrobot4.dpm models/", false): nasty filename rejected
Model models/weapons/g_hmg.md3 not found
]quit

To me it looks like the game doesn't download needed CS progs. But why? Maps are downloading fine! Other servers work well!

I'm using Xonotic 0.6.0 under Linux.
[Image: BSF48.png][Image: HMITP48.png][Image: S48.png][Image: TLT48.png]
Reply

#2
Works fine for me with git... Csprogs got served to me just fine.

I tried testing with authenticated connection as you use, but couldn't get it to work...
EDIT: Works with authed connection as well.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
Check dlcache for something like csprogs.dat.1028536.47168. From what your client reports, that file is most likely empty. Remove/restart/connect.

BTW. Certain clients are unable to properly download csprogs - they stall somewhere near/at file end. Only clue I have is that one client that was unable to download csprogs was going thru desura (could be coincidence)
Reply

#4
(05-04-2012, 02:50 PM)_Subzero_ Wrote: Check dlcache for something like csprogs.dat.1028536.47168. From what your client reports, that file is most likely empty. Remove/restart/connect.

BTW. Certain clients are unable to properly download csprogs - they stall somewhere near/at file end. Only clue I have is that one client that was unable to download csprogs was going thru desura (could be coincidence)

Yup. I had an empty csprogs file in dlcache.
I deleted it and everything's fine now.

Could the game fix this automatically? Simply scan dlcache for empty files and delete them on startup?

Bash would do it like this:
Code:
cd ~/.xonotic/dlcache
find -empty -delete
[Image: BSF48.png][Image: HMITP48.png][Image: S48.png][Image: TLT48.png]
Reply

#5
For maps it's not a problem, the engine discards the file if it's not the right format (so if the archive is corrupt it's discarded as well). Not sure why there are no preventive measures for csprogs. This could be a bug.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#6
I'm not shure it's not a problem. If corrupted pk3 is in dlcache engine will not, I belive, redownload it. So failed download may give black map untill offending file is deleted.
Reply

#7
(05-05-2012, 11:03 AM)_Subzero_ Wrote: I'm not shure it's not a problem. If corrupted pk3 is in dlcache engine will not, I belive, redownload it. So failed download may give black map untill offending file is deleted.

Really? In this other thread, I saw this in the log:
Code:
^7unable to load pak "blablabla/My Games/xonotic/data/dlcache/xonotic-20120308-maps.pk3"
^7Detected non-PAK dlcache/xonotic-20120308-maps.pk3, clearing and NOT resuming.

Maybe it doesn't do that in certain circumstances...
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Server not accessible? ColonelPhantom 2 405 10-03-2017, 05:55 AM
Last Post: ColonelPhantom
  [BUG] Devastator/mortar glitch (0.8.2 client/0.8.1 server) gd 4 778 05-23-2017, 10:40 PM
Last Post: kaadmy
  [NEED HELP] Server Not Showing Up on Server Browser Antares* 5 848 05-21-2017, 04:46 PM
Last Post: martin-t
  [NEEDS INFO] Dedicated server problem. kreestenrx1234 2 905 04-27-2016, 03:30 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] How to ubuntu xonotic server install? Turan 4 1,639 03-17-2016, 08:01 AM
Last Post: Turan
  [SOLVED] turning on spectator chat in duel, and disabling overkill TrackPt 1 1,196 02-12-2015, 02:26 AM
Last Post: Mr. Bougo
  [SOLVED] where are my downloaded map when joining a server? zwz 6 4,130 07-14-2014, 11:59 PM
Last Post: Mr. Bougo
  [SOLVED] Long waiting time when connecting to a server TheGoodGamer 3 2,946 10-20-2013, 07:18 AM
Last Post: TheGoodGamer
  [NEEDS INFO] Server spikes and lag. kidx 2 2,026 08-24-2013, 08:32 AM
Last Post: tZork
  [NEEDS INFO] Server crash report Vargos 21 8,019 04-17-2013, 01:21 PM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-