Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
When I host a game, my friends cannot connect/see it.

#1
Hi everyone,

I introduced Xonotic to two of my friends and I played with one of them online on an already created map/server but then when I proceeded to create my own so that we can all play together (along with bots), everything worked as expected except for the fact that my friends could not connect to my game when I gave them my global IP address. They even checked in the list of servers and couldn’t find my game. I’m running Windows Server 2008 R2 (x64) and I went to Windows Firewall with Advanced Security and enabled inbound/outbound rules to open the 26000 port because based on other create games that seemed to be the port required. I then proceeded to configure my D-Link DI-524 router to enable port forwarding with 26000 as the private and public ports and my private IP address being that of the computer I’m using (my local IP address is static). Dealing with networks is my weakness as far as computers are concerned so I would appreciate it if someone could help me resolve this issue so I can play a customized game suited for my friends and I.

Any help would be greatly appreciated!
Thanks in advance!

P.S.
I am running the server edition of Windows because it runs less services by default and I prefer worrying about enabling services I need than hunting down and disabling services I don’t need. That and I get it for free since I’m a student. I’m also a Debian GNU/Linux user but I haven’t tried this on Debian since I have major audio issues I have to deal with first.
Reply

#2
(05-13-2012, 12:42 AM)s3a Wrote: I’m running Windows

I found the problem!
Reply

#3
Code:
sv_public 1
should show your server in the public list. Can you connect to other (public) servers?

I must admit I didn't read all of your original post Confused
Reply

#4
How do you host the game? "Create" tab or dedicated server? Make sure that sv_public is not set to -2 or smaller.

Also make sure that the port you forwarded in your router was set as UDP or UDP&TCP, not just TCP.

And please read the server log, see if it says it successfully bound 0.0.0.0:26000 or something like that.
Reply

#5
I had the same issue when running on linux. It turned out that my router firewall was preventing them from connecting.

Also, I never did get my server to show up in the server list. I probably did not have my ports forwarded correctly, as Mr. Bougo said. Now I just run my amazon server, or at least I did until my wifi card died :/
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  My friends can't see me on the network.[Xonotic] zoroglur 1 277 10-27-2020, 01:41 PM
Last Post: BuddyFriendGuy
  Game servers in Kazakhstan. Mysyk 4 1,447 07-17-2020, 09:38 AM
Last Post: Mysyk
  [NEED HELP] Server show on the browser list, but I can't connect! Professor 1 1,732 12-19-2018, 11:39 AM
Last Post: Professor
  Local LAN Xonotic game server player Stats animatedjay 3 2,447 11-23-2018, 12:38 AM
Last Post: BuddyFriendGuy
  Why game mode menu is not showing at the end of match? marataziat 1 1,161 08-04-2018, 09:03 AM
Last Post: martin-t
  [NEED HELP] Game types | Tipos de juego [Votable] KyMAN 11 2,474 08-31-2017, 08:08 AM
Last Post: KyMAN
  How to change game to instagib through client? sgtsob 2 3,082 11-01-2016, 12:31 AM
Last Post: sgtsob
  Host custom maps on Google Drive sgtsob 3 2,562 10-27-2016, 12:05 AM
Last Post: sgtsob
  Server won't let more than 1 connect at a time nightspawn9911 7 3,864 08-02-2016, 12:18 AM
Last Post: Mario
  BuddyFriendGuy Pick Up Game (bfgpug) Server BuddyFriendGuy 4 3,361 07-05-2016, 01:02 AM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-