Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Some issues with 0.7.0 server

hi peepZ

first of all - thankies for the new release und your effort ... Big Grin

But found some problems on new release:

1. the spawnsound is not audible - even g_spawnsound is set to 1
2. on old map from nexuiz like evilspace there a a lot of locations where to find ammo - on old 0.6.0 release there are only 2 points
3. the annoucer voice don.t work (27 - three frags for -- 28 two frags for -- or annoucing 3 frags in row -- rage)

Maybe someone can help?

Greetz Su

You're usually a git user, aren't you? Did you notice these issues in git? (specify before and/or after the release)

already done Sir Mr. Bougo Sir ... Big Grin

Take a look at here:

GreetZ Su

Oh, ow. You should have reported that to the development tracker. I missed that thread somehow...

Please make a bug report then.

Done Sir Mr. Bougo Sir ..

GreetZ Su

Thanks! You should have reported the independant bugs in different items though. That should have been three items. I'll file this one as rejected, please make three items Smile

Thanks again for your help, I hope you don't mind.

I never mind ... Tongue Sir Mr. Bougo Sir

Reported 3 item in 3 different bug reports now:

When done anything wrong again please dont kill me Wink

GreetZ Su

You set no category or target version. I fixed that for you.

The map ammo bug needs more details, I asked that in the comment.

Thanks again!

Also, I'm not killing you, you're too helpful for that!

After a rollback to git version from 2013/04/21 everything works fine on server ...

When "downdate" of server was done I was able to hear spawnsounds and annoucer voice - even I use Xonotic 0.7.0 as client.

IMO - For client 0.7.0 works fine - but as server I.ll wait to update the official Prophets Server again to 0.7.0 until my Testserver works in every department to my satisfaction.

GreetZ Su

See my update to the spawn sound issue. Please also see my comment on bug #1668 (the evilspace item one)

according to Samual: it's not a bug it's a feature ...

anyway - I really dont understand why program parts are gonne be changed although they worked well Huh
A lot of players on my servers complained about the lack of the spawnsound/annoucer.

So I will use version v0.6.0-1378-g9494670 furthermore and I.ll see what the future brings new on git releases.

GreetZ Su

It changed because some features get moved from server to client when possible. It's a good thing.

If you want to be able to disable the spawn sound through a server setting, feel free to make a feature request.

Anyway, as we said above git works. You seem to have a problem with your server. Can you reproduce the issue? Did you try to turn off the music to hear better?

Also, as I said above, can you please comment on bug #1668? Otherwise it might get closed.

Mr. Bougo su is not alone i have the same problem too and other players too

Are you running 0.7? Do you get the problem on 0.7 servers or 0.6 servers? Which servers have this problem?

#15 done a update of description of the ammo bug:

GreetZ Su

Thanks. For anyone wondering, that's due to a change of how xonotic handles quake3 entities. Slugs used to be replaced by bullets, and they are now replaced by cells.

Fix the map entities to use proper xonotic entities instead of relying on compatibility, I guess!

last but not least got it ... Big Grin

Followed you advice: created ent files and shiped the maps with the modified ent-files as a new revision.

Thanks for you help and your calmness ...

++++ edit ++++

First marked the thread as solved but than noticed there seems to be more changes/issuses on 0.7.0 server for me:

X-height seemes to be interchanged

For ammo this is not a big deal:

Here the ammo position on 0.6.0 server:
[Image: xonoti13.jpg]

Now ammo position on 0.7.0-1133-g79af1d0 server:
[Image: xonoti14.jpg]

But for other items it becomes very funny:
Here on 0.6.0 server:
[Image: xonoti15.jpg]

Here same config same maps on 0.7.0-1133-g79af1d0 server:
Xonotic now present "Flying Sharks"
[Image: xonoti16.jpg]

the files on treasureisland are not modifiyed by edit .ent file

Makes me lolers =)

For official 0.7.0 version it works on treasureisland =)

+++ Created bug report: +++

GreetZ Su

Possibly Related Threads…
Thread Author Replies Views Last Post
  I can't see my listen server on server list fnmain 1 877 10-07-2023, 07:28 AM
Last Post: Grimnack
  Server not visible on the server browser for others or me DankoLord 1 1,972 02-21-2023, 08:02 PM
Last Post: ballerburg9005
  A certain server seems to manipulate stats of it's players by not listing some games nj 7 3,438 08-14-2022, 02:48 AM
Last Post: FAF
  BaI server | South American Xonotic server (located in Chile) z411 0 2,894 01-02-2022, 11:36 PM
Last Post: z411
  Full server tutorial start-2-finish with maps & config from live server ballerburg9005 0 9,368 09-03-2021, 10:21 AM
Last Post: ballerburg9005
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 5,277 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  Some players have black textures ted 6 3,300 05-28-2020, 03:48 AM
Last Post: ted
  [NEED HELP] Server dont appear in server browser abslimit 0 2,707 03-15-2020, 04:13 AM
Last Post: abslimit
  How to change server cfg on modified server veecho 4 4,644 04-24-2019, 08:15 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Xonotic Server crashes TF2 server Professor 2 3,105 02-20-2018, 07:50 PM
Last Post: Professor

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-