Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Missing shader previews / lack of authoritative Netradiant help

#1
Hi,

I've been trying to use Netradiant but I've come to a dead end. Netradiant correctly loads all the Xonotic assets except for the texture previews, so even though I can place existing textures, everything just shows up as "shader image missing". So, I can texture the entire map with a single texture but I have no idea what it looks like ingame.

If it helps, I've downloaded the Xonotic mapping support files, but I have no idea where to put them or what to do after that (I'm using Ubuntu). I've tried looking for help online, but all I got were several sources of conflicting information scattered throughout the Web.

Would it be possible to have a central, authoritative wiki for how to set up use Netradiant? This would be a tremendous help for newbies like me, and also for people looking to try out something they've never implemented before, and it would make troubleshooting a whole lot easier.
Reply

#2
I'm sorry that I myself can't assist you in this, but Justin has posted something that may be useful for you, even though it's for NetRadiant under Windows:

http://forums.xonotic.org/showthread.php...0#pid61760

I agree we'd need a dedicated place for information around NetRadiant. You can also check out #xonotic.editing on quakenet IRC, you'll find people there that know stuff about mapping.
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply

#3
In linux, you have to place the pk3 (having it unpacked there will do as well) in to /home/#yourusername#/.xonotic/data
[Image: 0_e8735_c58a251e_orig]
Reply

#4
aa, that's .xonotic/data/
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#5
Sorry, that was a typo.
[Image: 0_e8735_c58a251e_orig]
Reply

#6
Thanks! It's working fine now.

Also, about the dedicated place for Netradiant info: I found these wikis. They have some useful information, but they could be even better if they were finished (a couple of chapters in the Xonotic one are red placeholder 404 links)
Reply

#7
FYI: that link you posted is a file:// link to a local file on your computer. Only you can access that.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 388 08-18-2019, 10:11 PM
Last Post: Lyberta
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 320 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 408 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 607 03-29-2019, 11:19 AM
Last Post: Freddy
  [NEED HELP] Netradiant compiling? Raxno 2 1,368 11-11-2017, 04:50 AM
Last Post: It'sMe
  [SOLVED] NetRadiant crashing (Xonotic 0.8.2, NR 1.5.0-20120301) munyul 2 1,615 07-09-2017, 11:21 AM
Last Post: munyul
  [NEED HELP] video glitches in netradiant on windows 10 fabzor3 2 1,120 05-26-2017, 02:09 AM
Last Post: PinkRobot
  [SOLVED] Mortar model missing Dr. Midget 12 2,050 05-01-2017, 09:16 AM
Last Post: Lyberta
  [SOLVED] NetRadiant crash "Got to split the buffer" PinkRobot 7 2,594 08-27-2016, 06:16 AM
Last Post: PinkRobot
  [NEED HELP] Netradiant Xonotic support version BuddyFriendGuy 0 1,512 04-27-2016, 04:36 PM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-