Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Input lag?

#1
I turned off Vsync and tripple buffering, but there's still a bit of input lag.
The mouse and chat work fine, but when I fire a weapon, it always happens a bit later. Is it supposed to be like that? in pretty much all games it happens a tiny bit later(depends on the game tough, many games feel instant while they technicly aren't.), but in this game it feels like too much.
Reply

#2
I suppose you dont use a variety of different wireless devices?
How to Englich?
Reply

#3
Just to make sure, do you have such lags in local matches (singleplayer mode?)
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#4
Local and online, it's not related to ping.
Reply

#5
doing:

seta cl_netrepeatinput 0

may help, otherwise it'll be some sort of software/hardware issue.
[Image: 12766.png]
Sucks at weapons
Reply

#6
(10-18-2013, 01:09 PM)cvcxc Wrote: I suppose you dont use a variety of different wireless devices?

No, I use wired devices(and connection), 2 ms monitor, 500 polling rate for my mouse (or 1000 depending on what I pick in the software).
THe input lag is a lot like when you play a game on an emulator. It's always higher than the original console. However, with PC games it's ususally pretty much instant(I say that because there's no way to have 0 input lag).

cl_netrepeatinput 0, I'm not sure if this does anything. Also, when I go into singleplayer and a lot of stuff/people is on the screen(I'm playing on ultra without post processing and motion blur) My FPS drops a lot. my fps ususally also drops when I die. When I just fight a few people my FPS is very high.
I have an intel core i5 750 and a nvidia gtx 560 TI. It works fine with games that look a lot better than Xonotic, so it kinda confuses me. Ofcourse my PC can't handle most new games at a steady 60 fps on even lower settings, but why doesn't Xonotic work as well as, let's say, Unreal Tournament 3? Sad. I guess it's just because it's a small indie game, so it's less optimized? That would make sense, since UT3 is an AAA title that probably even got Nvidia Driver updates.
Reply

#7
Its possible your overtaxing your hardware with 1000hz poll (some drivers are really teribad), try lowering it and see if i helps.

Try the SDL binary if you haven't already; it uses different input handling.

Try the game from a different computer

Xonotic has lower performance than multi million AAA games since it dont have the best of the best to work flat out on optimizing it but rather a bunch of ppl doing what they can on their spare time. Deal with it Wink
Reply

#8
So the input lag dissapears if you lower the graphic settings?
How to Englich?
Reply

#9
No idea, depends on why its happening. How about you try it? Tongue
Reply

#10
(10-19-2013, 04:11 AM)tZork Wrote: Its possible your overtaxing your hardware with 1000hz poll (some drivers are really teribad), try lowering it and see if i helps.

Try the SDL binary if you haven't already; it uses different input handling.

Try the game from a different computer

Xonotic has lower performance than multi million AAA games since it dont have the best of the best to work flat out on optimizing it but rather a bunch of ppl doing what they can on their spare time. Deal with it Wink

Thought so, I'm not gonna complain about it than, might aswell just play on lower settings than.

I use 500 polling rate for that reason.
I'm going to try my old PC soon and see what happens Tongue.
Reply

#11
(10-20-2013, 06:54 AM)dylstew Wrote: I'm going to try my old PC soon and see what happens Tongue.

Curious to know if this worked? I also seem to have mouse lag, where by I always end up struggling to fire repeated shots in quick succession.
Reply

#12
(10-03-2016, 02:48 PM)jebus501 Wrote: Curious to know if this worked? I also seem to have mouse lag, where by I always end up struggling to fire repeated shots in quick succession.

That doesn't sound like a mouse lag -- it's probably network lag. All your queued actions are cleared all at once.

Does your keyboard have such lags too?
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 232 08-18-2019, 03:14 AM
Last Post: FAF
  [SOLVED] Random failures to register mouse input Halogene 2 1,114 06-15-2017, 01:04 PM
Last Post: Halogene
  [NEED HELP] Strange input lag and graphics lag in 0.8.2 mrdoklata 3 2,502 04-21-2017, 11:00 PM
Last Post: -z-

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-