Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] [Solved]How to install or runn Xonotic

So .. Hallo .. for one week i have changed (i never used something else as windows) my Windows to Ubuntu , so I am pretty new in Ubuntu, i know already something but not much .
My problem is now how to launch game Xonotic ..
I downloaded Xonotic , unpacket the game in to :
my problem is ... i do not know what to do now ....
If i launch xonotic-linux32-glx i get a message : something like i have to setup the basedir of game to the patch of my game data ...i do not know where to look ...
I dont even know if i have to install this game , but if i try :
sudo apt-get install Xonotic ... i receave message that the package was not found ...
I also found a file named Makefile where inside is :
PREFIX ?= /usr/local
LIBDIR ?= $(PREFIX)/lib/xonotic
DOCDIR ?= $(PREFIX)/share/doc/xonotic
Do i need edit this file ? I mean DESTDIR ... ?

So please help me if someone knows what to do.
And if you have tips for the future i would be glad to reed them ...
Thank you for helping me...

Can you try running it from a terminal? Open a terminal, navigate to the folder ("cd Games/Xonotic") and launch the appropriate executable then from there (do "./"). I think it has a ".sh" ending? Note that you can use the <TAB> key to autocomplete commands, if there are multiple completions possible, hit it twice to see the possibilities.

I think what you did is that you executed the script from a file manager? It might be that it doesn't get a proper basedir assigned then. When not launching it from terminal from within the folder, you might have to provide the basedir with the command, if I remember correctly. If you generate yourself a starter for your menu, you can enter the basedir for the skript somewhere there (which would be ~/Games/Xonotic in your case).

By the way, for some people the sdl version works better, but that has nothing to do with the error you encountered. You can try to do "./" to test it.

As for tips for the future, check out the Newbie Corner :o)
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


That was the second thing I did, i mean command line , but both ways are the same ... Filemanager and command line ...
I tried also copy the xonotic-linux32-glx/ in to few directories because binary executed data using their own directory as data source, after run the was the same error... basedir setup needet... ... as i have understand after reading a few posts...
If U have any other idea what can I do.. please tell me..

You might need to install libz: sudo apt-get install zlib1g
Can't confirm that this will work on a release, as I usually use Git when on Linux, which requires this library to be installed.

Also, the shell scripts should be in the Xonotic folder, along with the binaries (xonotic-linux32-glx/sdl).
If it still fails, could you post the console log? Open the console (shift+esc) and type this: condump crash.log
Then upload the contents of ~/.xonotic/data/crash.log to PasteBin or something (the .xonotic folder is hidden in your home directory, so you'll need to hold CTRL & press H to show it).
[Image: 230.png]

The command I use to open xonotic is ~/Xonotic/xonotic-linux64-glx -basedir ~/Xonotic

the zlib1g is the newest version already ...
Abouth the crash log .. i am not able to enter the console kz my system make a crash everytime i try enter the console and the only way to return to ubuntu is restart .. I did a little video what happends to me when i start the shel ... take a look i thing something is wrong with my Ubuntu 14.4. ....
and aboth the hiden folder... there is nothing about xonotic .. no hiden folder .. no other folder... only thing i have is ~/games/xonotic ....
i did not install it ... i dont know how to install it... that is why i dont have any hiden folders from xonotic ... at least i thing so...

From your video I can see you launch the game from within your home folder with "~/Games/Xonotic/...". As I suggested in my first reply, please navigate to the Xonotic folder with "cd Games/Xonotic" and THEN issue "./xonotic-linux32-glx" . Can you try that please?

If you're not issuing the command from within the folder, you will have to specify the basedir with the -basedir option, so you can alternatively try to execute from your home folder "Games/Xonotic/xonotic-linux64-glx -basedir ~/Xonotic"
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


So , i did it as you wrote Halogene ..... but i still can not access the console...i tryd something to write but my system crasched again... here is next video...

And one thing what can i provide is photo of console .. see attachement

Attached Files Thumbnail(s)

If you execute the binary (not using the shell script). You need to change into the game's basedir before.

Because the engine expects your current working directory is the basedir.

cd ~/Games/Xonotic; ./xonotic-linux64-sdl

Or you pass the basedir as argument for the binary (This is what Beagle suggests)

~/Games/Xonotic/xonotic-linux64-sdl -basedir ~/Games/Xonotic

However the easiest way is if you use the shell scripts.


If you take a look at the first lines, you will notice it changes the directory before calling the binary (next to other things).

3 path=`dirname "${0}"`
  4 link=`readlink -f "${0}"`
  6 [ -n "${link}" ] && path=`dirname "${link}"`
  7 cd "${path}"

However your issue seems to be that the extracted game files are not complete.

data/xonotic-20150825-data.pk3 is not a PK3 file
unable to load pak "data/xonotic-20150825-data.pk3"

The easiest and probably fastest way is to sync your game via the provided rsync script.


Please run this script.

Otherwise verify if the provided md5sum matches your downloaded zip file and re-extract the game.

The command
apt-get install xonotic
fails, because xonotic is not included in Ubuntu's repositories.

To add Xonotic to your Dash (Ubuntu's start menu) you can add a xonotic.desktop in ~/.local/share/applications/.


[Desktop Entry]                                                                                        
Comment=The Free and Fast Arena Shooter

SO that was my problem .. my data was not complete or corrupted .....
To update the data was a great idea ...i had no knowledge about this function , very goood..
So I used first :

And then i just did run the game as i already did but it was not working.. now works fine... THX Big Grin
Thank you all for your time and sharing your knowledge with me..
In fact .. thank you all .
Big GrinBig GrinBig GrinBig GrinBig Grin

Nice, glad you got it sorted out.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Need old rifle model(solved) Kotangens 8 3,318 08-27-2020, 01:42 AM
Last Post: Kotangens
Question [NEED HELP] How to create warpzones? (solved) Kotangens 10 4,869 08-19-2020, 07:05 AM
Last Post: Kotangens
Question [NEED HELP] How to use textures for radiant(win version)? (solved) Kotangens 4 3,055 08-12-2020, 01:33 AM
Last Post: Kotangens
Question [NEED HELP] can't build netradiant (SOLVED) bananovenc 7 4,654 12-25-2019, 03:34 PM
Last Post: illwieckz
  [NEEDS INFO] Linux install Old_Geekdad 7 4,684 01-16-2019, 06:03 PM
Last Post: Zoommair
Bug [SOLVED] troubleshooting how to install maps Eonman 2 4,634 03-06-2017, 10:14 PM
Last Post: -z-
  [NEEDS INFO] How to ubuntu xonotic server install? Turan 4 5,490 03-17-2016, 08:01 AM
Last Post: Turan
  [SOLVED] Ubuntu 12.04 Install Issue Red Viper 6 8,086 03-08-2014, 03:20 AM
Last Post: Halogene
  [SOLVED] [Solved] Not appearing on XonStat medimatrix 8 7,561 08-14-2013, 07:39 AM
Last Post: Antibody
  [SOLVED] help how to install maps Alex 5 7,626 03-11-2013, 05:07 PM
Last Post: Mr. Bougo

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-