Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Forum Upgrades

#1
Star 
Hey guys, -z- here, trying to establish clearly lines of communication, and be held more accountable for timely upgrades to the forums.

I would love to enhance the forums anyway I can, I don't always have time, but I promise to prioritize security patches, and major useability bugs.

I would love to help on new features, enhancements, small bugs.  If you can provide me with a patch, or meet me halfway on a solution, I can guarantee a faster result.

Use this thread as an opportunity to report any bugs, or request features!

If you prefer, find me on IRC #xonotic on freenode/quakenet.

If you have a gitlab account, the issues that are more complex should be captured here: https://gitlab.com/detrate/xonotic-mybb/issues


NEWS

02-03-2018

Added a responsive theme to the forums, select "NetPen" in the theme chooser in the footer, or in your profile.


01-31-2018

Upgraded with the latest security patches, fixed some user reported bugs (thanks guys!), re-purposed this thread.


03-03-2017

The forums look different today, the reason for that is we've upgraded! We're now using the latest version of MyBB, 1.8.10.

The new theme, revoxono, has overcome many of the issues we had with the old theme.  However, nothing is perfect, we expect you to find bugs, or miss features from the old theme.

We're planning on rolling out a few more changes over the next few weeks, stay tuned.

Big shout out to everyone on the team that helped make this upgrade as smooth as possible.
Reply

#2
Thanks so much for taking this on. The new theme looks slick!
asyyy^ | are you releated to chuck norris?
Reply

#3
Few small issues with the new theme that I'm seeing:

1. No link to "View Today's Posts" ( http://forums.xonotic.org/search.php?action=getdaily ) or "View New Posts" ( http://forums.xonotic.org/search.php?action=getnew ). They're both there in the default theme (Blue with white background), and were there in the old theme. I find them useful to keep up to date.

2. Hover the mouse over the little user panel on the bottom right of the new banner image (has your name & "Messages", and then move your pointer down over the menu that comes up. Unless you move over the tiny little grey piece that joins the text of the button to the rest of the box, the box tries (usually successfully) to vanish. Makes it annoying to access. The menu is also pushed right to match the start of the username, when it should probably be pushed left to align the right side of the menu with the right side of the username. Otherwise the menus end up on top of each other if you're too fast flicking between them.
[Image: 21975.png]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams
Reply

#4
cefiar: Good catch!

With your second point, we thought indeed that those dropdowns were a bit wonky, but somehow I had missed the flickering / disappearing problem that you mention. I think we wanted to replace those dropdowns with something based on css animations anyway.

As a quick fix to the disappearing menu problem, I decreased the margins of .dropdown-menu in dropdowns.css from "margin: 2px 0 0;" to "margin: 0 0 0;". Flickering between the two menus remains for now, because fixing the alignment would require more changes to the theme than I am comfortable with, considering [-z-] is the one who takes care of the theme.

For the first issue you mention, I'm hopeful [-z-] will look into that. Those are changes that should be made upstream (on the theme this one is based on) ideally, but I don't know how open to bug reports their theme developer is. We can probably fix it on our version in any case.



Here's a theme bug report from me: the right sidebar on the front page lists "latest activity". On wide screens, the items listed there don't take the full width of the latest activity box, so there is empty space on the right. I couldn't find a max-width strangely enough, so I don't know where this comes from.

EDIT: Ah, I understand now. It's not the theme limiting these! The titles of the threads are trimmed in the html itself. Still looks a bit strange.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#5
Consequential.
Reply

#6
As moderator there is this custom tool to move threads straight to "The Spam Hole". If I want to use it, it says I don't have permission to do so. However I can move a thread with the "Move thread"-tool.

Also (if possible) I think that anything from Whackity Wicktown and beyond should not show up in the "Latest activity" box

Edit: It seems that the upgrade does now like " in the custom user title Tongue It's supposed to be: "Big Grin"
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#7
(03-04-2017, 03:20 AM)Mr. Bougo Wrote: cefiar: Good catch!

With your second point, we thought indeed that those dropdowns were a bit wonky, but somehow I had missed the flickering / disappearing problem that you mention. I think we wanted to replace those dropdowns with something based on css animations anyway.

As a quick fix to the disappearing menu problem, I decreased the margins of .dropdown-menu in dropdowns.css from "margin: 2px 0 0;" to "margin: 0 0 0;". Flickering between the two menus remains for now, because fixing the alignment would require more changes to the theme than I am comfortable with, considering [-z-] is the one who takes care of the theme.

For the first issue you mention, I'm hopeful [-z-] will look into that. Those are changes that should be made upstream (on the theme this one is based on) ideally, but I don't know how open to bug reports their theme developer is. We can probably fix it on our version in any case.

Removing that margin definitely makes it much better for issue #2.

As an aside, I'd be happy if the links for issue #1 were in that user menu (the one under the user name). IMO it'd be a nice way to stop them cluttering up the rest of the user interface, and the "new posts" one is very user specific anyway.
[Image: 21975.png]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams
Reply

#8
1337 hours ago


Another minor issue: the post's time looks like it's a part of the message.
Also, the font size button doesn't represent the final post's text size.
[Image: 230.png]
Reply

#9
The home button takes the user to a special view of Xonotic - News instead of the main page.

A minor inconsistency: the username and Messages dropdowns expand automatically but Extras needs to be clicked.
[Image: 30381.png]
Reply

#10
Thanks for the bug reports guys! I've ironed out most of those already.

TODO: Make view new posts and today's posts more prominent
TODO: Investigate font-size discrepancy
TODO: drop-downs all CSS

Also, the "View Recent Posts" and "View New Posts" appear under the "Extras" menu in the top.

Is there another location ya'll would prefer it?

Lastly, if you have a gitlab account, the issues that are more complex will be captured here: https://gitlab.com/detrate/xonotic-mybb/issues
Reply

#11
Looks great!
Reply

#12
(03-04-2017, 06:37 AM)Mirio Wrote: As moderator there is this custom tool to move threads straight to "The Spam Hole". If I want to use it, it says I don't have permission to do so. However I can move a thread with the "Move thread"-tool.

Also (if possible) I think that anything from Whackity Wicktown and beyond should not show up in the "Latest activity" box

Edit: It seems that the upgrade does now like " in the custom user title Tongue It's supposed to be: "Big Grin"
That mod tool is supposed to work, I can't find a reason why it shouldn't. Do you have any more details in the error message?

As for user titles, that's weird indeed. Probably a MyBB bug. Reported it in our personal tracker but we'll probably submit it upstream.

EDIT: I just checked, quotes don't show up weird when you set your user title under this new version. Try resetting it, it should work ok.

(03-04-2017, 08:55 AM)martin-t Wrote: The home button takes the user to a special view of Xonotic - News instead of the main page.

A minor inconsistency: the username and Messages dropdowns expand automatically but Extras needs to be clicked.
What extras are you referring to? In the navigation bar at the very top? For me it pops up on hover.

(03-04-2017, 06:58 AM)Mario Wrote: 1337 hours ago


Another minor issue: the post's time looks like it's a part of the message.
Also, the font size button doesn't represent the final post's text size.
The horizontal rule that separates message header and body, and message body and signature, is indeed not contrasty enough. I bet that's an easy fix.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#13
(03-04-2017, 10:56 AM)Mr. Bougo Wrote:
(03-04-2017, 08:55 AM)martin-t Wrote: The home button takes the user to a special view of Xonotic - News instead of the main page.

A minor inconsistency: the username and Messages dropdowns expand automatically but Extras needs to be clicked.
What extras are you referring to? In the navigation bar at the very top? For me it pops up on hover.

I patched it already Wink

(03-04-2017, 10:56 AM)Mr. Bougo Wrote:
(03-04-2017, 06:58 AM)Mario Wrote: 1337 hours ago


Another minor issue: the post's time looks like it's a part of the message.
Also, the font size button doesn't represent the final post's text size.
The horizontal rule that separates message header and body, and message body and signature, is indeed not contrasty enough. I bet that's an easy fix.

Actually that was my improvement, but I can increase the contrast in these.
Reply

#14
@Mirio: the mod tool should be fixed. Note also that we now have a spam hole post tool: you can select posts and this tool will split them into a new thread that will move into the spam hole (see "Inline post moderation" drop-down). Enjoy!
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#15
(03-04-2017, 12:44 PM)Mr. Bougo Wrote: @Mirio: the mod tool should be fixed. Note also that we now have a spam hole post tool: you can select posts and this tool will split them into a new thread that will move into the spam hole (see "Inline post moderation" drop-down). Enjoy!

Is that "Soft Delete Posts" or how is it called?
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#16
Nice update guys, looks quite shiny and fits the main website theme slightly better.

One thing i don't like however is the user info being located to the left of the message rather than in line with the messages. It makes it harder to keep track of who is posting what, as you need to specificly look for the users name rather than being able to read a linear continuous stream. Also i think it makes some untidy arrangements sometimes:

Also i cant seem to be able to add an attachment. I get

Quote:Please correct the following errors before continuing:
  • The file upload failed. Please choose a valid file and try again.
 when trying to attach a .jpg
[Image: 0_e8735_c58a251e_orig]
Reply

#17

.jpg   xon-logo-sxb.jpg (Size: 154.47 KB / Downloads: 238)

I was able to insert the above attachment. Can you try again so I can see if that was in error?

As for the user info being separate from the content, I understand the complaint, but that's more of an opinion. That being said, there is an issue to revisit that part of the theme, so it could end up looking different: https://gitlab.com/detrate/xonotic-mybb/issues/1
Reply

#18
nice and fresh!!

Good work guys!

kwakkie
[Image: 39855.png]
Reply

#19
(03-04-2017, 03:02 PM)kwakkiezalf Wrote: nice and fresh!!

Good work guys!

kwakkie

Thanks kwakkie, haven't forgotten about the LMNT maps btw, they are still on deck, just have to wrap up some changes with the xmr-api first.
Reply

#20
(03-04-2017, 01:19 PM)Mirio Wrote:
(03-04-2017, 12:44 PM)Mr. Bougo Wrote: @Mirio: the mod tool should be fixed. Note also that we now have a spam hole post tool: you can select posts and this tool will split them into a new thread that will move into the spam hole (see "Inline post moderation" drop-down). Enjoy!

Is that "Soft Delete Posts" or how is it called?

No. It's in the menu that contains "soft delete posts", but the menu item is called "to spam hole". I think I'll rename to "split and move to spam hole"
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#21
(03-04-2017, 10:10 AM)-z- Wrote: Also, the "View Recent Posts" and "View New Posts" appear under the "Extras" menu in the top.

Is there another location ya'll would prefer it?

That'll do me. Main thing is, it's available!
[Image: 21975.png]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams
Reply

#22
w00t!
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#23
(03-04-2017, 04:37 PM)cefiar Wrote:
(03-04-2017, 10:10 AM)-z- Wrote: Also, the "View Recent Posts" and "View New Posts" appear under the "Extras" menu in the top.

Is there another location ya'll would prefer it?

That'll do me. Main thing is, it's available!

Thanks cefiar!

(03-04-2017, 05:18 PM)CuBe0wL Wrote: w00t!

hey CuBe0wL, happy to see you! Hope all is good man! miss you Smile
Reply

#24
When I delete a post, the post slides up like a drawer (nice effect), but the buttons for deletion/etc remain (of course, clicking delete post again causes an error), along with the posted time, as if the post is still kinda there.
[Image: 230.png]
Reply

#25
I tested Mario's bug. The default action for the "Delete" button is to soft-delete a post, indeed. However the "delete" button is then supposed to disappear and be replaced with a "restore" button; this is how the Default 1.8 theme behaves. In addition there is no sliding up of the post, but rather the background of the post becomes purple-colored. When the page is refreshed, the post appears as collapsed, and can be opened back into the purple-background appearance, and possibly restored. Permanent deletion is achieved through selecting the post and picking "Delete Posts Permanently" in the inline post moderation at the bottom of the page.

So what Mario noticed there with the post deletion is another theme bug.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Exclamation Forum update discussion (Was: Forum down time April 6th) Antibody 75 46,455 01-10-2013, 02:18 AM
Last Post: -maniac|Su-
  Forum downtime today Mr. Bougo 9 6,182 04-13-2012, 12:30 PM
Last Post: rocknroll237
Information New restrictions upon forum signatures Samual 21 12,947 10-26-2011, 02:59 PM
Last Post: Samual

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-