Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] When in game, the guns keep firing, sometimes doesn't fire when pointed at a target.

#1
Photo 
Hi, I have been playing Quake series as long as I can remember and XONOTIC is like the best thing ever happened (much much better than Quake live). I have been playing XONOTIC for years (only local, bad internet connection).

Recently I have been having some issues:

1. When in game the gun (any) keeps firing continuously even if I am not pressing the fire button.
2. When I point at a target and press fire it doesn't fire, press again- nope, again -nope. No I am not quickly firing without giving time for reload.
3. When running at a lower resolution (@720) than my desktop (@1080) moving the mouse to extreme right or extreme down "moves" the game display to the opposite direction revealing the desktop! Or just goes completely weird : please see the attachments.




I think you can understand the frustration when you can't properly shoot in a shooting game! Rolleyes  PLEASE HELP ME! Shy


Attached Files Thumbnail(s)
       
Reply

#2
According to your screenshots, you use KDE.
I had the exact same problems a few weeks ago Smile

There used to be a bug in Plasma that affect fullscreen games, but it should be fixed in Plasma 5.10.3. What Plasma version do you use?
Relevant KDE bug report: https://bugs.kde.org/show_bug.cgi?id=380476

As a workaround, you can disable the left touchscreen action (System Configuration -> Workspace behavior -> Touchscreen -> uncheck the left action).
You can also disable Screen Edges actions in order to fix your issue with lower resolutions.
Reply

#3
(09-07-2017, 06:51 AM)SpiKe Wrote: According to your screenshots, you use KDE.
I had the exact same problems a few weeks ago Smile

There used to be a bug in Plasma that affect fullscreen games, but it should be fixed in Plasma 5.10.3. What Plasma version do you use?
Relevant KDE bug report: https://bugs.kde.org/show_bug.cgi?id=380476

As a workaround, you can disable the left touchscreen action (System Configuration -> Workspace behavior -> Touchscreen -> uncheck the left action).
You can also disable Screen Edges actions in order to fix your issue with lower resolutions.

My Plasma version is 5.10.5 and I made the changes you suggested still the same issues!
Reply

#4
Make sure you have "Allow applications to block compositing" checked on System Settings -> Screen and Display -> Compositor.

If compositing is on while you play Xonotic, it may also cause issues.
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] cl_gunalign doesn't seem to work on some servers/maps Aguaumreal 2 2,660 09-10-2019, 03:42 AM
Last Post: Aguaumreal
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 2,914 03-29-2019, 11:19 AM
Last Post: Freddy
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 2,263 02-17-2019, 02:10 AM
Last Post: martin-t
  [NEED HELP] XUbuntu playing with drivers and now Xonotic doesn't start Bla1 9 6,430 05-15-2018, 09:29 PM
Last Post: Bla1
  [SOLVED] Can't respawn sometimes gd 6 4,240 12-09-2016, 09:53 AM
Last Post: Smilecythe
  [SOLVED] Xonotic doesn't work with overwolf Ch4mp 2 3,774 08-12-2016, 02:44 AM
Last Post: Ch4mp
  [SOLVED] Minstagib Alt Fire Repeating Problem ZxEfR 11 9,155 02-17-2014, 02:34 PM
Last Post: Mr. Bougo
  [NEEDS INFO] Map doesn't compile machine! 12 11,064 06-27-2013, 08:49 AM
Last Post: machine!
  [SOLVED] Sound doesn't work machine! 13 16,287 02-17-2013, 09:31 AM
Last Post: Mr. Bougo
  [NEEDS INFO] Failing to fallback when a shader doesn't compile edh 0 2,534 12-17-2012, 05:44 PM
Last Post: edh

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-