Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Minstagib Alt Fire Repeating Problem

#1
Whenever I play a local minstagib game the alt fire repeates automatically insanely fast and boosts me crazy high/fast. I've tried everything I can think of to stop it to no avail.

I have tried deleting my custom config.cfg file and starting the game with a new/default file and that didn't fix it. I'm guessing it's a bug in the game at this point?

I mostly play online, where the problem doesn't occur so it's not a huge deal but it'd be nice if I could get it fixed.

I'm running 0.7.0 on Linux Mint 16

Thanks
Reply

#2
This shouldn't happen with a default balance AFAIK, the cvar needed to fix it would be g_balance_laser_primary_refire.
[Image: 230.png]
Reply

#3
g_balance_laser_primary_refire is at the default of 0.7

I changed it to several different numbers without any affect.

I changed g_balance_laser_primary_force to 0 to make sure I was able to affect some kind of change and it made it so it wouldn't lift me off the ground at all. So I know that works.
Reply

#4
Can you try with another version of Xonotic, either 0.6 or autobuild (or maybe both)? Also, you already said hat you removed your config.cfg, but please rename your Xonotic folder to start with a completely fresh install, and see if the problem remains.

Do I understand this correctly that it only happens in local matches, but not on servers??
[Image: 9216.png] Web: YouTubeSoundCloudFlickrzykure.de[unconnected]
IRC: #uc.xonotic #xonotic #xonotic.de #xonotic.pickup
Reply

#5
Alright I finally had a chance to work on it a bit more. Sorry for the delay.

I have fixed the problem although still not quite sure what is causing it other than it has something to do with my config.cfg file.

I tried your suggestion zykure about starting fresh completely and the problem did not occur. I put my custom config.cfg file back in and it would start doing it again. I then tried just removing my config.cfg file and generating a fresh and it would still do it unless I restarted fresh all over again. I haven't had enough time to mess with it to try to narrow it down yet though not even sure I can.

So for now I'm just going to use a new custom config.cfg file with a fresh "install" and I should be good to go.

Thanks for your help fella's....now onto try to fix another strange problem I'm having where when I'm swinging on the grapple below any buildings it goes into super slow motion until I get real close to the bottom of the buildings where it resumes normal speed.

If I ever get the repeating problem narrowed down I'll add to the thread here what it was.
Reply

#6
Okay nice, glad to hear it worked out! It will be interesting to see what the actual problem was in the end, I suspect some weird .pk3 or something Wink

About the grapple issue: no idea, sorry. I don't play with hook at all...
[Image: 9216.png] Web: YouTubeSoundCloudFlickrzykure.de[unconnected]
IRC: #uc.xonotic #xonotic #xonotic.de #xonotic.pickup
Reply

#7
zykure you were right!

It was a .pk3 named zzzoverkill-61158e4.pk3

I'm new-ish to Xonotic so I didn't know a .pk3 could do that...so now I do!

It was also the cause of my other slow motion problem when dangling with the grapple.

Thanks!!! Big Grin
Reply

#8
Heh. I wonder what's in there that caused the issue... Do you still have the file?
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#9
Yes I do still have it. I was hoping someone who knows what they're doing would want to look at it.


.pk3   zzzoverkill-61158e4.pk3 (Size: 6.1 MB / Downloads: 2)
Reply

#10
Haha wow, it was just a wild guess .. nice Big Grin

About the .pk3 in general: The way it works is that all .pk3 files in the Xonotic directory are read in, in alphabetical order. If contents are duplicated, only the last file will be used. That means that if a "later" archive contains a file which was read before, it will use only the last one. This opens the possibility to make modifications without touching any of the original .pk3 files - just put your changed file into a new .pk3 (or a "xyz.pk3dir" subdirectory), and the game will use the new file. That is, by the way, the reason why your pk3 begins with "zzz" =)
[Image: 9216.png] Web: YouTubeSoundCloudFlickrzykure.de[unconnected]
IRC: #uc.xonotic #xonotic #xonotic.de #xonotic.pickup
Reply

#11
Ah....great info...thank you!
Reply

#12
Ah, it contains replacements for balance configs. It's a funny idea to give them the same name. Or to even include any cfgs at all, actually.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Windows 10 -basedir problem BlazedRasta 2 709 06-13-2019, 05:12 AM
Last Post: martin-t
  Chat key bind problem BuddyFriendGuy 4 698 01-26-2019, 11:12 PM
Last Post: BuddyFriendGuy
Photo [NEED HELP] When in game, the guns keep firing, sometimes doesn't fire when pointed at a target. U1Y5Y5 3 1,241 09-12-2017, 01:28 PM
Last Post: SpiKe
  [NEEDS INFO] Dedicated server problem. kreestenrx1234 2 1,443 04-27-2016, 03:30 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Player model problem hysik 2 1,905 12-15-2015, 11:35 AM
Last Post: hysik
  [NEEDS INFO] Invisible MinstaGib Model Beagle 5 3,040 06-21-2015, 07:49 PM
Last Post: Beagle
  [SOLVED] Problem with NetRadiant - shadertags.xml. No tag support. tobster 23 18,805 03-29-2015, 07:58 PM
Last Post: BuddyFriendGuy
  [SOLVED] Problem with screen being too large and off center. Cow_Fu 2 2,602 03-11-2015, 02:14 PM
Last Post: Ishatix
  [SOLVED] Xonotic Autobuild problem, August 14, 2013 __Ham__ 13 7,297 10-06-2014, 07:35 PM
Last Post: Lee_Stricklin
  [NEED HELP] GUI Mouse Problem with GLX Slackhead 2 2,322 08-31-2014, 04:22 AM
Last Post: Slackhead

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-